aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2003-06-15 05:53:02 +0000
committerGreg Lewis <glewis@FreeBSD.org>2003-06-15 05:53:02 +0000
commitfae59e03a34c463003dcb3dc626550a18901e368 (patch)
treef6333f8dd09bbfca449f6fef56d4f4e14ff3e477 /java
parentde2d4c3c360be78d79cc1c49fdcdf101f7b5969d (diff)
downloadports-fae59e03a34c463003dcb3dc626550a18901e368.tar.gz
ports-fae59e03a34c463003dcb3dc626550a18901e368.zip
. Reorder the check for the source and patchset so that the failure
messages are produced in the order that they were intended.
Notes
Notes: svn path=/head/; revision=83000
Diffstat (limited to 'java')
-rw-r--r--java/jdk12/Makefile22
-rw-r--r--java/jdk13/Makefile22
2 files changed, 22 insertions, 22 deletions
diff --git a/java/jdk12/Makefile b/java/jdk12/Makefile
index a11dc38e3d5a..5def629433c3 100644
--- a/java/jdk12/Makefile
+++ b/java/jdk12/Makefile
@@ -76,6 +76,17 @@ PLIST_SUB+= DEBUG:=""
.include <bsd.port.pre.mk>
+# Check for patchset
+.if !exists(${DISTDIR}/${PATCHSETFILE}) && !defined(PACKAGE_BUILDING)
+ECHO_MSG=/usr/bin/printf
+IGNORE= :\n\
+The source distribution exists on your system, but due to\n\
+licensing restrictions you still need to download the\n\
+patchset, ${PATCHSETFILE}, from\n\
+http://www.eyesbeyond.com/freebsddom/java/jdk.html.\n\
+Please place the patchset in ${DISTDIR}.\n
+.endif
+
# Check for JDK sources
.if !exists(${DISTDIR}/${SRCFILE}) && !defined(PACKAGE_BUILDING)
ECHO_MSG=/usr/bin/printf
@@ -90,17 +101,6 @@ download the file \"${SRCFILE}\". Please place this file in\n\
${DISTDIR}.\n
.endif
-# Check for patchset
-.if !exists(${DISTDIR}/${PATCHSETFILE}) && !defined(PACKAGE_BUILDING)
-ECHO_MSG=/usr/bin/printf
-IGNORE= :\n\
-The source distribution exists on your system, but due to\n\
-licensing restrictions you still need to download the\n\
-patchset, ${PATCHSETFILE}, from\n\
-http://www.eyesbeyond.com/freebsddom/java/jdk.html.\n\
-Please place the patchset in ${DISTDIR}.\n
-.endif
-
pre-patch:
@${MKDIR} ${WRKSRC}
.for dir in build src ext/i18n/build ext/i18n/src ext/iiimp/build
diff --git a/java/jdk13/Makefile b/java/jdk13/Makefile
index 9fcfa67d73fe..aaabdfbc7f48 100644
--- a/java/jdk13/Makefile
+++ b/java/jdk13/Makefile
@@ -132,6 +132,17 @@ BUILD_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
TAR= gtar # Necessary for proper extraction of sources
.endif
+# Check for patchset
+.if !exists(${DISTDIR}/${PATCHSETFILE}) && !defined(PACKAGE_BUILDING)
+ECHO_MSG=/usr/bin/printf
+IGNORE= :\n\
+The source distribution exists on your system, but due to\n\
+licensing restrictions you still need to download the\n\
+patchset, ${PATCHSETFILE}, from\n\
+http://www.eyesbeyond.com/freebsddom/java/jdk13.html.\n\
+Please place the patchset in ${DISTDIR}.\n
+.endif
+
# Check for JDK sources
.if !exists(${DISTDIR}/${SRCFILE}) && !defined(PACKAGE_BUILDING)
ECHO_MSG=/usr/bin/printf
@@ -146,17 +157,6 @@ download the source file, ${SRCFILE}. Please place this file in\n\
${DISTDIR}.\n
.endif
-# Check for patchset
-.if !exists(${DISTDIR}/${PATCHSETFILE}) && !defined(PACKAGE_BUILDING)
-ECHO_MSG=/usr/bin/printf
-IGNORE= :\n\
-The source distribution exists on your system, but due to\n\
-licensing restrictions you still need to download the\n\
-patchset, ${PATCHSETFILE}, from\n\
-http://www.eyesbeyond.com/freebsddom/java/jdk13.html.\n\
-Please place the patchset in ${DISTDIR}.\n
-.endif
-
# HotSpot and/or native threads require a recent version of FreeBSD
.if ( defined(WITH_NATIVE_THREADS) || defined(WITH_HOTSPOT) ) && ( ${OSVERSION} < 470101 || ( ${OSVERSION} >= 500000 && ${OSVERSION} < 500043 ) )
ECHO_MSG=/usr/bin/printf