aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2002-04-13 01:04:08 +0000
committerGreg Lewis <glewis@FreeBSD.org>2002-04-13 01:04:08 +0000
commit251616adc13d49b6cac3635c6f0edddb778b93da (patch)
tree1709b40d277c1188ac0d7512ee6a45b15ee94472 /java
parente82dea84006887180323358f3dd6319affd5d9da (diff)
downloadports-251616adc13d49b6cac3635c6f0edddb778b93da.tar.gz
ports-251616adc13d49b6cac3635c6f0edddb778b93da.zip
Fix user and group ownership of the installed files when they have been
built by someone other than root. Instead of moving the files with tar, move them with cpio and set up ownership. This leaves 11 of the ports listed in the PR still to go. PR: 36411 Submitted by: Alan Eldridge <ports@geeksrus.net> Reviewed by: sobomax Approved by: sobomax
Notes
Notes: svn path=/head/; revision=57646
Diffstat (limited to 'java')
-rw-r--r--java/jdk12-beta/Makefile8
-rw-r--r--java/jdk12/Makefile8
2 files changed, 8 insertions, 8 deletions
diff --git a/java/jdk12-beta/Makefile b/java/jdk12-beta/Makefile
index 88cc8e6b120a..9e4341d67650 100644
--- a/java/jdk12-beta/Makefile
+++ b/java/jdk12-beta/Makefile
@@ -111,11 +111,11 @@ pre-install:
do-install:
${MKDIR} ${PREFIX}/jdk${JDK_VERSION}
- (cd ${JDKIMAGEDIR} && ${TAR} -c -f - .) \
- | (cd ${PREFIX}/jdk${JDK_VERSION} && ${TAR} --unlink -x -f -)
+ cd ${JDKIMAGEDIR} && /usr/bin/find . \
+ | /usr/bin/cpio -pdmu -R ${LIBOWN}:${LIBGRP} ${PREFIX}/jdk${JDK_VERSION}
.if !defined(NODEBUG)
- (cd ${JDKIMAGEDIR_G} && ${TAR} -c -f - .) \
- | (cd ${PREFIX}/jdk${JDK_VERSION} && ${TAR} --unlink -x -f -)
+ cd ${JDKIMAGEDIR_G} && /usr/bin/find . \
+ | /usr/bin/cpio -pdmu -R ${LIBOWN}:${LIBGRP} ${PREFIX}/jdk${JDK_VERSION}
.endif
post-install:
diff --git a/java/jdk12/Makefile b/java/jdk12/Makefile
index 88cc8e6b120a..9e4341d67650 100644
--- a/java/jdk12/Makefile
+++ b/java/jdk12/Makefile
@@ -111,11 +111,11 @@ pre-install:
do-install:
${MKDIR} ${PREFIX}/jdk${JDK_VERSION}
- (cd ${JDKIMAGEDIR} && ${TAR} -c -f - .) \
- | (cd ${PREFIX}/jdk${JDK_VERSION} && ${TAR} --unlink -x -f -)
+ cd ${JDKIMAGEDIR} && /usr/bin/find . \
+ | /usr/bin/cpio -pdmu -R ${LIBOWN}:${LIBGRP} ${PREFIX}/jdk${JDK_VERSION}
.if !defined(NODEBUG)
- (cd ${JDKIMAGEDIR_G} && ${TAR} -c -f - .) \
- | (cd ${PREFIX}/jdk${JDK_VERSION} && ${TAR} --unlink -x -f -)
+ cd ${JDKIMAGEDIR_G} && /usr/bin/find . \
+ | /usr/bin/cpio -pdmu -R ${LIBOWN}:${LIBGRP} ${PREFIX}/jdk${JDK_VERSION}
.endif
post-install: