aboutsummaryrefslogtreecommitdiff
path: root/korean/bitchx
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2000-10-05 07:22:56 +0000
committerJeremy Lea <reg@FreeBSD.org>2000-10-05 07:22:56 +0000
commit7b4c77811e89d7fc1131ca6e63df3e719bc86b1d (patch)
tree9695733a1620c4c290c86f161a4f1b73160ed39a /korean/bitchx
parentc76cf46929051f9dd322487d888c82f104026e6d (diff)
downloadports-7b4c77811e89d7fc1131ca6e63df3e719bc86b1d.tar.gz
ports-7b4c77811e89d7fc1131ca6e63df3e719bc86b1d.zip
Implement WANT_GNOME.
Notes
Notes: svn path=/head/; revision=33430
Diffstat (limited to 'korean/bitchx')
-rw-r--r--korean/bitchx/Makefile61
-rw-r--r--korean/bitchx/files/patch-ag11
-rw-r--r--korean/bitchx/files/patch-ah11
-rw-r--r--korean/bitchx/pkg-plist37
4 files changed, 67 insertions, 53 deletions
diff --git a/korean/bitchx/Makefile b/korean/bitchx/Makefile
index 57b6a3411e5b..1621a5c95a8b 100644
--- a/korean/bitchx/Makefile
+++ b/korean/bitchx/Makefile
@@ -19,36 +19,31 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= hollywar@mail.holywar.net
-.if defined(WITH_GNOME)
-LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
-.endif
-
-#PATCH_DIST_ARGS= -d ${WRKDIR}/ --forward --quiet -E ${PATCH_DIST_STRIP}
-GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
WRKSRC= ${WRKDIR}/BitchX
+
USE_AUTOCONF= yes
USE_GMAKE= yes
-.if defined(WITH_GNOME)
-CONFIGURE_ARGS+= --with-plugins --with-gtk --enable-sound
-.else
-CONFIGURE_ARGS+= --with-plugins --without-gtk
-.endif
-CONFIGURE_ARGS+= --exec-prefix="${PREFIX}/share" \
- --bindir="${PREFIX}/bin" \
- --datadir="${PREFIX}/share" \
- --libdir="${PREFIX}/share"
-
+WANT_ESOUND= yes
+WANT_GNOME= yes
+CONFIGURE_ARGS= --with-plugins \
+ --exec-prefix="${PREFIX}/share" \
+ --bindir="${PREFIX}/bin" \
+ --datadir="${PREFIX}/share" \
+ --libdir="${PREFIX}/share"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- GLIB_CONFIG="${GLIB_CONFIG}" \
- GTK_CONFIG="${GTK_CONFIG}"
+ LIBS="-L{LOCALBASE}/lib"
-MAKE_ENV+= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
- INSTALL_DATA="${INSTALL_DATA}"
+.include <bsd.port.pre.mk>
-.if !defined(WITH_GNOME)
-pre-extract:
- @${ECHO} "You can add hooks for GNOME by defining WITH_GNOME"
+.if defined(HAVE_GNOME)
+USE_GNOME= yes
+CONFIGURE_ARGS+=--with-gtk
+.else
+CONFIGURE_ARGS+=--without-gtk
+.endif
+.if defined(HAVE_ESOUND)
+USE_ESOUND= yes
+CONFIGURE_ARGS+=--enable-sound
.endif
post-install:
@@ -61,21 +56,5 @@ post-install:
${RMDIR} ${PREFIX}/share/bx/help/4_Misc/fset
${RMDIR} ${PREFIX}/share/bx/help/4_Misc/wset
.endif
-.if defined(WITH_GNOME)
- @${ECHO} bin/gtkBitchX >> ${TMPPLIST}
- @${ECHO} bin/gtkBitchX-1.0c16+H1 >> ${TMPPLIST}
- @${ECHO} share/bx/plugins/nicklist.so >> ${TMPPLIST}
-.else
- @${ECHO} bin/bx >> ${TMPPLIST}
- @${ECHO} bin/BitchX >> ${TMPPLIST}
- @${ECHO} bin/BitchX-1.0c16+H1 >> ${TMPPLIST}
- @${ECHO} bin/scr-bx >> ${TMPPLIST}
- @${ECHO} share/bx/wserv >> ${TMPPLIST}
-.endif
- @${ECHO} @dirrm share/bx/help >> ${TMPPLIST}
- @${ECHO} @dirrm share/bx/plugins >> ${TMPPLIST}
- @${ECHO} @dirrm share/bx/script >> ${TMPPLIST}
- @${ECHO} @dirrm share/bx/translation >> ${TMPPLIST}
- @${ECHO} @dirrm share/bx >> ${TMPPLIST}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/korean/bitchx/files/patch-ag b/korean/bitchx/files/patch-ag
new file mode 100644
index 000000000000..163bf1445c7c
--- /dev/null
+++ b/korean/bitchx/files/patch-ag
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sun Jan 9 02:11:01 2000
++++ Makefile.in Sat Sep 9 01:24:46 2000
+@@ -43,7 +43,7 @@
+ IRCLIB = @IRCLIB@
+
+ CC = @CC@
+-DEFS = -I$$(srcdir)/../include -I$(topdir)/include
++DEFS = -I$$(srcdir)/../include -I$(topdir)/include -I. -I-
+ LIBS = @LIBS@
+ INCLUDES = @INCLUDES@
+
diff --git a/korean/bitchx/files/patch-ah b/korean/bitchx/files/patch-ah
new file mode 100644
index 000000000000..fca11c214367
--- /dev/null
+++ b/korean/bitchx/files/patch-ah
@@ -0,0 +1,11 @@
+--- dll/Makefile.in.orig Sun Oct 1 22:05:20 2000
++++ dll/Makefile.in Sun Oct 1 22:05:47 2000
+@@ -31,7 +32,7 @@
+ 'SHLIB_CFLAGS=$(SHLIB_CFLAGS)' \
+ 'IRCLIB=$(IRCLIB)' \
+ 'TCLINC=$(TCLINC)' \
+- 'INCLUDES=$(INCLUDES)' \
++ 'INCLUDES=$(DEFS) $(INCLUDES)' \
+ 'DEFS=$(DEFS)' \
+ 'local_dir=$(local_dir)' \
+ 'LIBS=$(LIBS)'
diff --git a/korean/bitchx/pkg-plist b/korean/bitchx/pkg-plist
index e27a42624e53..1db84aebe59f 100644
--- a/korean/bitchx/pkg-plist
+++ b/korean/bitchx/pkg-plist
@@ -1,3 +1,9 @@
+%%NOGNOME:%%bin/BitchX
+%%NOGNOME:%%bin/BitchX-1.0c16+H1
+%%GNOME:%%bin/gtkBitchX
+%%GNOME:%%bin/gtkBitchX-1.0c16+H1
+bin/bx
+%%NOGNOME:%%bin/scr-bx
share/bx/BitchX.quit
share/bx/BitchX.ircnames
share/bx/BitchX.reasons
@@ -907,6 +913,7 @@ share/bx/plugins/encrypt.so
share/bx/plugins/fserv.so
share/bx/plugins/hint.so
share/bx/plugins/nap.so
+%%GNOME:%%share/bx/plugins/nicklist.so
share/bx/plugins/pkga.so
share/bx/plugins/possum.so
share/bx/plugins/qmail.so
@@ -953,19 +960,25 @@ share/bx/translation/SWEDISH_NAMES_COM
share/bx/translation/SWISS
share/bx/translation/UNITED_KINGDOM
share/bx/translation/UNITED_KINGDOM_COM
+%%NOGNOME:%%share/bx/wserv
share/doc/bitchx/bxfaq.html
+@dirrm share/doc/bitchx
+@dirrm share/bx/translation
+@dirrm share/bx/script
+@dirrm share/bx/plugins
+@dirrm share/bx/help/8_Scripts
+@dirrm share/bx/help/7_Docs
+@dirrm share/bx/help/6_Functions
+@dirrm share/bx/help/5_Programming/on
+@dirrm share/bx/help/5_Programming
+@dirrm share/bx/help/4_Misc/window
+@dirrm share/bx/help/4_Misc/set
+@dirrm share/bx/help/4_Misc/bind
+@dirrm share/bx/help/4_Misc
+@dirrm share/bx/help/3_Operators
+@dirrm share/bx/help/2_Queries
@dirrm share/bx/help/1_General/dcc
@dirrm share/bx/help/1_General/ctcp
@dirrm share/bx/help/1_General
-@dirrm share/bx/help/2_Queries
-@dirrm share/bx/help/3_Operators
-@dirrm share/bx/help/4_Misc/bind
-@dirrm share/bx/help/4_Misc/set
-@dirrm share/bx/help/4_Misc/window
-@dirrm share/bx/help/4_Misc
-@dirrm share/bx/help/5_Programming/on
-@dirrm share/bx/help/5_Programming
-@dirrm share/bx/help/6_Functions
-@dirrm share/bx/help/7_Docs
-@dirrm share/bx/help/8_Scripts
-@dirrm share/doc/bitchx
+@dirrm share/bx/help
+@dirrm share/bx