aboutsummaryrefslogtreecommitdiff
path: root/korean/nabi
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2003-09-27 19:44:51 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2003-09-27 19:44:51 +0000
commitb4d41382948e80b66a77f5d16aad5d72fa6cdfc6 (patch)
tree2c1f5a9335fab4a44540118f2a526d2390ee28ce /korean/nabi
parent0c647e3abe901e82537f9628633fba1e270df8fc (diff)
downloadports-b4d41382948e80b66a77f5d16aad5d72fa6cdfc6.tar.gz
ports-b4d41382948e80b66a77f5d16aad5d72fa6cdfc6.zip
Update to 0.7
Notes
Notes: svn path=/head/; revision=89580
Diffstat (limited to 'korean/nabi')
-rw-r--r--korean/nabi/Makefile17
-rw-r--r--korean/nabi/distinfo2
-rw-r--r--korean/nabi/files/patch-src_ic.c20
3 files changed, 16 insertions, 23 deletions
diff --git a/korean/nabi/Makefile b/korean/nabi/Makefile
index cafbc85f20dc..bf949c2e318a 100644
--- a/korean/nabi/Makefile
+++ b/korean/nabi/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nabi
-PORTVERSION= 0.6
+PORTVERSION= 0.7
CATEGORIES= korean gnome x11
MASTER_SITES= http://download.kldp.net/nabi/
@@ -26,4 +26,17 @@ CONFIGURE_ARGS= --with-default-keyboard=39
CONFIGURE_ARGS= --with-default-keyboard=3f
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == amd64 || ${ARCH} == ia64 || ${ARCH} == sparc64
+# no appropriate iconv encoding for 64bit wchar_t
+VWCHARTENC= NOPE
+.else
+VWCHARTENC= UCS-4-INTERNAL
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} 's,WCHAR_T,${VWCHARTENC},g' \
+ ${WRKSRC}/src/server.c
+
+.include <bsd.port.post.mk>
diff --git a/korean/nabi/distinfo b/korean/nabi/distinfo
index 8f59de2014f2..2023d18288b4 100644
--- a/korean/nabi/distinfo
+++ b/korean/nabi/distinfo
@@ -1 +1 @@
-MD5 (nabi-0.6.tar.gz) = 14e7b788f82af9f2e164833fbe7bd738
+MD5 (nabi-0.7.tar.gz) = fa30c921bf0a1c98f15fd35cfaf9ceb9
diff --git a/korean/nabi/files/patch-src_ic.c b/korean/nabi/files/patch-src_ic.c
deleted file mode 100644
index 59a186bee04a..000000000000
--- a/korean/nabi/files/patch-src_ic.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/ic.c.orig Sat Aug 23 14:15:05 2003
-+++ src/ic.c Fri Sep 19 10:47:55 2003
-@@ -1219,7 +1219,7 @@
- * befor commiting the string. but it makes too many flickering
- * so I first send commit string and then delete preedit string.
- * This makes some problem on gtk2 entry */
-- /* nabi_ic_preedit_clear(ic); */
-+ nabi_ic_preedit_clear(ic);
-
- list[0] = buf;
- ret = XwcTextListToTextProperty(server->display, list, 1,
-@@ -1237,7 +1237,7 @@
- XFree(tp.value);
-
- /* we delete preedit string here */
-- nabi_ic_preedit_clear(ic);
-+ /* nabi_ic_preedit_clear(ic); */
-
- return True;
- }