aboutsummaryrefslogtreecommitdiff
path: root/korean
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
commit9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92 (patch)
treec4f78cbaf45ab044db3e157be708afd711a4e841 /korean
parent0533abe3e7aae5c19e0a0ce9c1e82ed5e94f63e8 (diff)
downloadports-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.tar.gz
ports-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.zip
Support LIBS like LDFLAGS.
- Add LIBS="${LIBS}" to MAKE_ENV and CONFIGURE_ENV. - Add an option helper for LIBS. - Adjust all ports that already use LIBS. Also remove references to PTHREAD_CFLAGS and PTHREAD_LIBS while here. - Some ports did not support having a LIBS environment variable and required additional patches. Somewhat simplified a linker command line looks like: ${CC} ${src_LDFLAGS} ${LDFLAGS} ${src_LIBS} ${LIBS} where src_LDFLAGS and src_LIBS are controlled by upstream and LDFLAGS and LIBS can be controlled by us. If possible -L and -l flags need to be added to LIBS to make sure they appear after any -L and -l flags set by upstream. Many ports currently add -L${LOCALBASE}/lib to LDFLAGS but this may appear too early on the command line causing installed libraries to be linked in instead of freshly built ones. Additional changes: benchmarks/netio: Replace WITH_IPV6 with an IPV6 option. comms/gnokii: Replace some patches with USES=pathfix. Also remove -fPIC. graphics/gimageview: USES=libtool and install desktop file in DESKTOPDIR. graphics/visionworkbench: Remove FreeBSD 7 support. multimedia/libmovtar: New LIB_DEPENDS syntax. multimedia/opencinematools: Use standard do-build. net/siproxd: USES=libtool:keepla (port actually needs .la files for plugins) net-mgmt/nagios: Remove -fPIC. net-mgmt/nagios4: Remove -fPIC. print/cups-base: Only add -lssp_nonshared on i386 and OSVERSION < 1000036. security/p11-kit: Replace PTHREAD_LIBS in CONFIGURE_ENV with ac_cv_func_pthread_mutexattr_init=no in CONFIGURE_ARGS. This skips a test in configure that falsely detects pthread_mutexattr_init in our libc. sysutils/dar: Fix iconv detection. x11/rxvt-unicode: Remove -lstdc++ and patch configure to remove a FreeBSD hack and use $CXX as linker as on other platforms. PR: 190592 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=357486
Diffstat (limited to 'korean')
-rw-r--r--korean/eterm/Makefile2
-rw-r--r--korean/eterm/files/patch-ac11
2 files changed, 1 insertions, 12 deletions
diff --git a/korean/eterm/Makefile b/korean/eterm/Makefile
index 7d38f13e3aba..5f9951605a97 100644
--- a/korean/eterm/Makefile
+++ b/korean/eterm/Makefile
@@ -21,7 +21,7 @@ USE_GNOME= imlib
USE_LDCONFIG= yes
USE_PERL5= build
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" LOCALBASE="${LOCALBASE}"
+LIBS+= -L${LOCALBASE}/lib
MAN1= Eterm.1
MAKE_JOBS_UNSAFE= yes
diff --git a/korean/eterm/files/patch-ac b/korean/eterm/files/patch-ac
index 2263fa57bfa0..c1158153b461 100644
--- a/korean/eterm/files/patch-ac
+++ b/korean/eterm/files/patch-ac
@@ -1,14 +1,3 @@
---- doc/Makefile.in.orig Sat Jan 30 00:19:23 1999
-+++ doc/Makefile.in Sat Jan 30 00:20:04 1999
-@@ -76,7 +76,7 @@
- EGCS = @EGCS@
- FEATURE_CMD = @FEATURE_CMD@
- GDB = @GDB@
--GRLIBS = @GRLIBS@
-+GRLIBS = -L${LOCALBASE}/lib @GRLIBS@
- IMLIB_CONFIG = @IMLIB_CONFIG@
- LD = @LD@
- LDFLAGS = @LDFLAGS@
--- utils/Makefile.in.orig Mon May 3 12:39:18 1999
+++ utils/Makefile.in Mon May 3 12:39:36 1999
@@ -225,7 +225,7 @@