aboutsummaryrefslogtreecommitdiff
path: root/korean
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-05-30 14:25:51 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-05-30 14:25:51 +0000
commitdeda491e7bfa7d089c63a461cbd69353d08a501d (patch)
treeba4f2012fa966d9aef3824f1635c9733b1e719b3 /korean
parent0053401747c3e21eee75c9e507c769551accc029 (diff)
downloadports-deda491e7bfa7d089c63a461cbd69353d08a501d.tar.gz
ports-deda491e7bfa7d089c63a461cbd69353d08a501d.zip
Add staging support
Notes
Notes: svn path=/head/; revision=355850
Diffstat (limited to 'korean')
-rw-r--r--korean/uniksc/Makefile1
-rw-r--r--korean/uniksc/files/patch-makefile20
2 files changed, 11 insertions, 10 deletions
diff --git a/korean/uniksc/Makefile b/korean/uniksc/Makefile
index c8d2a86cedd2..afda51b27fd3 100644
--- a/korean/uniksc/Makefile
+++ b/korean/uniksc/Makefile
@@ -16,5 +16,4 @@ PLIST_FILES= bin/uniksc include/uniksc.h lib/libuniksc.so.0
CFLAGS+= "-fPIC"
.endif
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/korean/uniksc/files/patch-makefile b/korean/uniksc/files/patch-makefile
index ee846b1523e9..31dd398f58a1 100644
--- a/korean/uniksc/files/patch-makefile
+++ b/korean/uniksc/files/patch-makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Sun Oct 8 15:38:51 2000
-+++ Makefile Sat Mar 13 18:23:29 2004
+--- Makefile.orig 2000-10-09 00:38:51.000000000 +0200
++++ Makefile 2014-05-30 15:04:05.812325981 +0200
@@ -1,8 +1,9 @@
-CC = gcc
+#CC = gcc
@@ -13,7 +13,7 @@
SRCS = ksc5601_utf16.c \
ksc5601_utf16_table.c \
-@@ -12,27 +13,27 @@
+@@ -12,27 +13,24 @@
OBJS = $(SRCS:.c=.o)
.c.o:
@@ -33,15 +33,17 @@
+ rm -f $(OBJS) uniksc libuniksc.so.0 *~
install:
- if ( test ! -d $(PREFIX)/bin ) ; then mkdir $(PREFIX)/bin ; fi
- if ( test ! -d $(PREFIX)/lib ) ; then mkdir $(PREFIX)/lib ; fi
- if ( test ! -d $(PREFIX)/include ) ; then mkdir $(PREFIX)/include ; fi
- cp -f uniksc $(PREFIX)/bin/uniksc
+- if ( test ! -d $(PREFIX)/bin ) ; then mkdir $(PREFIX)/bin ; fi
+- if ( test ! -d $(PREFIX)/lib ) ; then mkdir $(PREFIX)/lib ; fi
+- if ( test ! -d $(PREFIX)/include ) ; then mkdir $(PREFIX)/include ; fi
+- cp -f uniksc $(PREFIX)/bin/uniksc
- cp -f libuniksc.so.0.9 $(PREFIX)/lib/libuniksc.so.0.9
- ln -sf libuniksc.so.0.9 $(PREFIX)/lib/libuniksc.so.0
-+ cp -f libuniksc.so.0 $(PREFIX)/lib/libuniksc.so.0
+- cp -f uniksc.h $(PREFIX)/include/uniksc.h
++ $(BSD_INSTALL_PROGRAM) uniksc $(DESTDIR)$(PREFIX)/bin/uniksc
++ $(BSD_INSTALL_LIB) libuniksc.so.0 $(DESTDIR)$(PREFIX)/lib/libuniksc.so.0
+ #ln -sf libuniksc.so.0.9 $(PREFIX)/lib/libuniksc.so.0
- cp -f uniksc.h $(PREFIX)/include/uniksc.h
++ $(BSD_INSTALL_DATA) uniksc.h $(DESTDIR)$(PREFIX)/include/uniksc.h
uninstall:
rm -f $(PREFIX)/bin/uniksc