aboutsummaryrefslogtreecommitdiff
path: root/korean
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2011-08-05 20:48:19 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2011-08-05 20:48:19 +0000
commit07bcf47150045bbae983d663de97f1b77bd34813 (patch)
tree3464e84c880806ff401668aff2a2f7ebc4bcb161 /korean
parentf0c3d0386b65bd03c62b9177884a4dc211da3e1b (diff)
downloadports-07bcf47150045bbae983d663de97f1b77bd34813.tar.gz
ports-07bcf47150045bbae983d663de97f1b77bd34813.zip
Nanum font family is free Hangul fonts developed by NHN Corporation
and distributed under SIL Open Font License (OFL). WWW: http://hangeul.naver.com/
Notes
Notes: svn path=/head/; revision=278976
Diffstat (limited to 'korean')
-rw-r--r--korean/Makefile2
-rw-r--r--korean/nanumfonts-otf/Makefile68
-rw-r--r--korean/nanumfonts-otf/distinfo.otf2
-rw-r--r--korean/nanumfonts-otf/distinfo.ttf2
-rw-r--r--korean/nanumfonts-otf/files/LICENSE96
-rw-r--r--korean/nanumfonts-otf/pkg-descr4
-rw-r--r--korean/nanumfonts-ttf/Makefile13
7 files changed, 187 insertions, 0 deletions
diff --git a/korean/Makefile b/korean/Makefile
index f46a3256e333..5122ec9f72b5 100644
--- a/korean/Makefile
+++ b/korean/Makefile
@@ -41,6 +41,8 @@
SUBDIR += mizifont
SUBDIR += munhwafonts-cid
SUBDIR += nabi
+ SUBDIR += nanumfonts-otf
+ SUBDIR += nanumfonts-ttf
SUBDIR += nhpf
SUBDIR += pgp.language
SUBDIR += php_doc
diff --git a/korean/nanumfonts-otf/Makefile b/korean/nanumfonts-otf/Makefile
new file mode 100644
index 000000000000..9ddfa92fd36b
--- /dev/null
+++ b/korean/nanumfonts-otf/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: Nanum Hangul fonts
+# Date created: August 4, 2011
+# Whom: Jung-uk Kim <jkim@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nanumfonts
+PORTVERSION= 3.0
+CATEGORIES= korean
+MASTER_SITES= http://cdn.naver.com/naver/NanumFont/fontfiles/
+PKGNAMESUFFIX= -${FONTTYPE}
+DISTNAME= NanumFont_${FONTTYPE:U}_ALL
+
+MAINTAINER= jkim@FreeBSD.org
+COMMENT= Nanum family Hangul fonts (${FONTFORMAT})
+
+LICENSE= OFL
+LICENSE_NAME= Open Font License version 1.1
+LICENSE_FILE= ${FILESDIR}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+BUILD_DEPENDS+= ${LOCALBASE}/bin/mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
+ ${LOCALBASE}/bin/mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
+
+DISTINFO_FILE= ${PKGDIR}/distinfo.${FONTTYPE}
+
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+
+FONTTYPE?= otf
+FONTFORMAT?= OpenType
+
+FONTSDIR= lib/X11/fonts/nanum-${FONTTYPE}
+FONTLIST= NanumBrush \
+ NanumGothic \
+ NanumGothicBold \
+ NanumGothicExtraBold \
+ NanumMyeongjo \
+ NanumMyeongjoBold \
+ NanumMyeongjoExtraBold \
+ NanumPen
+
+.for f in ${FONTLIST}
+PLIST_FILES+= ${FONTSDIR}/${f}.${FONTTYPE}
+.endfor
+PLIST_FILES+= ${FONTSDIR}/fonts.dir \
+ ${FONTSDIR}/fonts.scale
+
+do-build:
+ ${PREFIX}/bin/mkfontscale ${WRKSRC}
+ ${PREFIX}/bin/mkfontdir ${WRKSRC}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${FONTSDIR}
+.for f in ${FONTLIST}
+ ${INSTALL_DATA} ${WRKSRC}/${f}.${FONTTYPE} ${PREFIX}/${FONTSDIR}
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/fonts.dir ${PREFIX}/${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/fonts.scale ${PREFIX}/${FONTSDIR}
+
+post-install:
+ @${ECHO_CMD} "@dirrm ${FONTSDIR}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec fc-cache -s %D/${FONTSDIR} 2>/dev/null || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec fc-cache -s %D/${FONTSDIR} 2>/dev/null || true" >> ${TMPPLIST}
+ @-${PREFIX}/bin/fc-cache -s ${PREFIX}/${FONTSDIR} 2>/dev/null
+
+.include <bsd.port.mk>
diff --git a/korean/nanumfonts-otf/distinfo.otf b/korean/nanumfonts-otf/distinfo.otf
new file mode 100644
index 000000000000..93b511412b3f
--- /dev/null
+++ b/korean/nanumfonts-otf/distinfo.otf
@@ -0,0 +1,2 @@
+SHA256 (NanumFont_OTF_ALL.zip) = b74da4ddb06e689c0932cab2978d747cca13190d3b57b4b99118058f2fdadc1d
+SIZE (NanumFont_OTF_ALL.zip) = 10237955
diff --git a/korean/nanumfonts-otf/distinfo.ttf b/korean/nanumfonts-otf/distinfo.ttf
new file mode 100644
index 000000000000..41581e15546d
--- /dev/null
+++ b/korean/nanumfonts-otf/distinfo.ttf
@@ -0,0 +1,2 @@
+SHA256 (NanumFont_TTF_ALL.zip) = 3f132ff5bd56434be5b6b0447b4613aa817c6dc3016ad4c51fa480818589d5d3
+SIZE (NanumFont_TTF_ALL.zip) = 14967190
diff --git a/korean/nanumfonts-otf/files/LICENSE b/korean/nanumfonts-otf/files/LICENSE
new file mode 100644
index 000000000000..a1bf5fb9d0b7
--- /dev/null
+++ b/korean/nanumfonts-otf/files/LICENSE
@@ -0,0 +1,96 @@
+Copyright (c) 2010, NHN Corporation (http://www.nhncorp.com),
+with Reserved Font Name Nanum, Naver Nanum, NanumGothic, Naver NanumGothic,
+NanumMyeongjo, Naver NanumMyeongjo, NanumBrush, Naver NanumBrush, NanumPen,
+Naver NanumPen.
+
+This Font Software is licensed under the SIL Open Font License, Version 1.1.
+This license is copied below, and is also available with a FAQ at:
+http://scripts.sil.org/OFL
+
+
+-----------------------------------------------------------
+SIL OPEN FONT LICENSE Version 1.1 - 26 February 2007
+-----------------------------------------------------------
+
+PREAMBLE
+The goals of the Open Font License (OFL) are to stimulate worldwide
+development of collaborative font projects, to support the font creation
+efforts of academic and linguistic communities, and to provide a free and
+open framework in which fonts may be shared and improved in partnership
+with others.
+
+The OFL allows the licensed fonts to be used, studied, modified and
+redistributed freely as long as they are not sold by themselves. The
+fonts, including any derivative works, can be bundled, embedded,
+redistributed and/or sold with any software provided that any reserved
+names are not used by derivative works. The fonts and derivatives,
+however, cannot be released under any other type of license. The
+requirement for fonts to remain under this license does not apply
+to any document created using the fonts or their derivatives.
+
+DEFINITIONS
+"Font Software" refers to the set of files released by the Copyright
+Holder(s) under this license and clearly marked as such. This may
+include source files, build scripts and documentation.
+
+"Reserved Font Name" refers to any names specified as such after the
+copyright statement(s).
+
+"Original Version" refers to the collection of Font Software components as
+distributed by the Copyright Holder(s).
+
+"Modified Version" refers to any derivative made by adding to, deleting,
+or substituting -- in part or in whole -- any of the components of the
+Original Version, by changing formats or by porting the Font Software to a
+new environment.
+
+"Author" refers to any designer, engineer, programmer, technical
+writer or other person who contributed to the Font Software.
+
+PERMISSION & CONDITIONS
+Permission is hereby granted, free of charge, to any person obtaining
+a copy of the Font Software, to use, study, copy, merge, embed, modify,
+redistribute, and sell modified and unmodified copies of the Font
+Software, subject to the following conditions:
+
+1) Neither the Font Software nor any of its individual components,
+in Original or Modified Versions, may be sold by itself.
+
+2) Original or Modified Versions of the Font Software may be bundled,
+redistributed and/or sold with any software, provided that each copy
+contains the above copyright notice and this license. These can be
+included either as stand-alone text files, human-readable headers or
+in the appropriate machine-readable metadata fields within text or
+binary files as long as those fields can be easily viewed by the user.
+
+3) No Modified Version of the Font Software may use the Reserved Font
+Name(s) unless explicit written permission is granted by the corresponding
+Copyright Holder. This restriction only applies to the primary font name as
+presented to the users.
+
+4) The name(s) of the Copyright Holder(s) or the Author(s) of the Font
+Software shall not be used to promote, endorse or advertise any
+Modified Version, except to acknowledge the contribution(s) of the
+Copyright Holder(s) and the Author(s) or with their explicit written
+permission.
+
+5) The Font Software, modified or unmodified, in part or in whole,
+must be distributed entirely under this license, and must not be
+distributed under any other license. The requirement for fonts to
+remain under this license does not apply to any document created
+using the Font Software.
+
+TERMINATION
+This license becomes null and void if any of the above conditions are
+not met.
+
+DISCLAIMER
+THE FONT SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT
+OF COPYRIGHT, PATENT, TRADEMARK, OR OTHER RIGHT. IN NO EVENT SHALL THE
+COPYRIGHT HOLDER BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+INCLUDING ANY GENERAL, SPECIAL, INDIRECT, INCIDENTAL, OR CONSEQUENTIAL
+DAMAGES, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF THE USE OR INABILITY TO USE THE FONT SOFTWARE OR FROM
+OTHER DEALINGS IN THE FONT SOFTWARE.
diff --git a/korean/nanumfonts-otf/pkg-descr b/korean/nanumfonts-otf/pkg-descr
new file mode 100644
index 000000000000..6a3b81ef2855
--- /dev/null
+++ b/korean/nanumfonts-otf/pkg-descr
@@ -0,0 +1,4 @@
+Nanum font family is free Hangul fonts developed by NHN Corporation
+and distributed under SIL Open Font License (OFL).
+
+WWW: http://hangeul.naver.com/
diff --git a/korean/nanumfonts-ttf/Makefile b/korean/nanumfonts-ttf/Makefile
new file mode 100644
index 000000000000..0be5c9f2e2e1
--- /dev/null
+++ b/korean/nanumfonts-ttf/Makefile
@@ -0,0 +1,13 @@
+# New ports collection makefile for: Nanum Hangul fonts
+# Date created: August 4, 2011
+# Whom: Jung-uk Kim <jkim@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+MASTERDIR= ${.CURDIR}/../nanumfonts-otf
+
+FONTTYPE= ttf
+FONTFORMAT= TrueType
+
+.include "${MASTERDIR}/Makefile"