aboutsummaryrefslogtreecommitdiff
path: root/lang/afnix/Makefile
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2014-01-08 18:01:25 +0000
committerJohan van Selst <johans@FreeBSD.org>2014-01-08 18:01:25 +0000
commit402551a405307b8ed257b2ebb9938a633f219e73 (patch)
tree5985639004fb6122e0e47f0344f76656a09e3a44 /lang/afnix/Makefile
parentee955d916feb48f8c0a728943e0009c813dc4ac7 (diff)
downloadports-402551a405307b8ed257b2ebb9938a633f219e73.tar.gz
ports-402551a405307b8ed257b2ebb9938a633f219e73.zip
- Update afnix to 2.4.0
- Enable stage support
Notes
Notes: svn path=/head/; revision=339161
Diffstat (limited to 'lang/afnix/Makefile')
-rw-r--r--lang/afnix/Makefile17
1 files changed, 4 insertions, 13 deletions
diff --git a/lang/afnix/Makefile b/lang/afnix/Makefile
index bd4b806833b3..bde6a7b7888b 100644
--- a/lang/afnix/Makefile
+++ b/lang/afnix/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= afnix
-PORTVERSION= 2.3.1
+PORTVERSION= 2.4.0
CATEGORIES= lang
MASTER_SITES= http://www.afnix.org/ftp/ \
ftp://ftp.stack.nl/pub/users/johans/afnix/
@@ -12,7 +12,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= johans@FreeBSD.org
COMMENT= A multi-threaded functional programming language
-USE_GMAKE= yes
+USES= gmake
USE_LDCONFIG= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= cnf/bin/afnix-setup
@@ -24,13 +24,6 @@ MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PORTDOCS= *
PLIST_SUB= PORTVER=${PORTVERSION:R}
-MAN1= afnix::adp.1 afnix::axp.1 axc.1 axd.1 axi.1 axl.1
-MAN3= afnix::csm.3 afnix::gfx.3 afnix::itu.3 afnix::mth.3 afnix::net.3 \
- afnix::nwg.3 afnix::sec.3 afnix::sio.3 afnix::sps.3 afnix::sys.3 \
- afnix::txt.3 afnix::wax.3 afnix::xml.3 afnix::xpe.3
-MAN7= afnix::guide.7 afnix::license.7 afnix::notes.7 afnix::reference.7
-
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == "powerpc"
@@ -44,8 +37,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|$$(CP)|$$(BSD_INSTALL_PROGRAM)|' \
${WRKSRC}/src/*/*/exe/Makefile
@${REINPLACE_CMD} -e '/\.rtf/d' ${WRKSRC}/etc/Makefile
- @${REINPLACE_CMD} -e '/^MANDIR/s/SHRDIR/MANPREFIX/' \
- ${WRKSRC}/cnf/mak/afnix-defs.mak
@${REINPLACE_CMD} -e '/uname -r/s/\\\./[.-]/' \
${WRKSRC}/cnf/bin/afnix-guess
@@ -57,10 +48,10 @@ post-install:
.if ! ${PORT_OPTIONS:MDOCS}
. for i in ${MAN1} ${MAN3} ${MAN7}
${INSTALL_MAN} ${WRKSRC}/bld/${PORTNAME}-doc-${PORTVERSION}/man/$i \
- ${MANPREFIX}/man/man${i:E}/
+ ${STAGEDIR}${MANPREFIX}/man/man${i:E}/
. endfor
.else
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} publish
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} DESTDIR=${STAGEDIR} ${GMAKE} publish
.endif
.include <bsd.port.post.mk>