aboutsummaryrefslogtreecommitdiff
path: root/lang/awka
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-31 16:33:18 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-31 16:33:18 +0000
commitdb2a13ade0d1ee8ed0be01fc5554edfb21c41aa3 (patch)
treef7af72401a05cda80820a773aa8779ebc13a0f9a /lang/awka
parentff73c080d0b7866aeab876d22d5bfe427f319d16 (diff)
downloadports-db2a13ade0d1ee8ed0be01fc5554edfb21c41aa3.tar.gz
ports-db2a13ade0d1ee8ed0be01fc5554edfb21c41aa3.zip
add awka
Converts the AWK script to C, then compiles it
Notes
Notes: svn path=/head/; revision=43359
Diffstat (limited to 'lang/awka')
-rw-r--r--lang/awka/Makefile26
-rw-r--r--lang/awka/distinfo1
-rw-r--r--lang/awka/pkg-comment1
-rw-r--r--lang/awka/pkg-descr8
-rw-r--r--lang/awka/pkg-plist6
5 files changed, 42 insertions, 0 deletions
diff --git a/lang/awka/Makefile b/lang/awka/Makefile
new file mode 100644
index 000000000000..96b297b9421e
--- /dev/null
+++ b/lang/awka/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# New ports collection makefile for: awka
+# Date created: May 31, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+
+PORTNAME= awka
+PORTVERSION= 0.7.3
+CATEGORIES= lang
+MASTER_SITES= http://awka.sourceforge.net/
+
+MAINTAINER= ijliao@FreeBSD.org
+
+GNU_CONFIGURE= yes
+
+INSTALLS_SHLIB= yes
+
+MANCOMPRESSED= no
+MAN1= awka.1
+MAN5= awka-elm.5 awka-elmref.5
+
+post-install:
+ @strip ${PREFIX}/bin/awka
+
+.include <bsd.port.mk>
diff --git a/lang/awka/distinfo b/lang/awka/distinfo
new file mode 100644
index 000000000000..d0530c62ce78
--- /dev/null
+++ b/lang/awka/distinfo
@@ -0,0 +1 @@
+MD5 (awka-0.7.3.tar.gz) = a1c17a23162f22cb7e3f92bd7bddc294
diff --git a/lang/awka/pkg-comment b/lang/awka/pkg-comment
new file mode 100644
index 000000000000..1da068d81227
--- /dev/null
+++ b/lang/awka/pkg-comment
@@ -0,0 +1 @@
+Converts the AWK script to C, then compiles it
diff --git a/lang/awka/pkg-descr b/lang/awka/pkg-descr
new file mode 100644
index 000000000000..a01d8bafd27e
--- /dev/null
+++ b/lang/awka/pkg-descr
@@ -0,0 +1,8 @@
+Awka is an open-source implementation of the AWK programming language.
+
+Awka is not an interpreter like Gawk, Mawk or Nawk, but instead it converts
+the program to ANSI-C, then compiles this using gcc or a native C compiled
+to create a binary executable. This means you must have an ANSI C compiler
+present on your system for Awka to work.
+
+WWW: http://awka.sourceforge.net/
diff --git a/lang/awka/pkg-plist b/lang/awka/pkg-plist
new file mode 100644
index 000000000000..40f861b3f30c
--- /dev/null
+++ b/lang/awka/pkg-plist
@@ -0,0 +1,6 @@
+bin/awka
+lib/libawka.a
+lib/libdfa.a
+lib/libawka.so
+include/libawka.h
+include/dfa.h