aboutsummaryrefslogtreecommitdiff
path: root/lang/chicken
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-06-02 06:11:39 +0000
committerWen Heping <wen@FreeBSD.org>2011-06-02 06:11:39 +0000
commit3a08792951010f4264295deb2e4226e0d0f8493c (patch)
tree86a2f0d54bc78aea59e5c133f0ffdd9e74fda906 /lang/chicken
parent05ca9d1eae4af0aae0ff95b4c3afe65f2ce4ba33 (diff)
downloadports-3a08792951010f4264295deb2e4226e0d0f8493c.tar.gz
ports-3a08792951010f4264295deb2e4226e0d0f8493c.zip
- Update to 4.7.0
ChangeLog: http://code.call-cc.org/releases/4.7.0/NEWS PR: ports/157496 Submitted by: Vitaly Magerya <vmagerya@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=274963
Diffstat (limited to 'lang/chicken')
-rw-r--r--lang/chicken/Makefile8
-rw-r--r--lang/chicken/distinfo5
-rw-r--r--lang/chicken/pkg-plist173
3 files changed, 97 insertions, 89 deletions
diff --git a/lang/chicken/Makefile b/lang/chicken/Makefile
index e6d2cdd9f11b..3aa45fc2811b 100644
--- a/lang/chicken/Makefile
+++ b/lang/chicken/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= chicken
-PORTVERSION= 4.6.0
+PORTVERSION= 4.7.0
CATEGORIES= lang scheme
MASTER_SITES= http://code.call-cc.org/releases/${PORTVERSION}/
@@ -14,6 +14,7 @@ MAINTAINER= vmagerya@gmail.com
COMMENT= A Scheme-to-C compiler
USE_GMAKE= yes
+MAKEFILE= GNUmakefile
USE_LDCONFIG= yes
MAKE_ARGS+= PLATFORM=bsd PREFIX=${PREFIX} \
TOPMANDIR=${PREFIX}/man ARCH=${NEW_ARCH} \
@@ -30,6 +31,11 @@ MAN1= chicken.1 chicken-bug.1 chicken-install.1 chicken-profile.1 \
MAKE_ARGS+= HACKED_APPLY=
.endif
+post-patch:
+ @${REINPLACE_CMD} \
+ 's|^DOCDIR = .*$$|DOCDIR = ${DOCSDIR}|' \
+ ${WRKSRC}/defaults.make
+
post-install:
@${INSTALL_DATA} ${WRKSRC}/NEWS ${DOCSDIR}
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
diff --git a/lang/chicken/distinfo b/lang/chicken/distinfo
index 4c430cd866d8..50c6a2081ad0 100644
--- a/lang/chicken/distinfo
+++ b/lang/chicken/distinfo
@@ -1,3 +1,2 @@
-MD5 (chicken-4.6.0.tar.gz) = 538a93e786e550ad848a040bcd902184
-SHA256 (chicken-4.6.0.tar.gz) = c55d1dadf9941b3efbc7be9181d5c7cbc304a20c614625fbf710c0acaa1cd245
-SIZE (chicken-4.6.0.tar.gz) = 3019126
+SHA256 (chicken-4.7.0.tar.gz) = 56afdbff812febe3f98ae437716ecaa96115732f21db5063ce413e4c7449a26c
+SIZE (chicken-4.7.0.tar.gz) = 3392031
diff --git a/lang/chicken/pkg-plist b/lang/chicken/pkg-plist
index 300d41186ae5..27d3491dc7d1 100644
--- a/lang/chicken/pkg-plist
+++ b/lang/chicken/pkg-plist
@@ -6,93 +6,96 @@ bin/chicken-status
bin/chicken-uninstall
bin/csc
bin/csi
-include/chicken-config.h
-include/chicken.h
-lib/chicken/5/chicken.import.so
-lib/chicken/5/csi.import.so
-lib/chicken/5/data-structures.import.so
-lib/chicken/5/extras.import.so
-lib/chicken/5/files.import.so
-lib/chicken/5/foreign.import.so
-lib/chicken/5/irregex.import.so
-lib/chicken/5/lolevel.import.so
-lib/chicken/5/modules.db
-lib/chicken/5/ports.import.so
-lib/chicken/5/posix.import.so
-lib/chicken/5/regex.import.so
-lib/chicken/5/scheme.import.so
-lib/chicken/5/setup-api.import.so
-lib/chicken/5/setup-api.so
-lib/chicken/5/setup-download.import.so
-lib/chicken/5/setup-download.so
-lib/chicken/5/srfi-1.import.so
-lib/chicken/5/srfi-13.import.so
-lib/chicken/5/srfi-14.import.so
-lib/chicken/5/srfi-18.import.so
-lib/chicken/5/srfi-4.import.so
-lib/chicken/5/srfi-69.import.so
-lib/chicken/5/tcp.import.so
-lib/chicken/5/types.db
-lib/chicken/5/utils.import.so
+include/chicken/chicken-config.h
+include/chicken/chicken.h
+lib/chicken/6/chicken.import.so
+lib/chicken/6/csi.import.so
+lib/chicken/6/data-structures.import.so
+lib/chicken/6/extras.import.so
+lib/chicken/6/files.import.so
+lib/chicken/6/foreign.import.so
+lib/chicken/6/irregex.import.so
+lib/chicken/6/lolevel.import.so
+lib/chicken/6/modules.db
+lib/chicken/6/ports.import.so
+lib/chicken/6/posix.import.so
+lib/chicken/6/scheme.import.so
+lib/chicken/6/setup-api.import.so
+lib/chicken/6/setup-api.so
+lib/chicken/6/setup-download.import.so
+lib/chicken/6/setup-download.so
+lib/chicken/6/srfi-1.import.so
+lib/chicken/6/srfi-13.import.so
+lib/chicken/6/srfi-14.import.so
+lib/chicken/6/srfi-18.import.so
+lib/chicken/6/srfi-4.import.so
+lib/chicken/6/srfi-69.import.so
+lib/chicken/6/tcp.import.so
+lib/chicken/6/types.db
+lib/chicken/6/utils.import.so
lib/libchicken.a
lib/libchicken.so
-lib/libchicken.so.5
-%%DATADIR%%/chicken.png
+lib/libchicken.so.6
%%DATADIR%%/setup.defaults
-%%DOCSDIR%%/LICENSE
-%%DOCSDIR%%/NEWS
-%%DOCSDIR%%/README
-%%DOCSDIR%%/manual/Accessing external objects
-%%DOCSDIR%%/manual/Acknowledgements
-%%DOCSDIR%%/manual/Basic mode of operation
-%%DOCSDIR%%/manual/Bibliography
-%%DOCSDIR%%/manual/Bugs and limitations
-%%DOCSDIR%%/manual/C interface
-%%DOCSDIR%%/manual/Callbacks
-%%DOCSDIR%%/manual/Cross development
-%%DOCSDIR%%/manual/Data representation
-%%DOCSDIR%%/manual/Declarations
-%%DOCSDIR%%/manual/Deployment
-%%DOCSDIR%%/manual/Deviations from the standard
-%%DOCSDIR%%/manual/Embedding
-%%DOCSDIR%%/manual/Exceptions
-%%DOCSDIR%%/manual/Extensions
-%%DOCSDIR%%/manual/Extensions to the standard
-%%DOCSDIR%%/manual/Foreign type specifiers
-%%DOCSDIR%%/manual/Getting started
-%%DOCSDIR%%/manual/Interface to external functions and variables
-%%DOCSDIR%%/manual/Locations
-%%DOCSDIR%%/manual/Modules
-%%DOCSDIR%%/manual/Non-standard macros and special forms
-%%DOCSDIR%%/manual/Non-standard read syntax
-%%DOCSDIR%%/manual/Other support procedures
-%%DOCSDIR%%/manual/Parameters
-%%DOCSDIR%%/manual/Supported language
-%%DOCSDIR%%/manual/The R5RS standard
-%%DOCSDIR%%/manual/The User's Manual
-%%DOCSDIR%%/manual/Unit data-structures
-%%DOCSDIR%%/manual/Unit eval
-%%DOCSDIR%%/manual/Unit expand
-%%DOCSDIR%%/manual/Unit extras
-%%DOCSDIR%%/manual/Unit files
-%%DOCSDIR%%/manual/Unit library
-%%DOCSDIR%%/manual/Unit lolevel
-%%DOCSDIR%%/manual/Unit ports
-%%DOCSDIR%%/manual/Unit posix
-%%DOCSDIR%%/manual/Unit regex
-%%DOCSDIR%%/manual/Unit srfi-1
-%%DOCSDIR%%/manual/Unit srfi-13
-%%DOCSDIR%%/manual/Unit srfi-14
-%%DOCSDIR%%/manual/Unit srfi-18
-%%DOCSDIR%%/manual/Unit srfi-4
-%%DOCSDIR%%/manual/Unit srfi-69
-%%DOCSDIR%%/manual/Unit tcp
-%%DOCSDIR%%/manual/Unit utils
-%%DOCSDIR%%/manual/Using the compiler
-%%DOCSDIR%%/manual/Using the interpreter
-%%DOCSDIR%%/manual/faq
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/manual/Accessing external objects.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Acknowledgements.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Basic mode of operation.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Bibliography.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Bugs and limitations.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/C interface.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Callbacks.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Cross development.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Data representation.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Declarations.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Deployment.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Deviations from the standard.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Embedding.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Exceptions.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Extensions to the standard.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Extensions.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Foreign type specifiers.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Getting started.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Interface to external functions and variables.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Locations.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Macros.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Modules.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Non-standard macros and special forms.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Non-standard read syntax.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Other support procedures.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Parameters.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Supported language.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/The R5RS standard.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/The User's Manual.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Unit data-structures.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Unit eval.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Unit expand.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Unit extras.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Unit files.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Unit irregex.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Unit library.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Unit lolevel.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Unit ports.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Unit posix.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Unit srfi-1.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Unit srfi-13.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Unit srfi-14.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Unit srfi-18.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Unit srfi-4.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Unit srfi-69.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Unit tcp.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Unit utils.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Using the compiler.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Using the interpreter.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/chicken.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/index.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/manual.css
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%
-@dirrm %%DOCSDIR%%/manual
-@dirrm %%DOCSDIR%%
-@dirrm lib/chicken/5
+@dirrm lib/chicken/6
@dirrm lib/chicken
+@dirrm include/chicken