aboutsummaryrefslogtreecommitdiff
path: root/lang/cmucl
diff options
context:
space:
mode:
authorMartin Cracauer <cracauer@FreeBSD.org>1997-07-15 14:35:20 +0000
committerMartin Cracauer <cracauer@FreeBSD.org>1997-07-15 14:35:20 +0000
commite79ebfe1e0e19597c2acc748c6d3cd7f5657a667 (patch)
tree36dfd85ad14d9e5f4f4eba1dd9f8726b7863c45d /lang/cmucl
parentba6a1f2759c71b250b9411a86f5f081b58b2e638 (diff)
downloadports-e79ebfe1e0e19597c2acc748c6d3cd7f5657a667.tar.gz
ports-e79ebfe1e0e19597c2acc748c6d3cd7f5657a667.zip
The CMU implementation of Common Lisp, prerelease 18a
Notes
Notes: svn path=/head/; revision=7340
Diffstat (limited to 'lang/cmucl')
-rw-r--r--lang/cmucl/Makefile33
-rw-r--r--lang/cmucl/distinfo1
-rw-r--r--lang/cmucl/pkg-comment1
-rw-r--r--lang/cmucl/pkg-descr24
-rw-r--r--lang/cmucl/pkg-plist12
5 files changed, 71 insertions, 0 deletions
diff --git a/lang/cmucl/Makefile b/lang/cmucl/Makefile
new file mode 100644
index 000000000000..f8be05ad1aea
--- /dev/null
+++ b/lang/cmucl/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: CMUCL
+# Version required: 18a
+# Date created: Jul, 15, 1997
+# Whom: cracauer@cons.org "Martin Cracauer"
+#
+# $Id: Makefile,v 1.5 1997/07/15 13:35:10 cracauer Exp $
+#
+#
+
+DISTNAME= cmucl-18a.x86.FreeBSD21
+PKGNAME= cmucl-18a
+CATEGORIES= lang
+MASTER_SITES= ftp://ftp2.cons.org/pub/languages/lisp/cmucl/binaries/
+
+MAINTAINER= cracauer@cons.org
+
+NO_CONFIGURE= yes
+NO_BUILD= yes
+MAN1= lisp.1 cmucl.1
+
+do-install:
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} work/bin/lisp ${PREFIX}/bin
+ -$(MKDIR) ${PREFIX}/lib/cmucl
+ (cd work && tar fc - lib) | (cd ${PREFIX}/lib/cmucl && tar fx -)
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} work/README.1st \
+ ${PREFIX}/lib/cmucl
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} work/man/man1/cmucl.1 \
+ ${PREFIX}/man/man1
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} work/man/man1/lisp.1 \
+ ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
+
diff --git a/lang/cmucl/distinfo b/lang/cmucl/distinfo
new file mode 100644
index 000000000000..a6e28f72e3d7
--- /dev/null
+++ b/lang/cmucl/distinfo
@@ -0,0 +1 @@
+MD5 (cmucl-18a.x86.FreeBSD21.tar.gz) = 2aeaf3e98870a42e1bdcd09aaba60693
diff --git a/lang/cmucl/pkg-comment b/lang/cmucl/pkg-comment
new file mode 100644
index 000000000000..5f37bc557316
--- /dev/null
+++ b/lang/cmucl/pkg-comment
@@ -0,0 +1 @@
+The CMU implementation of Common Lisp
diff --git a/lang/cmucl/pkg-descr b/lang/cmucl/pkg-descr
new file mode 100644
index 000000000000..f94584b65687
--- /dev/null
+++ b/lang/cmucl/pkg-descr
@@ -0,0 +1,24 @@
+CMUCL is the CMU implementation of Common Lisp. This is a 18a
+prerelease, probably the most stable version to get for FreeBSD. For
+further information see http://www.cons.org/cmucl/
+
+First-aid documentation is in the manpages lisp(1) and cmucl(1) and
+via the normal Common Lisp documentation runtime functions (describe
+...) (documentation ...) and (apropos ...). There is a real user
+manual that is currently adopted to 18a. See the homepage for
+pointers, we have GNU info, postscript and initial HTML files.
+
+CMUCL's strength in comparision with other Lisp systems (or dynamic
+languages in general) is its highly optimizing compiler. If you know
+how to write efficient Common Lisp code, you are free of unwanted
+memory allocation, type checks, indirections to objects. And CMUCL
+helps you to write efficient Common Lisp, it generates very
+informative warning messages about code constructs that prevent
+compilation to efficient code.
+
+Optional packages for graphical user interfaces and other Common Lisp
+applications and librarues are are on
+ftp://ftp2.cons.org/pub/languages/lisp/cmucl/binaries/ (FreeBSD-Binaries) and
+ftp://ftp2.cons.org/pub/languages/lisp/cmucl/ports/ *source)
+
+Martin Cracauer <cracauer@cons.org>
diff --git a/lang/cmucl/pkg-plist b/lang/cmucl/pkg-plist
new file mode 100644
index 000000000000..7b25c727bd10
--- /dev/null
+++ b/lang/cmucl/pkg-plist
@@ -0,0 +1,12 @@
+bin/lisp
+man/man1/cmucl.1.gz
+man/man1/lisp.1.gz
+lib/cmucl/lib/lisp.core
+lib/cmucl/lib/site-init.lisp
+lib/cmucl/lib/load-foreign.csh
+lib/cmucl/lib/config.lisp
+lib/cmucl/lib/config
+lib/cmucl/README.1st
+@dirrm lib/cmucl/lib/subsystems
+@dirrm lib/cmucl/lib
+@dirrm lib/cmucl