aboutsummaryrefslogtreecommitdiff
path: root/lang/cparser
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-03-25 08:13:17 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-03-25 08:13:17 +0000
commitf6b22cc82f529d9fdd7cd5a65cf8b24314dba2f5 (patch)
treeab4880db208f62323b078393fdb5774fb5af54d5 /lang/cparser
parent6afc01fa092f7b258aeef8950c02f3dad5695352 (diff)
downloadports-f6b22cc82f529d9fdd7cd5a65cf8b24314dba2f5.tar.gz
ports-f6b22cc82f529d9fdd7cd5a65cf8b24314dba2f5.zip
Support stage
Stop trying to remove striping from INSTALL_PROGRAM is DEBUG is set, the framework already does that
Notes
Notes: svn path=/head/; revision=349112
Diffstat (limited to 'lang/cparser')
-rw-r--r--lang/cparser/Makefile24
1 files changed, 9 insertions, 15 deletions
diff --git a/lang/cparser/Makefile b/lang/cparser/Makefile
index d98ee57eb3fa..28a64ac193bb 100644
--- a/lang/cparser/Makefile
+++ b/lang/cparser/Makefile
@@ -7,31 +7,25 @@ CATEGORIES= lang devel
MASTER_SITES= SF
MAINTAINER= sperber@FreeBSD.org
-COMMENT= A C99 compiler using libFIRM as backend
+COMMENT= C99 compiler using libFIRM as backend
LICENSE= GPLv2
-LIB_DEPENDS= firm:${PORTSDIR}/devel/libfirm
+LIB_DEPENDS= libfirm.so:${PORTSDIR}/devel/libfirm
-USE_BZIP2= yes
-USE_GMAKE= yes
-USES= pkgconfig
+USES= pkgconfig gmake tar:bzip2
-PLIST_FILES= bin/cparser
-
-MAN1= cparser.1
+PLIST_FILES= bin/cparser \
+ man/man1/cparser.1.gz
BUILDDIR= optimize
-INSTALL_CMD= ${INSTALL_PROGRAM}
OPTIONS_DEFINE= DEBUG
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDEBUG}
BUILDDIR= debug
-INSTALL_CMD= ${INSTALL_PROGRAM:S,-s,,}
.else
post-patch:
@${REINPLACE_CMD} -e 's/^variant ?= debug/variant ?= optimize/' \
@@ -39,7 +33,7 @@ post-patch:
.endif
do-install:
- @${INSTALL_CMD} ${WRKSRC}/build/${BUILDDIR}/cparser ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/cparser.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/${BUILDDIR}/cparser ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/cparser.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>