aboutsummaryrefslogtreecommitdiff
path: root/lang/csharp-mode.el
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-06-19 10:02:05 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-06-19 10:02:05 +0000
commit3d264d251825085e1b19b74b46b53eae5cec5c65 (patch)
treef3c45c98f894fa9755f820f6088f7446cfe2ebb8 /lang/csharp-mode.el
parent34ff7dab0c31f4898cc028d834a6355782cc9c93 (diff)
downloadports-3d264d251825085e1b19b74b46b53eae5cec5c65.tar.gz
ports-3d264d251825085e1b19b74b46b53eae5cec5c65.zip
Add csharp-mode.el.
After a good number of years, we noticed that there wasn't a "non-patched" version of a csharp-mode for Emacs. There were a few, but most of them had comments that they were "in progress" or "about to merge", but then we noticed that those notices were there even after a couple of months. Then, we saw a request for a csharp-mode on the cc-mode Emacs site, so we decided to follow the rules and create one that required no patching or modification to the core cc-mode engine (which is a good thing). So, this is the C# mode. WWW: http://mfgames.com/linux/csharp-mode
Notes
Notes: svn path=/head/; revision=165762
Diffstat (limited to 'lang/csharp-mode.el')
-rw-r--r--lang/csharp-mode.el/Makefile40
-rw-r--r--lang/csharp-mode.el/distinfo3
-rw-r--r--lang/csharp-mode.el/pkg-descr14
-rw-r--r--lang/csharp-mode.el/pkg-message8
4 files changed, 65 insertions, 0 deletions
diff --git a/lang/csharp-mode.el/Makefile b/lang/csharp-mode.el/Makefile
new file mode 100644
index 000000000000..f414a2aebf3d
--- /dev/null
+++ b/lang/csharp-mode.el/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: csharp-mode.el
+# Date created: 19 Jun 2006
+# Whom: Jean-Yves Lefort <jylefort@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= csharp-mode.el
+PORTVERSION= 0.5.0
+CATEGORIES= lang elisp
+MASTER_SITES= http://mfgames.com/linux/releases/
+DISTNAME= ${PORTNAME:S|.el$||}-${PORTVERSION}
+
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= Emacs/XEmacs major mode for editing C\# source code
+
+USE_BZIP2= yes
+NO_WRKSUBDIR= yes
+
+USE_EMACS= yes
+EMACS_PORT_NAME?= emacs22
+CSHARP_MODE_DIR= ${EMACS_LIBDIR_WITH_VER}/lisp
+
+PLIST_FILES= ${CSHARP_MODE_DIR}/csharp-mode.el \
+ ${CSHARP_MODE_DIR}/csharp-mode.elc
+
+post-patch:
+ @${MV} ${WRKSRC}/csharp-mode-${PORTVERSION}.el ${WRKSRC}/csharp-mode.el
+
+do-build:
+ cd ${WRKSRC} && ${EMACS_CMD} -batch -q -f batch-byte-compile csharp-mode.el
+
+do-install:
+ ${MKDIR} ${PREFIX}/${CSHARP_MODE_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/csharp-mode.* ${PREFIX}/${CSHARP_MODE_DIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/lang/csharp-mode.el/distinfo b/lang/csharp-mode.el/distinfo
new file mode 100644
index 000000000000..75e7cfdb6b4b
--- /dev/null
+++ b/lang/csharp-mode.el/distinfo
@@ -0,0 +1,3 @@
+MD5 (csharp-mode-0.5.0.tar.bz2) = e58afd4a1d708ac227ab52b1420ef2f3
+SHA256 (csharp-mode-0.5.0.tar.bz2) = 0fcec187188cd9d349a1fc1962cf9b9e257d770ca267d5b657bdf7553b910dd6
+SIZE (csharp-mode-0.5.0.tar.bz2) = 5439
diff --git a/lang/csharp-mode.el/pkg-descr b/lang/csharp-mode.el/pkg-descr
new file mode 100644
index 000000000000..a89af0a8d225
--- /dev/null
+++ b/lang/csharp-mode.el/pkg-descr
@@ -0,0 +1,14 @@
+After a good number of years, we noticed that there wasn't a "non-patched"
+version of a csharp-mode for Emacs. There were a few, but most of them had
+comments that they were "in progress" or "about to merge", but then we noticed
+that those notices were there even after a couple of months.
+
+Then, we saw a request for a csharp-mode on the cc-mode Emacs site, so we
+decided to follow the rules and create one that required no patching or
+modification to the core cc-mode engine (which is a good thing). So, this is
+the C# mode.
+
+WWW: http://mfgames.com/linux/csharp-mode
+
+- Jean-Yves Lefort
+jylefort@FreeBSD.org
diff --git a/lang/csharp-mode.el/pkg-message b/lang/csharp-mode.el/pkg-message
new file mode 100644
index 000000000000..8de392e1e987
--- /dev/null
+++ b/lang/csharp-mode.el/pkg-message
@@ -0,0 +1,8 @@
+===============================================================================
+
+To use csharp-mode, add the following lines to your ~/.emacs file:
+
+ (autoload 'csharp-mode "csharp-mode" "Major mode for editing C# code." t)
+ (setq auto-mode-alist (append '(("\\.cs$" . csharp-mode)) auto-mode-alist))
+
+===============================================================================