aboutsummaryrefslogtreecommitdiff
path: root/lang/dice
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-02-22 14:06:04 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-02-22 14:06:04 +0000
commit95dc5b97dcd027c0ea021995c9db7191f70050ce (patch)
tree1d7de8b49f114de2addb4a9bf6b5388e19482fc6 /lang/dice
parent8bf307c65183d1812cdb4cc0f723c5f792874149 (diff)
downloadports-95dc5b97dcd027c0ea021995c9db7191f70050ce.tar.gz
ports-95dc5b97dcd027c0ea021995c9db7191f70050ce.zip
flynn@energyhq.homeip.net wrote:
Dice is Matt Dillon's (yes, our FreeBSD guru :) portable 68000 C Compiler. Found it odd that there's not a port for this, considering that the author of the compiler is a FreeBSD commiter. PR: 34449 Submitted by: flynn@energyhq.homeip.net
Notes
Notes: svn path=/head/; revision=55084
Diffstat (limited to 'lang/dice')
-rw-r--r--lang/dice/Makefile34
-rw-r--r--lang/dice/distinfo1
-rw-r--r--lang/dice/files/Makefile12
-rw-r--r--lang/dice/pkg-comment1
-rw-r--r--lang/dice/pkg-descr9
-rw-r--r--lang/dice/pkg-plist99
6 files changed, 156 insertions, 0 deletions
diff --git a/lang/dice/Makefile b/lang/dice/Makefile
new file mode 100644
index 000000000000..acbda341fc9f
--- /dev/null
+++ b/lang/dice/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: dice
+# Date created: Wed Jan 30 13:26:52 CET 2002
+# Whom: Miguel Mendez <flynn@energyhq.homeip.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dice
+PORTVERSION= 3.15
+CATEGORIES= lang devel
+MASTER_SITES= http://www.obviously.com/dice/
+DISTNAME= ${PORTNAME}-rel-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= flynn@energyhq.homeip.net
+
+post-patch:
+ @${CP} ${FILESDIR}/Makefile ${WRKSRC}
+
+do-install:
+ @for i in ${WRKSRC}/ubin/*; \
+ do \
+ ${INSTALL_PROGRAM} $$i ${PREFIX}/bin; \
+ done
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/dice
+ @for i in ${WRKSRC}/doc/* ; \
+ do \
+ ${INSTALL_DATA} $$i ${PREFIX}/share/doc/dice; \
+ done
+.endif
+
+.include <bsd.port.mk>
diff --git a/lang/dice/distinfo b/lang/dice/distinfo
new file mode 100644
index 000000000000..31227e7f3cbd
--- /dev/null
+++ b/lang/dice/distinfo
@@ -0,0 +1 @@
+MD5 (dice-rel-3.15.tgz) = 14bf25b7d82a2e3d02921997c5998126
diff --git a/lang/dice/files/Makefile b/lang/dice/files/Makefile
new file mode 100644
index 000000000000..c44199bbaabf
--- /dev/null
+++ b/lang/dice/files/Makefile
@@ -0,0 +1,12 @@
+# Makefile for dice
+# Created by Miguel Mendez <flynn@energyhq.homeip.net>
+# $FreeBSD$
+
+DCCOPTS= -3.0 -//
+DINCLUDE= `pwd`/include/
+
+all:
+ cd suplib && ${MAKE} && ${MAKE} install
+ cd src && ${MAKE} && ${MAKE} install
+
+install:
diff --git a/lang/dice/pkg-comment b/lang/dice/pkg-comment
new file mode 100644
index 000000000000..af9f6146ce79
--- /dev/null
+++ b/lang/dice/pkg-comment
@@ -0,0 +1 @@
+DICE - The Amiga/embedded/generic 68000 C compiler
diff --git a/lang/dice/pkg-descr b/lang/dice/pkg-descr
new file mode 100644
index 000000000000..82664d4750d0
--- /dev/null
+++ b/lang/dice/pkg-descr
@@ -0,0 +1,9 @@
+Free source code for a the complete DICE C compiler core. Will compile easily
+on the Amiga, FreeBSD, Linux and other Unix systems. Able to create both
+relocatable and fixed address (ROM) based code. Quite suitable for embedded
+68K development on chips such as the 68000 / 68302 / 68306.
+
+WWW: http://www.obviously.com/dice/
+Author: Matt Dillon <dillon@apollo.backplane.com>
+
+- Miguel Mendez <flynn@energyhq.homeip.net>
diff --git a/lang/dice/pkg-plist b/lang/dice/pkg-plist
new file mode 100644
index 000000000000..356622202f6d
--- /dev/null
+++ b/lang/dice/pkg-plist
@@ -0,0 +1,99 @@
+bin/Join
+bin/bintohex
+bin/das
+bin/dc1
+bin/dcc
+bin/dcpp
+bin/dlink
+bin/dmake
+bin/dobj
+bin/fdtolib
+bin/fdtopragma
+bin/hunks
+bin/istrip
+bin/lbmake
+bin/libtos
+bin/makeproto
+bin/romable
+bin/uprev
+share/doc/dice/BEGINNER_README.DOC
+share/doc/dice/COMPILER.DOC
+share/doc/dice/EXTENSIONS.DOC
+share/doc/dice/GERMAN_DISTRIBUTOR.DOC
+share/doc/dice/KnownBugs
+share/doc/dice/REGARGS.DOC
+share/doc/dice/REGISTER.DOC
+share/doc/dice/TUTORIAL
+share/doc/dice/UTILITIES.DOC
+share/doc/dice/_MAIN.DOC
+share/doc/dice/alib.doc
+share/doc/dice/ame.doc
+share/doc/dice/amiga.doc
+share/doc/dice/ascii_chart.doc
+share/doc/dice/assert.doc
+share/doc/dice/autorefs.doc
+share/doc/dice/bintohex.doc
+share/doc/dice/c_quickref.doc
+share/doc/dice/cat.doc
+share/doc/dice/chap08.doc
+share/doc/dice/chap12.doc
+share/doc/dice/compat.doc
+share/doc/dice/ctype.doc
+share/doc/dice/das.doc
+share/doc/dice/dc1.doc
+share/doc/dice/dcc.doc
+share/doc/dice/dcpp.doc
+share/doc/dice/dice_commands.doc
+share/doc/dice/dice_debugger.doc
+share/doc/dice/dice_extras.doc
+share/doc/dice/dice_libraries.doc
+share/doc/dice/dicehelp.doc
+share/doc/dice/dlink.doc
+share/doc/dice/dmake.doc
+share/doc/dice/dme.doc
+share/doc/dice/dme.refs
+share/doc/dice/dobj.doc
+share/doc/dice/dprof.doc
+share/doc/dice/dsearch.doc
+share/doc/dice/du.doc
+share/doc/dice/dupdate.doc
+share/doc/dice/dynamic.doc
+share/doc/dice/errors.doc
+share/doc/dice/expand.doc
+share/doc/dice/extra.doc
+share/doc/dice/extras.doc
+share/doc/dice/fd.doc
+share/doc/dice/fdtoinline.doc
+share/doc/dice/fdtolib.doc
+share/doc/dice/float.doc
+share/doc/dice/flush.doc
+share/doc/dice/head.doc
+share/doc/dice/istrip.doc
+share/doc/dice/lbmake.doc
+share/doc/dice/lhex.doc
+share/doc/dice/libmake.doc
+share/doc/dice/libtos.doc
+share/doc/dice/loadabs.c
+share/doc/dice/loadabs.doc
+share/doc/dice/loadfile.doc
+share/doc/dice/makeproto.doc
+share/doc/dice/memoration.doc
+share/doc/dice/memory.doc
+share/doc/dice/methodology.doc
+share/doc/dice/mkrefs
+share/doc/dice/mungwall.doc
+share/doc/dice/owner.doc
+share/doc/dice/quickref.doc
+share/doc/dice/rexx.doc
+share/doc/dice/romable.doc
+share/doc/dice/setjmp.doc
+share/doc/dice/signal.doc
+share/doc/dice/stdio.doc
+share/doc/dice/stdlib.doc
+share/doc/dice/string.doc
+share/doc/dice/sushi.doc
+share/doc/dice/time.doc
+share/doc/dice/tstat.doc
+share/doc/dice/unix.doc
+share/doc/dice/wedge.doc
+@dirrm share/doc/dice