aboutsummaryrefslogtreecommitdiff
path: root/lang/etoile-compiler
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-11-29 12:27:35 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-11-29 12:27:35 +0000
commitda1acef930591edd2395bc4babe11dec478b0328 (patch)
tree081bf2e3a8a46681df703f81a5acaeb68ba1cff8 /lang/etoile-compiler
parent8b03de786cc6812a0c7afa7c9cceac112a3335ec (diff)
downloadports-da1acef930591edd2395bc4babe11dec478b0328.tar.gz
ports-da1acef930591edd2395bc4babe11dec478b0328.zip
Pragmatic Smalltalk Compiler
This is an implementation of Smalltalk designed to run on top of an Objective-C runtime. WWW: http://www.etoile-project.org/
Notes
Notes: svn path=/head/; revision=223530
Diffstat (limited to 'lang/etoile-compiler')
-rw-r--r--lang/etoile-compiler/Makefile38
-rw-r--r--lang/etoile-compiler/distinfo3
-rw-r--r--lang/etoile-compiler/pkg-descr6
3 files changed, 47 insertions, 0 deletions
diff --git a/lang/etoile-compiler/Makefile b/lang/etoile-compiler/Makefile
new file mode 100644
index 000000000000..ee8adad7e620
--- /dev/null
+++ b/lang/etoile-compiler/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: etoile-compiler
+# Date created: 26 Nov 2008
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= compiler
+PORTVERSION= 0.4.0
+CATEGORIES= lang gnustep
+MASTER_SITES= http://download.gna.org/etoile/
+PKGNAMEPREFIX= etoile-
+DISTNAME= etoile-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Etoile Project Smalltalk Compiler
+
+USE_BZIP2= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
+USE_GNUSTEP_LOCAL_LIBS+= EtoileFoundation:${FOUNDATION_PORT}
+USE_GNUSTEP_LOCAL_LIBS+= LanguageKit:${LANGUAGEKIT_PORT}
+USE_GNUSTEP_LOCAL_LIBS+= SmalltalkKit:${SMALLTALKKIT_PORT}
+
+DEFAULT_LIBVERSION= 0.1
+WRKSRC= ${WRKDIR}/Etoile-${PORTVERSION}
+USE_GNUSTEP_MAKE_DIRS+= Languages/Compiler
+PLIST_FILES= Local/Tools/edlc
+
+FOUNDATION_PORT?= devel/etoile-foundation
+LANGUAGEKIT_PORT?= lang/etoile-languagekit
+SMALLTALKKIT_PORT?= lang/etoile-smalltalkkit
+
+.include <bsd.port.mk>
diff --git a/lang/etoile-compiler/distinfo b/lang/etoile-compiler/distinfo
new file mode 100644
index 000000000000..2c1e8a612c54
--- /dev/null
+++ b/lang/etoile-compiler/distinfo
@@ -0,0 +1,3 @@
+MD5 (etoile-0.4.0.tar.bz2) = 7c33baf8ec3a708d0d419b1e137452de
+SHA256 (etoile-0.4.0.tar.bz2) = 05b5f01932aaad2ae6251ae01a1ad5376d29c984ee83d9fb62688c8d4a20237a
+SIZE (etoile-0.4.0.tar.bz2) = 8225128
diff --git a/lang/etoile-compiler/pkg-descr b/lang/etoile-compiler/pkg-descr
new file mode 100644
index 000000000000..58553edd7e22
--- /dev/null
+++ b/lang/etoile-compiler/pkg-descr
@@ -0,0 +1,6 @@
+Pragmatic Smalltalk Compiler
+
+This is an implementation of Smalltalk designed to run
+on top of an Objective-C runtime.
+
+WWW: http://www.etoile-project.org/