aboutsummaryrefslogtreecommitdiff
path: root/lang/expect
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2007-03-27 23:59:22 +0000
committerShaun Amott <shaun@FreeBSD.org>2007-03-27 23:59:22 +0000
commit4edca4d9df00a0d5e7e7a008933cef8d9060ac6d (patch)
tree1744b6e733196f44b0ff4d70516109ad59d6c61a /lang/expect
parent6316da55999a15891cedd432ffb106c348a0f290 (diff)
downloadports-4edca4d9df00a0d5e7e7a008933cef8d9060ac6d.tar.gz
ports-4edca4d9df00a0d5e7e7a008933cef8d9060ac6d.zip
Let expect detect and use openpty(3), and therefore allow it to utilise
as many ptys as we support. The breakage was caused by a bogus (or temporarily introduced) CONFIGURE_ENV. PR: ports/108311 Submitted by: Lars Erik Gullerud <lerik@nolink.net>
Notes
Notes: svn path=/head/; revision=188606
Diffstat (limited to 'lang/expect')
-rw-r--r--lang/expect/Makefile3
-rw-r--r--lang/expect/files/patch-pty_termios.c20
2 files changed, 1 insertions, 22 deletions
diff --git a/lang/expect/Makefile b/lang/expect/Makefile
index d78c36ff2e49..a8827648b769 100644
--- a/lang/expect/Makefile
+++ b/lang/expect/Makefile
@@ -6,7 +6,7 @@
PORTNAME= expect
PORTVERSION= 5.43.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang tcl84 tk84
MASTER_SITES= http://expect.nist.gov/src/
@@ -44,7 +44,6 @@ CONFIGURE_ARGS?=--enable-shared \
--with-tclconfig=${LOCALBASE}/lib/tcl8.4 \
--with-tclinclude=${LOCALBASE}/include/tcl8.4 \
${TK_CONFIG_ARGS}
-CONFIGURE_ENV= LDFLAGS="-lutil"
.if !defined(NO_MAN_INSTALL)
MAN1= autoexpect.1 cryptdir.1 decryptdir.1 dislocate.1 \
diff --git a/lang/expect/files/patch-pty_termios.c b/lang/expect/files/patch-pty_termios.c
deleted file mode 100644
index 64a9cca5408d..000000000000
--- a/lang/expect/files/patch-pty_termios.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- pty_termios.c.orig Fri May 7 17:46:03 2004
-+++ pty_termios.c Fri Oct 6 01:17:48 2006
-@@ -166,7 +166,7 @@
- static char *slave_bank;
- static char *slave_num;
- #else
--static char banks[] = "pqrstuvwxyzPQRSTUVWXYZ";
-+static char banks[] = "pqrsPQRS"; /* FreeBSD scheme */
- static char master_name[] = "/dev/ptyXX";
- static char slave_name [] = "/dev/ttyXX";
- #endif /* HAVE_PTYM */
-@@ -489,7 +489,7 @@
- *tty_bank = *bank;
- *tty_num = '0';
- if (stat(master_name, &stat_buf) < 0) break;
-- for (hex = "0123456789abcdef";*hex;hex++) {
-+ for (hex = "0123456789abcdefghijklmnopqrstuv";*hex;hex++) {
- *tty_num = *hex;
- strcpy(slave_name,master_name);
- *tty_type = 't';