aboutsummaryrefslogtreecommitdiff
path: root/lang/ferite
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-04-13 17:31:57 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-04-13 17:31:57 +0000
commitdf4416fbe9de291e66d907c029e350218408e123 (patch)
tree627cebc05c629c172c3ecde95e0016f18e01224b /lang/ferite
parent3233cdd00a7d0787d5098e846bcde6198a6d814d (diff)
downloadports-df4416fbe9de291e66d907c029e350218408e123.tar.gz
ports-df4416fbe9de291e66d907c029e350218408e123.zip
USE_LIBTOOL instead of local patch
Notes
Notes: svn path=/head/; revision=133259
Diffstat (limited to 'lang/ferite')
-rw-r--r--lang/ferite/Makefile1
-rw-r--r--lang/ferite/files/patch-ltmain.sh36
2 files changed, 1 insertions, 36 deletions
diff --git a/lang/ferite/Makefile b/lang/ferite/Makefile
index c0f7ab668f96..76229168e610 100644
--- a/lang/ferite/Makefile
+++ b/lang/ferite/Makefile
@@ -18,6 +18,7 @@ COMMENT= An embeddable scripting language
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
xml2.5:${PORTSDIR}/textproc/libxml2
+USE_LIBTOOL_VER=15
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/lang/ferite/files/patch-ltmain.sh b/lang/ferite/files/patch-ltmain.sh
deleted file mode 100644
index 8eff0c638517..000000000000
--- a/lang/ferite/files/patch-ltmain.sh
+++ /dev/null
@@ -1,36 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh.orig Wed Jan 9 08:46:56 2002
-+++ ltmain.sh Wed Jan 9 12:09:50 2002
-@@ -958,6 +958,7 @@
- ;;
-
- -avoid-version)
-+ build_old_libs=no
- avoid_version=yes
- continue
- ;;
-@@ -2462,6 +2463,9 @@
- *-*-openbsd* | *-*-freebsd*)
- # Do not include libc due to us having libc/libc_r.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test $build_libtool_need_lc = "yes"; then
-@@ -4247,10 +4251,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"