aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc295
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-12-04 06:38:33 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-12-04 06:38:33 +0000
commit9d50625beb9c814b0342e0b803c5b820e4ef3c83 (patch)
treefcdfd85ef457207998b07fcfa07783b489c0fe0b /lang/gcc295
parent6adf02f268a098f9f45ae3a10e745225077ba07f (diff)
downloadports-9d50625beb9c814b0342e0b803c5b820e4ef3c83.tar.gz
ports-9d50625beb9c814b0342e0b803c5b820e4ef3c83.zip
The __WORD_BIT constant in GCC's stl_bvector.h caused a namespace
conflict which kept the mailsync port from compiling. Resolve it.
Notes
Notes: svn path=/head/; revision=94877
Diffstat (limited to 'lang/gcc295')
-rw-r--r--lang/gcc295/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/lang/gcc295/Makefile b/lang/gcc295/Makefile
index ac71f565fec2..878eccc21eec 100644
--- a/lang/gcc295/Makefile
+++ b/lang/gcc295/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 2.95.3
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= releases/${PKGNAME}
@@ -58,6 +59,11 @@ MAN1= cccp.1 g++295.1 gcc295.1
pre-patch:
@${MV} ${WRKSRC}/gcc/config/i386/freebsd.h ${WRKSRC}/gcc/config/i386/freebsd-aout.h
@${MV} ${WRKSRC}/gcc/config/i386/freebsd-elf.h ${WRKSRC}/gcc/config/i386/freebsd.h
+ @${MV} ${WRKSRC}/libstdc++/stl/stl_bvector.h \
+ ${WRKSRC}/libstdc++/stl/stl_bvector.h.orig
+ @${SED} -e "s,_WORD_BIT,_WORD_BIT_GCC295,g" \
+ < ${WRKSRC}/libstdc++/stl/stl_bvector.h.orig \
+ > ${WRKSRC}/libstdc++/stl/stl_bvector.h
pre-configure:
@(MAJ=`/sbin/sysctl -n kern.osreldate | ${SED} -e '/.....$$/s///'` ; \