aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc33
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2000-02-14 11:39:38 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2000-02-14 11:39:38 +0000
commit8aeb26324208c469d8e1bda3b5f021bf6e065163 (patch)
treef71197edf1204855250c2a1f32e6d12a54de5df9 /lang/gcc33
parent30721dfa47ce3d41239a122895134d2a58d5df34 (diff)
downloadports-8aeb26324208c469d8e1bda3b5f021bf6e065163.tar.gz
ports-8aeb26324208c469d8e1bda3b5f021bf6e065163.zip
Upgrade to the 2000-02-07 GCC 2.96 development snapshot.
Notes
Notes: svn path=/head/; revision=25815
Diffstat (limited to 'lang/gcc33')
-rw-r--r--lang/gcc33/Makefile2
-rw-r--r--lang/gcc33/distinfo10
-rw-r--r--lang/gcc33/files/patch-ad30
-rw-r--r--lang/gcc33/files/patch-af31
-rw-r--r--lang/gcc33/files/patch-ar9
-rw-r--r--lang/gcc33/files/patch-fa56
-rw-r--r--lang/gcc33/pkg-plist22
7 files changed, 75 insertions, 85 deletions
diff --git a/lang/gcc33/Makefile b/lang/gcc33/Makefile
index 7e19127dbee8..8adab151e458 100644
--- a/lang/gcc33/Makefile
+++ b/lang/gcc33/Makefile
@@ -7,7 +7,7 @@
# $FreeBSD$
#
-SNAPDATE= 2000-01-10
+SNAPDATE= 2000-02-07
SNAPVER= ${SNAPDATE:S/-//g}
DISTNAME= gcc-2.96
diff --git a/lang/gcc33/distinfo b/lang/gcc33/distinfo
index 020c4a14328b..f986ab4a25f8 100644
--- a/lang/gcc33/distinfo
+++ b/lang/gcc33/distinfo
@@ -1,5 +1,5 @@
-MD5 (egcs-core-20000110.tar.gz) = e47ca05ab5ce7e18ce4a506555d60f81
-MD5 (egcs-g++-20000110.tar.gz) = c19564a16c0c17845d50dc190c5741f9
-MD5 (egcs-g77-20000110.tar.gz) = 35c1df043f600a70b0c2dbb493312af3
-MD5 (egcs-java-20000110.tar.gz) = 126b2a84f69cf771ad68c087e05f0b04
-MD5 (egcs-objc-20000110.tar.gz) = 70bb4f393cb07c706008d310cd5fb506
+MD5 (egcs-core-20000207.tar.gz) = aeb16c43745a1192db09629df8d7a63b
+MD5 (egcs-g++-20000207.tar.gz) = 9973693120531615e8a28c40cbb17e10
+MD5 (egcs-g77-20000207.tar.gz) = fa19219b4aab5ba4ef19a21ec66d553b
+MD5 (egcs-java-20000207.tar.gz) = 47cde2f432c910dbb5587f7d5eb94238
+MD5 (egcs-objc-20000207.tar.gz) = 257d673cfabadcd1f2e289d6f21a9715
diff --git a/lang/gcc33/files/patch-ad b/lang/gcc33/files/patch-ad
index b838666b14fa..934da77780a4 100644
--- a/lang/gcc33/files/patch-ad
+++ b/lang/gcc33/files/patch-ad
@@ -1,21 +1,20 @@
---- gcc/config/i386/freebsd-aout.h.orig Tue Jun 1 17:02:37 1999
-+++ gcc/config/i386/freebsd-aout.h Mon Jun 14 14:11:20 1999
-@@ -32,12 +36,10 @@
- #include "i386/perform.h"
+--- gcc/config/i386/freebsd-aout.h.orig Sun Jan 30 23:28:05 2000
++++ gcc/config/i386/freebsd-aout.h Fri Feb 4 05:19:16 2000
+@@ -31,12 +31,7 @@
/* This goes away when the math-emulator is fixed */
--#undef TARGET_DEFAULT
+ #undef TARGET_DEFAULT
-#define TARGET_DEFAULT \
- (MASK_80387 | MASK_IEEE_FP | MASK_FLOAT_RETURNS | MASK_NO_FANCY_MATH_387)
+-
+-#undef CPP_PREDEFINES
+-#define CPP_PREDEFINES "-Dunix -D__FreeBSD__\
+- -Asystem(unix) -Asystem(bsd) -Asystem(FreeBSD)"
+#define TARGET_CPU_DEFAULT 0400 /* TARGET_NO_FANCY_MATH_387 */
- #undef CPP_PREDEFINES
--#define CPP_PREDEFINES "-Dunix -Di386 -D__FreeBSD__ -Asystem(unix) -Asystem(FreeBSD) -Acpu(i386) -Amachine(i386)"
-+#define CPP_PREDEFINES "-Di386 -Acpu(i386) -Amachine(i386)" CPP_FBSD_PREDEFINES
-
/* Like the default, except no -lg. */
#define LIB_SPEC "%{!shared:%{!pg:-lc}%{pg:-lc_p}}"
-@@ -87,14 +89,6 @@
+@@ -84,14 +79,6 @@
necessary when compiling PIC code. */
#define JUMP_TABLES_IN_TEXT_SECTION 1
@@ -30,7 +29,7 @@
/* i386 freebsd still uses old binutils that don't insert nops by default
when the .align directive demands to insert extra space in the text
-@@ -105,19 +99,18 @@
+@@ -102,19 +89,18 @@
/* Profiling routines, partially copied from i386/osfrose.h. */
@@ -53,7 +52,7 @@
fprintf (FILE, "\tcall mcount\n"); \
} \
}
-@@ -135,6 +128,7 @@
+@@ -132,6 +118,7 @@
#define TYPE_ASM_OP ".type"
#define SIZE_ASM_OP ".size"
@@ -61,7 +60,7 @@
/* The following macro defines the format used to output the second
operand of the .type assembler directive. Different svr4 assemblers
-@@ -144,6 +138,12 @@
+@@ -141,6 +128,12 @@
#define TYPE_OPERAND_FMT "@%s"
@@ -74,9 +73,12 @@
/* Write the extra assembler code needed to declare a function's result.
Most svr4 assemblers don't require any special declaration of the
result value, but there are exceptions. */
-@@ -245,3 +245,5 @@
+@@ -242,6 +235,8 @@
#define STARTFILE_SPEC \
"%{shared:c++rt0.o%s} \
%{!shared:%{pg:gcrt0.o%s}%{!pg:%{static:scrt0.o%s}%{!static:crt0.o%s}}}"
+
+#define MD_STARTFILE_PREFIX "/usr/lib/aout/"
+
+ /* Define this so we can compile MS code for use with WINE. */
+ #define HANDLE_PRAGMA_PACK_PUSH_POP
diff --git a/lang/gcc33/files/patch-af b/lang/gcc33/files/patch-af
index c1fbd05ffed6..33a8f0886e01 100644
--- a/lang/gcc33/files/patch-af
+++ b/lang/gcc33/files/patch-af
@@ -1,8 +1,8 @@
---- gcc/config/i386/freebsd.h.orig Mon Nov 22 22:17:32 1999
-+++ gcc/config/i386/freebsd.h Wed Dec 15 02:32:20 1999
-@@ -117,6 +117,10 @@
- : ((n) >= FIRST_STACK_REG && (n) <= LAST_STACK_REG) ? (n)+3 \
- : (-1))
+--- gcc/config/i386/freebsd.h.orig Sun Jan 30 23:28:05 2000
++++ gcc/config/i386/freebsd.h Fri Feb 4 05:22:36 2000
+@@ -52,6 +52,10 @@
+ #undef DBX_REGISTER_NUMBER
+ #define DBX_REGISTER_NUMBER(n) svr4_dbx_register_map[n]
+/* Don't use EGCS's normal profiling code -- we have our own fine-grained
+ basic block profiling. */
@@ -11,13 +11,15 @@
/* Tell final.c that we don't need a label passed to mcount. */
#undef FUNCTION_PROFILER
-@@ -140,7 +144,15 @@
+@@ -73,11 +77,15 @@
+
+ #undef WCHAR_TYPE_SIZE
#define WCHAR_TYPE_SIZE BITS_PER_WORD
-
- #undef CPP_PREDEFINES
--#define CPP_PREDEFINES "-Di386 -Dunix -D__ELF__ -D__FreeBSD__ -Asystem(unix) -Asystem(FreeBSD) -Acpu(i386) -Amachine(i386)"
-+#define CPP_PREDEFINES "-Di386 -Acpu(i386) -Amachine(i386)" CPP_FBSD_PREDEFINES
-+
+-
+-#undef CPP_PREDEFINES
+-#define CPP_PREDEFINES "-Dunix -D__ELF__ -D__FreeBSD__\
+- -Asystem(unix) -Asystem(bsd) -Asystem(FreeBSD)"
+
+#undef CC1_SPEC
+#define CC1_SPEC "\
+ %{gline:%{!g:%{!g0:%{!g1:%{!g2: -g1}}}}} \
@@ -25,10 +27,11 @@
+
+#undef ASM_SPEC
+#define ASM_SPEC "%{v*: -v} %{maout: %{fpic:-k} %{fPIC:-k}}"
-
++
/* Provide a STARTFILE_SPEC appropriate for FreeBSD. Here we add
the magical crtbegin.o file (see crtstuff.c) which provides part
-@@ -149,11 +161,11 @@
+ of the support for getting C++ file-scope static object constructed
+@@ -85,11 +93,11 @@
#undef STARTFILE_SPEC
#define STARTFILE_SPEC \
@@ -45,7 +48,7 @@
/* Provide a ENDFILE_SPEC appropriate for FreeBSD. Here we tack on
the magical crtend.o file (see crtstuff.c) which provides part of
-@@ -163,7 +175,7 @@
+@@ -99,7 +107,7 @@
#undef ENDFILE_SPEC
#define ENDFILE_SPEC \
diff --git a/lang/gcc33/files/patch-ar b/lang/gcc33/files/patch-ar
index f2200f115da8..e6a4c8ad30b0 100644
--- a/lang/gcc33/files/patch-ar
+++ b/lang/gcc33/files/patch-ar
@@ -1,12 +1,15 @@
--- gcc/config/freebsd.h.orig Mon Nov 22 22:17:32 1999
-+++ gcc/config/freebsd.h Sat Dec 18 14:42:03 1999
-@@ -48,13 +48,23 @@
++++ gcc/config/freebsd.h Fri Feb 4 05:29:31 2000
+@@ -48,13 +48,26 @@
#undef WORD_SWITCH_TAKES_ARG
#define WORD_SWITCH_TAKES_ARG(STR) (FBSD_WORD_SWITCH_TAKES_ARG(STR))
+/* Place spaces around this string. We depend on string splicing to produce
+ the final CPP_PREDEFINES value. */
-+#define CPP_FBSD_PREDEFINES " -Dunix -D__FreeBSD__ -Asystem(unix) -Asystem(FreeBSD) "
++#define FBSD_CPP_PREDEFINES " -Dunix -D__FreeBSD__ -Asystem(unix) -Asystem(bsd) -Asystem(FreeBSD) "
++
++#undef CPP_PREDEFINES
++#define CPP_PREDEFINES FBSD_CPP_PREDEFINES
+
/* Provide a CPP_SPEC appropriate for FreeBSD. We just deal with the GCC
option `-posix', and PIC issues. */
diff --git a/lang/gcc33/files/patch-fa b/lang/gcc33/files/patch-fa
index 7f5e0e611ae8..984c773d8c16 100644
--- a/lang/gcc33/files/patch-fa
+++ b/lang/gcc33/files/patch-fa
@@ -1,15 +1,15 @@
---- gcc/c-common.c.orig Mon Feb 15 16:40:05 1999
-+++ gcc/c-common.c Tue Mar 30 03:35:22 1999
-@@ -61,7 +61,7 @@
- int, int, int));
- static void init_attributes PROTO((void));
- static void record_function_format PROTO((tree, tree, enum format_type,
-- int, int));
-+ int, int, int));
- static void record_international_format PROTO((tree, tree, int));
-
- /* Keep a stack of if statements. We record the number of compound
-@@ -669,6 +669,7 @@
+--- gcc/c-common.c.orig Mon Jan 24 12:10:00 2000
++++ gcc/c-common.c Tue Feb 1 02:43:39 2000
+@@ -152,7 +152,7 @@
+ int, int, int));
+ static void init_attributes PARAMS ((void));
+ static void record_function_format PARAMS ((tree, tree, enum format_type,
+- int, int));
++ int, int, int));
+ static void record_international_format PARAMS ((tree, tree, int));
+ static tree c_find_base_decl PARAMS ((tree));
+ static int default_valid_lang_attribute PARAMS ((tree, tree, tree, tree));
+@@ -812,6 +812,7 @@
= TREE_VALUE (TREE_CHAIN (TREE_CHAIN (args)));
int format_num;
int first_arg_num;
@@ -17,8 +17,8 @@
enum format_type format_type;
tree argument;
int arg_num;
-@@ -682,7 +683,7 @@
-
+@@ -825,7 +826,7 @@
+
if (TREE_CODE (format_type_id) != IDENTIFIER_NODE)
{
- error ("unrecognized format specifier");
@@ -26,9 +26,9 @@
continue;
}
else
-@@ -690,12 +691,26 @@
- char *p = IDENTIFIER_POINTER (format_type_id);
-
+@@ -833,12 +834,26 @@
+ const char *p = IDENTIFIER_POINTER (format_type_id);
+
if (!strcmp (p, "printf") || !strcmp (p, "__printf__"))
+ {
+ format_type = printf_format_type;
@@ -52,8 +52,8 @@
+ }
else
{
- error ("`%s' is an unrecognized format function type", p);
-@@ -766,7 +781,8 @@
+ warning ("`%s' is an unrecognized format function type", p);
+@@ -909,7 +924,8 @@
record_function_format (DECL_NAME (decl),
DECL_ASSEMBLER_NAME (decl),
@@ -63,7 +63,7 @@
break;
}
-@@ -1010,6 +1026,11 @@
+@@ -1213,6 +1229,11 @@
} format_char_info;
static format_char_info print_char_table[] = {
@@ -75,7 +75,7 @@
{ "di", 0, T_I, T_I, T_I, T_L, T_LL, T_LL, T_ST, "-wp0 +" },
{ "oxX", 0, T_UI, T_UI, T_UI, T_UL, T_ULL, T_ULL, T_ST, "-wp0#" },
{ "u", 0, T_UI, T_UI, T_UI, T_UL, T_ULL, T_ULL, T_ST, "-wp0" },
-@@ -1070,6 +1091,7 @@
+@@ -1273,6 +1294,7 @@
tree name; /* identifier such as "printf" */
tree assembler_name; /* optional mangled identifier (for C++) */
enum format_type format_type; /* type of format (printf, scanf, etc.) */
@@ -83,7 +83,7 @@
int format_num; /* number of format argument */
int first_arg_num; /* number of first arg (zero for varargs) */
} function_format_info;
-@@ -1102,25 +1124,25 @@
+@@ -1305,25 +1327,25 @@
init_function_format_info ()
{
record_function_format (get_identifier ("printf"), NULL_TREE,
@@ -119,7 +119,7 @@
record_international_format (get_identifier ("gettext"), NULL_TREE, 1);
record_international_format (get_identifier ("dgettext"), NULL_TREE, 2);
-@@ -1137,11 +1159,12 @@
+@@ -1340,11 +1362,12 @@
(e.g. for varargs such as vfprintf). */
static void
@@ -133,7 +133,7 @@
int format_num;
int first_arg_num;
{
-@@ -1165,6 +1188,7 @@
+@@ -1368,6 +1391,7 @@
}
info->format_type = format_type;
@@ -141,7 +141,7 @@
info->format_num = format_num;
info->first_arg_num = first_arg_num;
}
-@@ -1314,7 +1338,8 @@
+@@ -1521,7 +1545,8 @@
if (integer_zerop (format_tree))
{
@@ -151,7 +151,7 @@
return;
}
if (TREE_CODE (format_tree) != ADDR_EXPR)
-@@ -1485,12 +1510,13 @@
+@@ -1710,12 +1735,13 @@
It will work on most machines, because size_t and int
have the same mode. But might as well warn anyway,
since it will fail on other machines. */
@@ -166,7 +166,7 @@
}
}
else
-@@ -1535,6 +1561,53 @@
+@@ -1760,6 +1786,53 @@
}
}
}
@@ -220,7 +220,7 @@
aflag = 0;
-@@ -1604,7 +1677,8 @@
+@@ -1828,7 +1901,8 @@
switch (info->format_type)
{
case printf_format_type:
diff --git a/lang/gcc33/pkg-plist b/lang/gcc33/pkg-plist
index 8b45855df51e..c498178645e2 100644
--- a/lang/gcc33/pkg-plist
+++ b/lang/gcc33/pkg-plist
@@ -77,7 +77,6 @@ lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/map.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/memory
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/multimap.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/multiset.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/new.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/numeric
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/ostream.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/pair.h
@@ -237,7 +236,6 @@ lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/collect2
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/f771
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/README
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/assert.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/curses.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/exception
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/float.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g2c.h
@@ -250,33 +248,17 @@ lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/proto.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/stdarg.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/stdbool.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/stddef.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/stdlib.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/stdio.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/syslimits.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/typeinfo
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/values.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/varargs.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/zconf.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/net/netisr.h
+lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/machine/ansi.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/net/zlib.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/netatm/atm_if.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/netatm/atm_ioctl.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/netatm/atm_var.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/netatm/kern_include.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/netatm/port.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/netinet/ip_compat.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/netinet/ip_fil.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/netinet/ip_nat.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/netipx/ipx.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/netkey/keysock.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/netns/ns.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/netns/spp_var.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/rpc/auth.h
+lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/rpc/des.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/rpc/svc.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/rpc/types.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/security/_pam_compat.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/sys/dvdio.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/sys/types.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/objc/NXConstStr.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/objc/Object.h
lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/objc/Protocol.h