aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc34
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-03-25 18:30:26 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-03-25 18:30:26 +0000
commitc143c5eaa46cdef79aa6f45bd1420625369ddc90 (patch)
treedd91ed804f2225c33931319d11c4647e831bcba5 /lang/gcc34
parent32640bdf6cbd1e0fe09a9a0483dee80266fdfe2c (diff)
downloadports-c143c5eaa46cdef79aa6f45bd1420625369ddc90.tar.gz
ports-c143c5eaa46cdef79aa6f45bd1420625369ddc90.zip
- add RC_D_SH to keep shared libs working after reboot
Approved by: gerald
Notes
Notes: svn path=/head/; revision=158116
Diffstat (limited to 'lang/gcc34')
-rw-r--r--lang/gcc34/Makefile7
-rw-r--r--lang/gcc34/files/gcc.sh.in14
2 files changed, 21 insertions, 0 deletions
diff --git a/lang/gcc34/Makefile b/lang/gcc34/Makefile
index b3fd47714263..3cae3bf11103 100644
--- a/lang/gcc34/Makefile
+++ b/lang/gcc34/Makefile
@@ -62,6 +62,10 @@ MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
CONFIGURE_ARGS+= --enable-shared
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= ${TARGLIB}
+SUB_LIST= TARGLIB="${TARGLIB}"
+SUB_FILES= gcc.sh
+RC_D_SH= etc/rc.d/gcc${SUFFIX}.sh
+PLIST_FILES+= ${RC_D_SH}
.else
CONFIGURE_ARGS+= --disable-shared
.if ${OSVERSION} < 500000 && ${ARCH} == alpha
@@ -104,6 +108,9 @@ check: build
cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
post-install:
+.if defined(WANT_SHAREDLIBS)
+ ${INSTALL_SCRIPT} ${WRKDIR}/gcc.sh ${PREFIX}/${RC_D_SH}
+.endif
# man pages can only be generated if Perl >= 5.6 is installed;
# fake them otherwise.
for mp in ${_MANPAGES}; do \
diff --git a/lang/gcc34/files/gcc.sh.in b/lang/gcc34/files/gcc.sh.in
new file mode 100644
index 000000000000..987e9531e371
--- /dev/null
+++ b/lang/gcc34/files/gcc.sh.in
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+case "$1" in
+start)
+ ldconfig -m %%TARGLIB%%
+ ;;
+stop)
+ ;;
+*)
+ echo "Usage: ${0##*/} { start | stop }" >&2
+ exit 64
+ ;;
+esac
+exit 0