aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc45
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2004-01-09 22:04:51 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2004-01-09 22:04:51 +0000
commit8f8670c3abdb731c524b49f6afe2401b1b951853 (patch)
tree3077a90612c0c342996cc0a97f3fdd3e9a4e4d07 /lang/gcc45
parent1077db094daafe040bba02c0011bc75992e7d428 (diff)
downloadports-8f8670c3abdb731c524b49f6afe2401b1b951853.tar.gz
ports-8f8670c3abdb731c524b49f6afe2401b1b951853.zip
Fix packaging which was quite broken. On the way, update PORTVERSION to
match the new versioning scheme in GCC-land and adjust the renaming of gccbug to the scheme used by the other programs installed by this port.
Notes
Notes: svn path=/head/; revision=97810
Diffstat (limited to 'lang/gcc45')
-rw-r--r--lang/gcc45/Makefile11
-rw-r--r--lang/gcc45/pkg-plist2
2 files changed, 6 insertions, 7 deletions
diff --git a/lang/gcc45/Makefile b/lang/gcc45/Makefile
index 3ab667bf30ae..364ac5ba9453 100644
--- a/lang/gcc45/Makefile
+++ b/lang/gcc45/Makefile
@@ -10,10 +10,10 @@ SNAPDATE= 2003-12-31
#CVS_DATE= ${SNAPDATE} 18:53:04 EDT
PORTNAME= gcc
-PORTVERSION= 3.4
+PORTVERSION= 3.4.0
PORTREVISION= ${SNAPDATE:S/-//g}
CATEGORIES= lang java
-VERSIONSTRING= ${PORTVERSION}-${PORTREVISION}
+VERSIONSTRING= 3.4-${PORTREVISION}
MASTER_SITES= ${MASTER_SITE_GCC} \
http://web.inter.NL.net/hcc/Haj.Ten.Brugge/:bc
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -44,11 +44,10 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-GCC_VER= ${PORTVERSION:C/\.0$//}
SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
WRKSRC= ${WRKDIR}/build
-TARGLIB= ${PREFIX}/lib/gcc/${CONFIGURE_TARGET}/${GCC_VER}
-PLIST_SUB= GCC_VER=${GCC_VER} GNU_HOST=${CONFIGURE_TARGET}
+TARGLIB= ${PREFIX}/lib/gcc/${CONFIGURE_TARGET}/${PORTVERSION}
+PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET}
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BISON= yes
@@ -143,7 +142,7 @@ post-install:
|| ${MV} -f ${PREFIX}/man/man1/${f}.1 \
${PREFIX}/man/man1/${f}-34.1 )
.endfor
- ${MV} -f ${PREFIX}/bin/gccbug ${PREFIX}/bin/gccbug-${PORTVERSION}
+ ${MV} -f ${PREFIX}/bin/gccbug ${PREFIX}/bin/gccbug34
# These 3 libraries are moved from PREFIX/lib to avoid conflicts
# with the stock compiler.
.for f in libstdc++ libsupc++ libg2c libfrtbegin libobjc ${EXTRA_SHLIB}
diff --git a/lang/gcc45/pkg-plist b/lang/gcc45/pkg-plist
index 182357f13a85..63ed478b829e 100644
--- a/lang/gcc45/pkg-plist
+++ b/lang/gcc45/pkg-plist
@@ -9,7 +9,7 @@ bin/%%GNU_HOST%%-gcc34
bin/%%GNU_HOST%%-g++34
bin/%%GNU_HOST%%-gcj
bin/%%GNU_HOST%%-gcjh
-bin/gccbug-%%GCC_VER%%
+bin/gccbug34
bin/gcj34
bin/gcjh34
bin/gij34