aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2004-03-17 14:21:58 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2004-03-17 14:21:58 +0000
commitbd3834a0e5b63c77f6601e93d912b3a5de4417b2 (patch)
tree7f9138e476354059ae533e4fa1d2b01dc17e7365 /lang/gcc
parent9b2598a9123dbb85353bcfd03afbedb8e23f59d6 (diff)
downloadports-bd3834a0e5b63c77f6601e93d912b3a5de4417b2.tar.gz
ports-bd3834a0e5b63c77f6601e93d912b3a5de4417b2.zip
Try to fix breakage of non-amd64 platforms introduced by 1.165 and
remove inflamatory comment. Remove BROKEN from sparc64 and simplify special case handling of libgcj on ia64 and sparc64. USE_SIZE is now the default, no need to specify it explicitly. Remove WANT_THREADS_SUPPORT knob, which should be a no-op by now.
Notes
Notes: svn path=/head/; revision=104297
Diffstat (limited to 'lang/gcc')
-rw-r--r--lang/gcc/Makefile16
1 files changed, 3 insertions, 13 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index 8ff31da6c6b5..2a315db2fd2a 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -33,7 +33,6 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5_BUILD=yes
USE_REINPLACE= yes
-USE_SIZE= yes
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
@@ -42,16 +41,12 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-# fscking Linux & GNU $*!%
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.else
+CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
-.if ${ARCH} == sparc64
-BROKEN= "libgcj is not supported/packaging is broken on this platform"
-WITHOUT_LIBJAVA= yes
-.endif
-
-.if ${ARCH} == ia64
+.if ${ARCH} == ia64 || ${ARCH} == sparc64
WITHOUT_LIBJAVA= yes
.endif
@@ -74,11 +69,6 @@ EXTRA_SHLIB= libgcc_s
.else
CONFIGURE_ARGS+= --disable-shared
.endif
-.if defined(WANT_THREADS_SUPPORT)
-CONFIGURE_ARGS+= --enable-threads
-# ?is this an ObjC only thing?
-CONFIGURE_ARGS+= --enable-threads=posix
-.endif
ALL_TARGET= bootstrap-lean
PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET}
MAN1= cpp${SUFFIX}.1 \