aboutsummaryrefslogtreecommitdiff
path: root/lang/gnat_util/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-16 15:11:40 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-16 15:11:40 +0000
commitbee4622fe3268a1fca36af1e82e2c34ba9739497 (patch)
tree95ebe1309939f38eabd4f0469b5c79d936ac4932 /lang/gnat_util/Makefile
parentd2fd619340975e436f216d4c07194c3bef7ef55c (diff)
downloadports-bee4622fe3268a1fca36af1e82e2c34ba9739497.tar.gz
ports-bee4622fe3268a1fca36af1e82e2c34ba9739497.zip
lang/gnat_util, devel/gprbuild: Support gcc5-aux
GPRBuild is too highly tethered to the compiler -- in practical terms each version of GPRBuild is meant to be built by a specific GPL GNAT, but we're trying to build it with multiple FSF GNATS that are out of sync. This patch set does allow GPRBuild to build and apparently work with both gcc-aux and gcc5-aux. There is no real change for gcc-aux (OpenVMS is removed from the code but it should be same difference) ang for gcc5-aux, the previous patches aren't needed but new ones are. Thus, EXTRA_PATCHES had to be set for each of the two supported compilers. lang/gnat_utils had to be modified to stop packaging OpenVMS target files as apparently this target has been removed from gcc5-aux.
Notes
Notes: svn path=/head/; revision=381407
Diffstat (limited to 'lang/gnat_util/Makefile')
-rw-r--r--lang/gnat_util/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/lang/gnat_util/Makefile b/lang/gnat_util/Makefile
index a5ecd5451b6b..430cf09396bc 100644
--- a/lang/gnat_util/Makefile
+++ b/lang/gnat_util/Makefile
@@ -17,12 +17,14 @@ LICENSE_COMB= multi
USES= ada tar:bzip2
NO_MTREE= yes
-DISTINFO_FILE= ${.CURDIR}/../gcc-aux/distinfo
+DISTINFO_FILE= ${.CURDIR}/../${ADAXX}-aux/distinfo
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_ENV= MAKEOBJDIR=${WRKSRC}/obj
.include "${.CURDIR}/Makefile.sources"
-.include "${.CURDIR}/../gcc-aux/Makefile.version"
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../${ADAXX}-aux/Makefile.version"
post-extract:
@${MKDIR} ${WRKSRC}/obj
@@ -41,4 +43,4 @@ post-install:
@(cd ${STAGEDIR}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
${SORT} >> ${TMPPLIST})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>