aboutsummaryrefslogtreecommitdiff
path: root/lang/helium
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2003-01-28 09:57:00 +0000
committerOliver Braun <obraun@FreeBSD.org>2003-01-28 09:57:00 +0000
commitbda620e29cbce7322a4fc3417f4927d061f146f6 (patch)
treef57cc5b869ffed76215d3ed2f7aad268c606b1b4 /lang/helium
parent0707c24745b1565b300c6552456792de6a5ab6bd (diff)
downloadports-bda620e29cbce7322a4fc3417f4927d061f146f6.tar.gz
ports-bda620e29cbce7322a4fc3417f4927d061f146f6.zip
Helium is a compiler for a subset of Haskell designed especially for teaching
Notes
Notes: svn path=/head/; revision=74124
Diffstat (limited to 'lang/helium')
-rw-r--r--lang/helium/Makefile34
-rw-r--r--lang/helium/distinfo1
-rw-r--r--lang/helium/pkg-comment1
-rw-r--r--lang/helium/pkg-descr11
-rw-r--r--lang/helium/pkg-plist20
5 files changed, 67 insertions, 0 deletions
diff --git a/lang/helium/Makefile b/lang/helium/Makefile
new file mode 100644
index 000000000000..619555c9a97e
--- /dev/null
+++ b/lang/helium/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: helium
+# Date created: 28 January 2003
+# Whom: Oliver Braun <obraun@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= helium
+PORTVERSION= 1.0
+CATEGORIES= lang haskell
+MASTER_SITES= http://www.cs.uu.nl/~afie/helium/
+DISTNAME= ${PORTNAME}
+#DISTFILES= ${PORTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= obraun@FreeBSD.org
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_GMAKE= yes
+
+do-configure:
+ @(cd ${WRKSRC}/lvm/src/ && ./configure)
+ @(cd ${WRKSRC}/heliumNT/ && ./configure)
+
+do-build:
+ @(cd ${WRKSRC}/heliumNT/src && ${GMAKE} depend)
+ @(cd ${WRKSRC}/heliumNT/src && ${GMAKE})
+
+do-install:
+ @(cd ${WRKSRC}/heliumNT/src && ${GMAKE} install)
+
+.include <bsd.port.mk>
diff --git a/lang/helium/distinfo b/lang/helium/distinfo
new file mode 100644
index 000000000000..b2463bd9c7be
--- /dev/null
+++ b/lang/helium/distinfo
@@ -0,0 +1 @@
+MD5 (helium.tar.gz) = 6445b483106e0bd6b5887be1ff994765
diff --git a/lang/helium/pkg-comment b/lang/helium/pkg-comment
new file mode 100644
index 000000000000..4d075d88e879
--- /dev/null
+++ b/lang/helium/pkg-comment
@@ -0,0 +1 @@
+Functional programming compiler for a subset of Haskell
diff --git a/lang/helium/pkg-descr b/lang/helium/pkg-descr
new file mode 100644
index 000000000000..d2a430bd4fc4
--- /dev/null
+++ b/lang/helium/pkg-descr
@@ -0,0 +1,11 @@
+Helium --- For learning Haskell.
+
+Helium is a functional programming language and a compiler designed especially
+for teaching Haskell. Quality of the error messages has been the main concern
+both in the choice of the language features and in the implementation of the
+compiler.
+
+WWW: http://www.cs.uu.nl/~afie/helium/
+
+-- Oliver Braun
+obraun@FreeBSD.org
diff --git a/lang/helium/pkg-plist b/lang/helium/pkg-plist
new file mode 100644
index 000000000000..b2f1bacdc9bb
--- /dev/null
+++ b/lang/helium/pkg-plist
@@ -0,0 +1,20 @@
+bin/helium
+bin/lvmrun
+helium/demo/Calendar.hs
+helium/demo/ParserDemo.hs
+helium/demo/ParserLibrary.hs
+helium/demo/TicTacToe.hs
+helium/lib/HeliumLang.lvm
+helium/lib/List.hs
+helium/lib/List.lvm
+helium/lib/LvmException.lvm
+helium/lib/LvmIO.lvm
+helium/lib/LvmLang.lvm
+helium/lib/Maybe.hs
+helium/lib/Maybe.lvm
+helium/lib/Prelude.hs
+helium/lib/Prelude.lvm
+helium/lib/PreludePrim.lvm
+@dirrm helium/demo
+@dirrm helium/lib
+@dirrm helium