aboutsummaryrefslogtreecommitdiff
path: root/lang/icc/Makefile
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2003-03-28 10:45:57 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2003-03-28 10:45:57 +0000
commit81ac3ff758316ae56b653c49143731e4999f7877 (patch)
treef126e5d4a02be21db12e4a8ea4a1972651572f3b /lang/icc/Makefile
parentf1b92aefa71a0d250f47f3308978f6acf2ec51df (diff)
downloadports-81ac3ff758316ae56b653c49143731e4999f7877.tar.gz
ports-81ac3ff758316ae56b653c49143731e4999f7877.zip
- Update to 7.1.006.
Submitted by: marius@alchemy.franken.de - Minor cosmetics (FIND) and corrections (COMMENT).
Notes
Notes: svn path=/head/; revision=77613
Diffstat (limited to 'lang/icc/Makefile')
-rw-r--r--lang/icc/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index e128fbcb167a..0d5f6188479f 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= icc
-PORTVERSION= 7.0.086
+PORTVERSION= 7.1.006
CATEGORIES= lang linux devel
MASTER_SITES=
-DISTNAME= l_cc_pu_${PORTVERSION}
+DISTNAME= l_cc_p_${PORTVERSION}
EXTRACT_SUFX= .tar
MAINTAINER= netchild@FreeBSD.org
-COMMENT= Intels C/C++ compiler, set up to produce native FreeBSD objects
+COMMENT= Intels C/C++ compiler, set up to produce native FreeBSD binaries
BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm2cpio
@@ -41,6 +41,7 @@ ICC_SITE= http://www.intel.com/software/products/compilers/
ICCCFGVAL!= ${UNAME} -r | ${SED} -e 's/\..*//'
+CPIO?= /usr/bin/cpio
OBJCOPY?= /usr/bin/objcopy
.if !exists(${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX})
@@ -61,14 +62,14 @@ post-extract:
${FILESDIR}/cpio-exclude_noportdocs >>${WRKDIR}/cpio-exclude
.endif
.for i in \
- intel-icc7-7.0-86.i386.rpm
-# intel-ildb7-7.0-172.i386.rpm \
-# intel-isubh7-7.0-86.i386.rpm \
-# intel-ecc7-7.0-86.ia64.rpm \
-# intel-eldb7-7.0-172.ia64.rpm \
-# intel-esubh7-7.0-86.ia64.rpm
+ intel-icc7-7.1-6.i386.rpm
+# intel-ildb7-7.1-11.i386.rpm \
+# intel-isubh7-7.1-6.i386.rpm \
+# intel-ecc7-7.1-6.ia64.rpm \
+# intel-eldb7-7.1-11.ia64.rpm \
+# intel-esubh7-7.1-6.ia64.rpm
@cd ${WRKSRC} && rpm2cpio 2>/dev/null ${i} | \
- cpio -idfuE ${WRKDIR}/cpio-exclude --quiet
+ ${CPIO} -idfuE ${WRKDIR}/cpio-exclude --quiet
.endfor
pre-patch:
@@ -143,7 +144,8 @@ do-build:
@${CHMOD} 755 ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld
do-install:
- @cd ${WRKSRC}/opt && find . | cpio -pdu -R ${BINOWN}:${BINGRP} ${PREFIX}
+ @cd ${WRKSRC}/opt && ${FIND} . -print | \
+ ${CPIO} -pdu -R ${BINOWN}:${BINGRP} --quiet ${PREFIX}
post-install:
@${ECHO_CMD} "${PKGNAME} is now installed in ${PREFIX}/intel, to use it you have to"