aboutsummaryrefslogtreecommitdiff
path: root/lang/icc/Makefile
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2004-01-30 12:41:19 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2004-01-30 12:41:19 +0000
commite05c290c8378bd503d69b228742b64098c13c6dc (patch)
treedc0e611c25f71c04c2b9056039c6b3f9ce9016a9 /lang/icc/Makefile
parent0227c64715e54e674b70659b79b36d04520714f3 (diff)
downloadports-e05c290c8378bd503d69b228742b64098c13c6dc.tar.gz
ports-e05c290c8378bd503d69b228742b64098c13c6dc.zip
- update to 8.0.058.p059
- use SIZE - remove variables for objcopy and brandelf, they're now available from bsd.port.mk - use a more generic chmod command
Notes
Notes: svn path=/head/; revision=99505
Diffstat (limited to 'lang/icc/Makefile')
-rw-r--r--lang/icc/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index 4f896b146b2e..8d464371637b 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= icc
-PORTVERSION= 8.0.058
+PORTVERSION= 8.0.058.p059
CATEGORIES= lang linux devel
MASTER_SITES=
DISTNAME= l_cc_pc_${PORTVERSION:C/\.p.+$//}
@@ -31,6 +31,7 @@ CONFLICTS= linux_devtools*
USE_LINUX= yes
USE_REINPLACE= yes
+USE_SIZE= yes
NO_FILTER_SHLIBS= yes
COMPILERDIR= intel_cc_80
@@ -53,9 +54,6 @@ EXTRACT_AFTER_ARGS= | tar -xf - \
ICCCFGVAL!= ${UNAME} -r | ${SED} -e 's/\..*//'
-BRANDELF?= /usr/bin/brandelf
-OBJCOPY?= /usr/bin/objcopy
-
.for file in ${DISTFILES}
.if !exists(${DISTDIR}/${DIST_SUBDIR}/${file})
IGNORE= "Go to Intel Premier Support, https://premier.intel.com, to obtain ${DISTFILES}. Product updates such as this compiler are posted regularly on Premier Support. You must have a license to obtain access to Premier Support. If you do not already have a license go to ${ICC_SITE} to review licensing options \(evaluation, commercial, and free non-commercial\) and obtain a license. Put ${DISTFILES} into ${DISTDIR} and run make again"
@@ -93,7 +91,7 @@ pre-patch: intel-patch
# Remove unneeded/unsafe access rights.
.for i in doc include lib
@${FIND} ${WRKSRC}/opt/${COMPILERDIR}/${i} -type f -print0 | \
- ${XARGS} -0 ${CHMOD} a-x,g-w
+ ${XARGS} -0 ${CHMOD} a-x,og-w
.endfor
@${FIND} ${WRKSRC}/opt -type d -print0 | ${XARGS} -0 ${CHMOD} go-w
@${CHMOD} a-x ${WRKSRC}/opt/${COMPILERDIR}/bin/Errormatch.txt