aboutsummaryrefslogtreecommitdiff
path: root/lang/jakarta-commons-jelly
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-08-01 15:11:30 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-08-01 15:11:30 +0000
commit636406d3d53bc27feb814c0a3e0df63cfd81c351 (patch)
tree86aa6499b26005d9681e72bade379be4d249c98a /lang/jakarta-commons-jelly
parent3ab7cf9031cc137a04e1d5952da940abd36ede3a (diff)
downloadports-636406d3d53bc27feb814c0a3e0df63cfd81c351.tar.gz
ports-636406d3d53bc27feb814c0a3e0df63cfd81c351.zip
Jelly is an XML based scripting engine. The basic idea is that XML elements can
be bound to a Java Tag which is a Java bean that performs some function. Jelly is totally extendable via custom actions (in a similar way to JSP custom tags) as well as cleanly integrating with scripting languages such as Jexl, Velocity, pnuts, beanshell and via BSF (Bean Scripting Framework) languages like JavaScript & JPython. Jelly uses an XMLOutput class which extends SAX ContentHandler to output XML events. This makes Jelly ideal for XML content generation, SOAP scripting or dynamic web site generation. A single Jelly tag can produce, consume, filter or transform XML events. This leads to a powerful XML pipeline engine similar in some ways to Cocoon. WWW: http://jakarta.apache.org/commons/jelly/index.html
Notes
Notes: svn path=/head/; revision=140673
Diffstat (limited to 'lang/jakarta-commons-jelly')
-rw-r--r--lang/jakarta-commons-jelly/Makefile54
-rw-r--r--lang/jakarta-commons-jelly/distinfo2
-rw-r--r--lang/jakarta-commons-jelly/files/jelly.sh.in15
-rw-r--r--lang/jakarta-commons-jelly/pkg-descr15
4 files changed, 86 insertions, 0 deletions
diff --git a/lang/jakarta-commons-jelly/Makefile b/lang/jakarta-commons-jelly/Makefile
new file mode 100644
index 000000000000..70bb5c989891
--- /dev/null
+++ b/lang/jakarta-commons-jelly/Makefile
@@ -0,0 +1,54 @@
+# Ports collection makefile for: Jakarta Commons Jelly
+# Date created: 29 July 2005
+# Whom: Herve Quiroz <hq@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= commons-jelly
+PORTVERSION= 1.0
+CATEGORIES= lang devel java
+MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
+MASTER_SITE_SUBDIR= ${PORTNAME:S,-,/,}/binaries
+PKGNAMEPREFIX= jakarta-
+
+MAINTAINER= hq@FreeBSD.org
+COMMENT= XML based scripting engine
+
+RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
+
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
+NO_BUILD= yes
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+READMES= LICENSE.txt NOTICE.txt README.txt RELEASE-NOTES.txt
+DATAFILES= custom lib bin
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+SUB_FILES= jelly.sh
+PLIST_FILES= bin/jelly
+
+post-extract:
+ ${RM} -f ${WRKSRC}/bin/jelly.bat ${WRKSRC}/bin/jelly
+
+do-install:
+ cd ${WRKSRC} && ${FIND} ${DATAFILES} -type d -exec ${MKDIR} ${DATADIR}/{} ";"
+ cd ${WRKSRC} && ${FIND} ${DATAFILES} -type f -exec ${INSTALL_DATA} {} ${DATADIR}/{} ";"
+ ${INSTALL_SCRIPT} ${WRKDIR}/jelly.sh ${PREFIX}/bin/jelly
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC}/docs && ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${DOCSDIR}/{} ";"
+ cd ${WRKSRC}/docs && ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} ";"
+ ${INSTALL_DATA} ${READMES:S|^|${WRKSRC}/|} ${DOCSDIR}/
+.endif
+
+post-install:
+ @${FIND} -s ${DATAFILES:S,^,${WRKSRC}/,} -not -type d 2>/dev/null | \
+ ${SED} -ne 's,^${WRKSRC},${DATADIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${FIND} -s -d ${DATAFILES:S,^,${WRKSRC}/,} -type d 2>/dev/null | \
+ ${SED} -ne 's,^${WRKSRC},@dirrm ${DATADIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${ECHO_CMD} '@dirrm ${DATADIR:S,^${PREFIX}/,,}' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/lang/jakarta-commons-jelly/distinfo b/lang/jakarta-commons-jelly/distinfo
new file mode 100644
index 000000000000..a78d69d227a3
--- /dev/null
+++ b/lang/jakarta-commons-jelly/distinfo
@@ -0,0 +1,2 @@
+MD5 (commons-jelly-1.0.tar.gz) = e9e3ba84a214d2bcf96aa31b24f3bb5f
+SIZE (commons-jelly-1.0.tar.gz) = 3384141
diff --git a/lang/jakarta-commons-jelly/files/jelly.sh.in b/lang/jakarta-commons-jelly/files/jelly.sh.in
new file mode 100644
index 000000000000..bcc7cc0427a1
--- /dev/null
+++ b/lang/jakarta-commons-jelly/files/jelly.sh.in
@@ -0,0 +1,15 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+JELLY_HOME="${JELLY_HOME:-"%%DATADIR%%"}"
+CLASSPATH="${CLASSPATH}:${JELLY_HOME}/lib/forehead-1.0-beta-5.jar"
+FOREHEAD_CONF="${FOREHEAD_CONF:-"${JELLY_HOME}/bin/forehead.conf"}"
+
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" \
+ -classpath "${CLASSPATH}" \
+ -Dforehead.conf.file="${FOREHEAD_CONF}" \
+ -Djelly.home="${JELLY_HOME}" \
+ -Dtools.jar="${JAVA_HOME}/lib/tools.jar" \
+ ${JELLY_OPTS} \
+ com.werken.forehead.Forehead "$@"
diff --git a/lang/jakarta-commons-jelly/pkg-descr b/lang/jakarta-commons-jelly/pkg-descr
new file mode 100644
index 000000000000..db1b7e3c78e0
--- /dev/null
+++ b/lang/jakarta-commons-jelly/pkg-descr
@@ -0,0 +1,15 @@
+Jelly is an XML based scripting engine. The basic idea is that XML elements can
+be bound to a Java Tag which is a Java bean that performs some function.
+
+Jelly is totally extendable via custom actions (in a similar way to JSP custom
+tags) as well as cleanly integrating with scripting languages such as Jexl,
+Velocity, pnuts, beanshell and via BSF (Bean Scripting Framework) languages
+like JavaScript & JPython.
+
+Jelly uses an XMLOutput class which extends SAX ContentHandler to output XML
+events. This makes Jelly ideal for XML content generation, SOAP scripting or
+dynamic web site generation. A single Jelly tag can produce, consume, filter or
+transform XML events. This leads to a powerful XML pipeline engine similar in
+some ways to Cocoon.
+
+WWW: http://jakarta.apache.org/commons/jelly/index.html