aboutsummaryrefslogtreecommitdiff
path: root/lang/lua51
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-01-17 01:28:31 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-01-17 01:28:31 +0000
commit9df11b915914f306599ce26e94b92430ce9c7720 (patch)
treee91556d95d3dba67efb015bc13a0a2bb9ac57fc7 /lang/lua51
parente16ecef5102027e33fc123bf2a4c82dd2b2d439d (diff)
downloadports-9df11b915914f306599ce26e94b92430ce9c7720.tar.gz
ports-9df11b915914f306599ce26e94b92430ce9c7720.zip
Link on port version of libedit
Avoid overlinking on liblua
Notes
Notes: svn path=/head/; revision=377207
Diffstat (limited to 'lang/lua51')
-rw-r--r--lang/lua51/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/lang/lua51/Makefile b/lang/lua51/Makefile
index 1b2b45e428fe..e0e39bbf8989 100644
--- a/lang/lua51/Makefile
+++ b/lang/lua51/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lua
PORTVERSION= 5.1.5
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= lang
MASTER_SITES= http://www.lua.org/ftp/
PKGNAMESUFFIX= 51
@@ -14,7 +14,7 @@ COMMENT= Small, compilable scripting language providing easy access to C code
LICENSE= MIT
LUA_VER= 5.1
-USES= readline
+LIB_DEPENDS+= libedit.so.0:${PORTSDIR}/devel/libedit
USE_LDCONFIG= yes
# Overriding __MAKE_CONF makes sure that we don't re-parse
@@ -26,10 +26,12 @@ USE_LDCONFIG= yes
MAKE_ARGS= __MAKE_CONF=${NONEXISTENT}
# liblua.so requires libm, so make sure it has an explicit dependency
# so that applications need not second-guess lua's dependencies.
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -lm -pthread
BUILD_WRKSRC= ${WRKSRC}/src
MAKE_ARGS+= MYCFLAGS="${CFLAGS} ${CPPFLAGS} -DLUA_USE_LINUX" \
- MYLDFLAGS="${LDFLAGS} -Wl,-E -lreadline" \
+ MYLDFLAGS="${LDFLAGS}" \
+ MYLIBS="-Wl,-E -ledit" \
CC="${CC}" \
LUA_T=lua51 \
LUAC_T=luac51 \