aboutsummaryrefslogtreecommitdiff
path: root/lang/micropython
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2015-04-03 12:59:59 +0000
committerMarcus von Appen <mva@FreeBSD.org>2015-04-03 12:59:59 +0000
commit24b9f273e6161c0e759d4348e8d5a1116458a7ba (patch)
tree4bb55f530eb913087c332b5cf76ee4eab702d3e1 /lang/micropython
parent5a2708a6be1c330cfa3ca425d34dfc609201bbb8 (diff)
downloadports-24b9f273e6161c0e759d4348e8d5a1116458a7ba.tar.gz
ports-24b9f273e6161c0e759d4348e8d5a1116458a7ba.zip
- Update to version 1.4
Major changes since 1.3.1: - new builtins, ujson, uheapq, ubinascii modules - new memoryview and compile builtins - improvements for eval and exec - array slice assignment support - basix regex support - x86 support for the native emitter - many other fixes and improvements Changelogs: https://github.com/micropython/micropython/release
Notes
Notes: svn path=/head/; revision=383115
Diffstat (limited to 'lang/micropython')
-rw-r--r--lang/micropython/Makefile26
-rw-r--r--lang/micropython/distinfo4
2 files changed, 20 insertions, 10 deletions
diff --git a/lang/micropython/Makefile b/lang/micropython/Makefile
index fa52a7861a12..23beb951cf47 100644
--- a/lang/micropython/Makefile
+++ b/lang/micropython/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= micropython
-PORTVERSION= 1.3.1
+PORTVERSION= 1.4.0
CATEGORIES= lang python
MAINTAINER= mva@FreeBSD.org
@@ -11,29 +11,39 @@ LICENSE= MIT
LIB_DEPENDS= libffi.so:${PORTSDIR}/devel/libffi
-USES= gmake pkgconfig python:build readline shebangfix
+USES= gmake pkgconfig python:3,build readline shebangfix
USE_GITHUB= yes
GH_ACCOUNT= micropython
GH_PROJECT= micropython
-GH_TAGNAME= v1.3.1
-GH_COMMIT= 0f6d298
+GH_TAGNAME= v1.4
PLIST_FILES= bin/micropython
-WRKSRC= ${WRKDIR}/${GH_ACCOUNT}-${GH_PROJECT}-${GH_COMMIT}/unix
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.4/unix
SHEBANG_FILES= ../py/py-version.sh
bash_CMD?= /bin/sh
MAKE_ARGS+= V=1
MAKE_ENV+= PYTHON=${PYTHON_CMD} CFLAGS_EXTRA="${CPPFLAGS} ${CFLAGS}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000024
+# Our default GCC 4.2.1 build can't handle some quirks correctly.
+# Use an up to date version for FreeBSD releases, which use GCC
+# as default compiler
+USE_GCC= yes
+.endif
+
post-patch:
- @${REINPLACE_CMD} -e 's|-Wno-error=cpp||;s|-Werror||;/^COPT =/d' \
- ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|-Werror||;/^COPT =/d' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|AS =|AS ?=|;s|LD =|LD ?=|; \
s|CC =|CC ?=|;s|PYTHON =|PYTHON ?=|' \
${WRKSRC}/../py/mkenv.mk
+ @${REINPLACE_CMD} -e 's|libc\.so\.6|libc\.so\.7|;' \
+ ${WRKSRC}/../tests/unix/ffi_callback.py \
+ ${WRKSRC}/../tests/unix/ffi_float.py
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/micropython ${STAGEDIR}${PREFIX}/bin
@@ -42,4 +52,4 @@ regression-test: build
${RM} ${WRKSRC}/../tests/basics/memoryerror.py
cd ${WRKSRC} && ${MAKE_CMD} test
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/micropython/distinfo b/lang/micropython/distinfo
index ca39aa64107e..8e5c02de4cc2 100644
--- a/lang/micropython/distinfo
+++ b/lang/micropython/distinfo
@@ -1,2 +1,2 @@
-SHA256 (micropython-1.3.1.tar.gz) = c65cff07c1fba2e7aa75f62a53da4721635ff528fef28e98c5746c87d5f553bc
-SIZE (micropython-1.3.1.tar.gz) = 4328886
+SHA256 (micropython-micropython-1.4.0-v1.4_GH0.tar.gz) = 9af6cc972c8ea96bd6d961ea6fecc49127198878182b0d13e3845ab6a7d2220b
+SIZE (micropython-micropython-1.4.0-v1.4_GH0.tar.gz) = 5692053