aboutsummaryrefslogtreecommitdiff
path: root/lang/nawk
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-07-04 09:01:45 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-07-04 09:01:45 +0000
commit457c5426203922b31c61b006a364dcec2d7895b0 (patch)
treebe7773213b2203e53da740a0d3c1bd3bb0c51b56 /lang/nawk
parentc29f23e3a2dcbcb4c41ddba39bd83e4cf05088dd (diff)
downloadports-457c5426203922b31c61b006a364dcec2d7895b0.tar.gz
ports-457c5426203922b31c61b006a364dcec2d7895b0.zip
- Update to 20070501
- Add one fix from src/usr.bin/awk/lib.c.diff rev 1.2 - Normalize DIST_SUBDIR as other ports PR: ports/114227 Submitted by: Pedro F. Giffuni <giffunip at tutopia.com>
Notes
Notes: svn path=/head/; revision=194880
Diffstat (limited to 'lang/nawk')
-rw-r--r--lang/nawk/Makefile4
-rw-r--r--lang/nawk/distinfo6
-rw-r--r--lang/nawk/files/patch-lib.c11
-rw-r--r--lang/nawk/files/patch-makefile23
4 files changed, 31 insertions, 13 deletions
diff --git a/lang/nawk/Makefile b/lang/nawk/Makefile
index 9551f31fb465..63596ce347a6 100644
--- a/lang/nawk/Makefile
+++ b/lang/nawk/Makefile
@@ -7,11 +7,11 @@
#
PORTNAME= nawk
-PORTVERSION= 20050424
+PORTVERSION= 20070501
CATEGORIES= lang
MASTER_SITES= http://cm.bell-labs.com/cm/cs/who/bwk/
DISTNAME= awk
-DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Brian Kernighan's pattern scanning and processing language
diff --git a/lang/nawk/distinfo b/lang/nawk/distinfo
index 6c864e874690..f3b7841cc7ad 100644
--- a/lang/nawk/distinfo
+++ b/lang/nawk/distinfo
@@ -1,3 +1,3 @@
-MD5 (nawk-20050424/awk.tar.gz) = 6a8c9efb19d8f1d641148429202ac1de
-SHA256 (nawk-20050424/awk.tar.gz) = 34fdda15708b7cfba47544ffddf9a79ed6291f167f3d1e2e8d7a64047f2eda71
-SIZE (nawk-20050424/awk.tar.gz) = 114935
+MD5 (nawk/awk.tar.gz) = b63342525afee1cc5e3a4211cbf87fae
+SHA256 (nawk/awk.tar.gz) = 3827c90fa4573caf82ce6c084020230c9520ef4f91ac06f86c4a0c068400c061
+SIZE (nawk/awk.tar.gz) = 117479
diff --git a/lang/nawk/files/patch-lib.c b/lang/nawk/files/patch-lib.c
new file mode 100644
index 000000000000..e29449c4ef8d
--- /dev/null
+++ b/lang/nawk/files/patch-lib.c
@@ -0,0 +1,11 @@
+--- lib.c.orig Tue Jul 3 15:00:23 2007
++++ lib.c Tue Jul 3 15:00:28 2007
+@@ -40,7 +40,7 @@
+ int fieldssize = RECSIZE;
+
+ Cell **fldtab; /* pointers to Cells */
+-char inputFS[10] = " ";
++char inputFS[100] = " ";
+
+ #define MAXFLD 2
+ int nfields = MAXFLD; /* last allocated slot for $i */
diff --git a/lang/nawk/files/patch-makefile b/lang/nawk/files/patch-makefile
index 5dd4923bbde0..7367d31613b5 100644
--- a/lang/nawk/files/patch-makefile
+++ b/lang/nawk/files/patch-makefile
@@ -1,19 +1,26 @@
---- makefile.orig Mon Mar 28 15:40:31 2005
-+++ makefile Thu Dec 1 11:28:45 2005
-@@ -22,16 +22,6 @@
+--- makefile.orig Mon Apr 30 08:10:40 2007
++++ makefile Mon Jul 2 18:32:10 2007
+@@ -22,20 +22,11 @@
# THIS SOFTWARE.
# ****************************************************************/
-CFLAGS = -g
-CFLAGS = -O2
-CFLAGS =
--
++CFLAGS ?= -O2
+
-CC = gcc -Wall -g -Wwrite-strings
--CC = gcc -fprofile-arcs -ftest-coverage
-- # followed by gcov onefile.c; cat onefile.c.gcov
+-CC = gcc -fprofile-arcs -ftest-coverage # then gcov f1.c; cat f1.c.gcov
-CC = gcc -Wall -g
-CC = cc
+-CC = gcc -O4
+-CC = gcc -Wall -g
++CC ?= cc
+
-
- YACC = bison -y
- YACC = yacc
+-YACC = bison -y
+-YACC = yacc
++YACC ?= yacc
YFLAGS = -d
+
+ OFILES = b.o main.o parse.o proctab.o tran.o lib.o run.o lex.o