aboutsummaryrefslogtreecommitdiff
path: root/lang/ocaml
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-22 23:49:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-22 23:49:34 +0000
commit24adc215fd013e668346c70600fe231dc1d7c2d9 (patch)
tree9cfd3bab6edd06c6afb9fd01b1d177d1d56e4142 /lang/ocaml
parent30b9d261003671c3109179a8f1e158ab48d0d4c9 (diff)
downloadports-24adc215fd013e668346c70600fe231dc1d7c2d9.tar.gz
ports-24adc215fd013e668346c70600fe231dc1d7c2d9.zip
- Replace nasty [A-Za-hj-z] with a recursive cp. Not that elegant but it
works under all locales. Approved by: maintainer
Notes
Notes: svn path=/head/; revision=104992
Diffstat (limited to 'lang/ocaml')
-rw-r--r--lang/ocaml/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index bd4ce0d50fa5..dd1a2abadd56 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -98,10 +98,8 @@ post-install:
@${MKDIR} ${EXAMPLESDIR}/camltk/images
@cd ${WRKSRC}/otherlibs/labltk/examples_labltk; \
${INSTALL_DATA} * ${EXAMPLESDIR}/labltk
- @cd ${WRKSRC}/otherlibs/labltk/examples_camltk/images; \
- ${INSTALL_DATA} * ${EXAMPLESDIR}/camltk/images
- @cd ${WRKSRC}/otherlibs/labltk/examples_camltk; \
- ${INSTALL_DATA} [A-Za-hj-z]* ${EXAMPLESDIR}/camltk
+ @${CP} -r ${WRKSRC}/otherlibs/labltk/examples_camltk/* \
+ ${EXAMPLESDIR}/camltk
.endif
.for prog in camlp4o.opt camlp4r.opt ocamlc.opt ocamldep.opt ocamldoc.opt \
ocamllex.opt ocamlopt.opt ocamlrun ocamlyacc