aboutsummaryrefslogtreecommitdiff
path: root/lang/onyx/Makefile
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2003-01-31 13:04:13 +0000
committerOliver Braun <obraun@FreeBSD.org>2003-01-31 13:04:13 +0000
commit77ab3f6fa6d293ffbd3c0ce9290f18116988bf82 (patch)
treef03ff11d29c0672fbc49e8e6060fd022995471ba /lang/onyx/Makefile
parent9227ab842391dbe4043bd3aaf6c2a487d608ac8c (diff)
downloadports-77ab3f6fa6d293ffbd3c0ce9290f18116988bf82.tar.gz
ports-77ab3f6fa6d293ffbd3c0ce9290f18116988bf82.zip
Fix libs.
PR: ports/47486 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Notes
Notes: svn path=/head/; revision=74353
Diffstat (limited to 'lang/onyx/Makefile')
-rw-r--r--lang/onyx/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/lang/onyx/Makefile b/lang/onyx/Makefile
index 28c6010f7755..be55f39349bf 100644
--- a/lang/onyx/Makefile
+++ b/lang/onyx/Makefile
@@ -7,6 +7,7 @@
PORTNAME= onyx
PORTVERSION= 4.2.1
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://www.canonware.com/download/onyx/
@@ -16,15 +17,21 @@ BUILD_DEPENDS= cook:${PORTSDIR}/devel/cook
LIB_DEPENDS= edit.5:${PORTSDIR}/devel/libedit \
pcre.0:${PORTSDIR}/devel/pcre
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-libedit-prefix=${LOCALBASE}
+CONFIGURE_ARGS= --with-libedit-prefix=${LOCALBASE} \
+ --with-pcre-prefix=${LOCALBASE} \
+ --disable-slate
INSTALLS_SHLIB= yes
MAN1= onyx.1 onyx_config.1
PLIST_SUB= ONYX_VERSION=${PORTVERSION}
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+
do-build:
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} cook)