aboutsummaryrefslogtreecommitdiff
path: root/lang/oorexx
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2007-11-14 04:57:15 +0000
committerMax Khon <fjoe@FreeBSD.org>2007-11-14 04:57:15 +0000
commita0319a48dea9e38e05e0675e363e741cbe8c051a (patch)
tree31c31bd21d6c3ac688625d92fa49a8a87b939385 /lang/oorexx
parent0e323fc402d7101adb26b7e9094b7467071b0a4f (diff)
downloadports-a0319a48dea9e38e05e0675e363e741cbe8c051a.tar.gz
ports-a0319a48dea9e38e05e0675e363e741cbe8c051a.zip
Fix build on FreeBSD 7 and later.
Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=202695
Diffstat (limited to 'lang/oorexx')
-rw-r--r--lang/oorexx/Makefile4
-rw-r--r--lang/oorexx/files/patch-rexxapi-RexxAPIManager.cpp12
2 files changed, 12 insertions, 4 deletions
diff --git a/lang/oorexx/Makefile b/lang/oorexx/Makefile
index ff91a81670f6..854f1a7e4987 100644
--- a/lang/oorexx/Makefile
+++ b/lang/oorexx/Makefile
@@ -21,10 +21,6 @@ MAN1= rexx.1 rexxc.1 rxmigrate.1 rxsubcom.1 rxqueue.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
.if ${ARCH} != "i386"
BROKEN= Does not compile on !i386
.endif
diff --git a/lang/oorexx/files/patch-rexxapi-RexxAPIManager.cpp b/lang/oorexx/files/patch-rexxapi-RexxAPIManager.cpp
new file mode 100644
index 000000000000..060fb29c5911
--- /dev/null
+++ b/lang/oorexx/files/patch-rexxapi-RexxAPIManager.cpp
@@ -0,0 +1,12 @@
+--- rexxapi/RexxAPIManager.cpp.orig 2007-11-14 03:31:03.000000000 +0600
++++ rexxapi/RexxAPIManager.cpp 2007-11-14 03:32:26.000000000 +0600
+@@ -108,6 +108,9 @@
+ #include <signal.h>
+ #include <limits.h>
+ #endif
++#if defined(__FreeBSD__)
++#include <limits.h>
++#endif
+ /* #if defined(LINUX) && !defined(OPSYS_SUN) */
+ /* #include <bits/posix1_lim.h> */
+ /* #endif */