aboutsummaryrefslogtreecommitdiff
path: root/lang/p2c
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1994-10-20 01:51:56 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1994-10-20 01:51:56 +0000
commit3e790a10b5986696d132230c686648f335f94f60 (patch)
tree2eab9799856d9a1206b6e4b60b58f8dea1e35fef /lang/p2c
parentd50ac316fc9969968111fe9566c698fa6a4e1fc5 (diff)
downloadports-3e790a10b5986696d132230c686648f335f94f60.tar.gz
ports-3e790a10b5986696d132230c686648f335f94f60.zip
Changes from Jean-Marc Zucconi to obey PREFIX properly.
Submitted by: jmz
Notes
Notes: svn path=/head/; revision=247
Diffstat (limited to 'lang/p2c')
-rw-r--r--lang/p2c/Makefile9
-rw-r--r--lang/p2c/scripts/configure20
2 files changed, 16 insertions, 13 deletions
diff --git a/lang/p2c/Makefile b/lang/p2c/Makefile
index 329565bb433c..b2199d1dd917 100644
--- a/lang/p2c/Makefile
+++ b/lang/p2c/Makefile
@@ -3,10 +3,11 @@ DISTFILES= p2c-1.21alpha2.tar.gz
MASTER_SITES= ftp://src.doc.ic.ac.uk/gnu/hurd/
pre-install:
- @mkdir -p /usr/local/lib
- @mkdir -p /usr/local/man/man1
- @mkdir -p /usr/local/include/p2c
- @cp ${WRKSRC}/src/p2cc.man /usr/local/man/man1/p2cc.1
+ @mkdir -p ${PREFIX}/bin
+ @mkdir -p ${PREFIX}/lib
+ @mkdir -p ${PREFIX}/man/man1
+ @mkdir -p ${PREFIX}/include/p2c
+ @cp ${WRKSRC}/src/p2cc.man ${PREFIX}/man/man1/p2cc.1
.include <bsd.port.mk>
diff --git a/lang/p2c/scripts/configure b/lang/p2c/scripts/configure
index eab3c4597275..d1784843c707 100644
--- a/lang/p2c/scripts/configure
+++ b/lang/p2c/scripts/configure
@@ -1,19 +1,21 @@
#!/bin/sh
-cat >>${WRKSRC}/Makefile <<END || exit 1;
+cat >>$WRKSRC/Makefile <<END || exit 1;
+
all:
cd src; make OPT=-O
END
-mv ${WRKSRC}/src/p2cc.perl ${WRKSRC}/src/p2cc.perl.orig || exit 1;
-sed -e 1s/--.*// < ${WRKSRC}/src/p2cc.perl.orig > ${WRKSRC}/src/p2cc.perl || exit 1;
+mv $WRKSRC/src/p2cc.perl $WRKSRC/src/p2cc.perl.orig || exit 1;
+sed -e 1s/--.*// < $WRKSRC/src/p2cc.perl.orig > $WRKSRC/src/p2cc.perl || exit 1;
-cat >>${WRKSRC}/src/Makefile <<END || exit 1;
-HOMEDIR=/usr/local/lib/p2c
-INCDIR=/usr/local/include/p2c
-BINDIR=/usr/local/bin
-LIBDIR=/usr/local/lib
-MANDIR=/usr/local/man/man1
+cat >>$WRKSRC/src/Makefile <<END || exit 1;
+HOMEDIR=$PREFIX/lib/p2c
+INCDIR=$PREFIX/include/p2c
+BINDIR=$PREFIX/bin
+LIBDIR=$PREFIX/lib
+MANDIR=$PREFIX/man/man1
+ABSHOMEDIR=$PREFIX/lib/p2c
END
exit 0;