aboutsummaryrefslogtreecommitdiff
path: root/lang/p5-TryCatch/Makefile
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-04-25 00:00:11 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-04-25 00:00:11 +0000
commitd7aa7c3c08ff76e2e41175e8d79cacfe5a81b391 (patch)
tree43ad2599f73eb799d75b472ae66d7670590d82db /lang/p5-TryCatch/Makefile
parent5e6bfa47f6116cf200f723dd15eee94e85de90e6 (diff)
downloadports-d7aa7c3c08ff76e2e41175e8d79cacfe5a81b391.tar.gz
ports-d7aa7c3c08ff76e2e41175e8d79cacfe5a81b391.zip
- This module aims to provide a nicer syntax and method to catch errors in
Perl, similar to what is found in other languages (such as Java, Python or C++). The standard method of using eval {}; if($@) {} is often prone to subtle bugs, primarily that tis far too easy to stomp on the error in error handlers. And also eval/if isn't the nicest idiom. WWW: http://search.cpan.org/dist/TryCatch PR: ports/145951 Submitted by: Jonathan Chu <milki@rescomp.berkeley.edu>
Notes
Notes: svn path=/head/; revision=253190
Diffstat (limited to 'lang/p5-TryCatch/Makefile')
-rw-r--r--lang/p5-TryCatch/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/lang/p5-TryCatch/Makefile b/lang/p5-TryCatch/Makefile
new file mode 100644
index 000000000000..be99181244fd
--- /dev/null
+++ b/lang/p5-TryCatch/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-TryCatch
+# Date created: 22 April 2010
+# Whom: milki
+#
+# $FreeBSD$
+#
+
+PORTNAME= TryCatch
+PORTVERSION= 1.002000
+CATEGORIES= lang perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/A/AS/ASH
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= milki@rescomp.berkeley.edu
+COMMENT= First class try catch semantics for Perl, without source filters
+
+BUILD_DEPENDS= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-ExtUtils-Depends>=0.302:${PORTSDIR}/devel/p5-ExtUtils-Depends \
+ p5-B-Hooks-OP-Check>=0.18:${PORTSDIR}/devel/p5-B-Hooks-OP-Check \
+ p5-B-Hooks-OP-PPAddr>=0.03:${PORTSDIR}/devel/p5-B-Hooks-OP-PPAddr
+RUN_DEPENDS= p5-Parse-Method-Signatures>=1.003012:${PORTSDIR}/devel/p5-Parse-Method-Signatures \
+ p5-B-Hooks-EndOfScope>=0.08:${PORTSDIR}/devel/p5-B-Hooks-EndOfScope \
+ p5-Devel-Declare>=0.005007:${PORTSDIR}/devel/p5-Devel-Declare \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-Types>=0:${PORTSDIR}/devel/p5-MooseX-Types \
+ p5-Scope-Upper>=0.06:${PORTSDIR}/devel/p5-Scope-Upper \
+ p5-Variable-Magic>=0.28:${PORTSDIR}/devel/p5-Variable-Magic \
+ p5-Sub-Exporter>=0.979:${PORTSDIR}/devel/p5-Sub-Exporter \
+ p5-XSLoader>=0:${PORTSDIR}/devel/p5-XSLoader
+
+PERL_CONFIGURE= 5.8.1+
+
+MAN3= TryCatch.3
+
+.include <bsd.port.mk>