aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.14/pkg-plist
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /lang/perl5.14/pkg-plist
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'lang/perl5.14/pkg-plist')
-rw-r--r--lang/perl5.14/pkg-plist13
1 files changed, 4 insertions, 9 deletions
diff --git a/lang/perl5.14/pkg-plist b/lang/perl5.14/pkg-plist
index 00c052af3cd0..7a0457717878 100644
--- a/lang/perl5.14/pkg-plist
+++ b/lang/perl5.14/pkg-plist
@@ -678,7 +678,6 @@ lib/perl5/%%PERL_VER%%/integer.pm
lib/perl5/%%PERL_VER%%/less.pm
lib/perl5/%%PERL_VER%%/locale.pm
lib/perl5/%%PERL_VER%%/look.pl
-lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/.packlist
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/B.pm
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/B/Concise.pm
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/B/Showlex.pm
@@ -2999,14 +2998,10 @@ man/man1/s2p.1.gz
man/man1/shasum.1.gz
man/man1/splain.1.gz
man/man1/xsubpp.1.gz
-@dir lib/perl5/%%PERL_VER%%/man/man3
+@dir %%SITE_PERL%%/man/man3
@dir %%SITE_PERL%%/auto
-@dir %%SITE_PERL%%/%%PERL_ARCH%%/auto
-@dir %%SITE_PERL%%/%%PERL_ARCH%%/machine
-@dir %%SITE_PERL%%/%%PERL_ARCH%%/sys
-@exec cd /usr/include && %D/bin/h2ph -d %D/%%SITE_PERL%%/%%PERL_ARCH%% *.h machine/*.h sys/*.h >/dev/null
+@dir %%SITE_ARCH%%/auto
+@exec makewhatis %D/%%SITE_PERL%%/man
@exec makewhatis %D/lib/perl5/%%PERL_VER%%/man
-@exec makewhatis %D/lib/perl5/%%PERL_VER%%/perl/man
@rmtry lib/perl5/%%PERL_VER%%/man/whatis
-@rmtry lib/perl5/%%PERL_VER%%/perl/man/whatis
-@unexec find %D/%%SITE_PERL%%/%%PERL_ARCH%%/ -name '*.ph' -delete 2>/dev/null || true
+@rmtry %%SITE_PERL%%/man/whatis