aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.14
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-08-08 14:32:41 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-08-08 14:32:41 +0000
commit137c0739787e2293bc9e748407e675869865f23a (patch)
treebec6fa6a1d069b7a866672ff38353411bc8e5471 /lang/perl5.14
parent8f03d4ac9401d3c005f243310d7b95828acd1872 (diff)
downloadports-137c0739787e2293bc9e748407e675869865f23a.tar.gz
ports-137c0739787e2293bc9e748407e675869865f23a.zip
- Fix perl configure erroneously saving /usr/local/script as a site script install directory if it's present, which leads to misinstallation of many ports which install perl scripts (p5-Mail-SpamAssassin, for example)
PR: 149771 Submitted by: Peter Radcliffe <pir-freebsd.org@pir.net> Patch by: myself Approved by: jadawin
Notes
Notes: svn path=/head/; revision=279239
Diffstat (limited to 'lang/perl5.14')
-rw-r--r--lang/perl5.14/Makefile1
-rw-r--r--lang/perl5.14/files/patch-Configure12
2 files changed, 12 insertions, 1 deletions
diff --git a/lang/perl5.14/Makefile b/lang/perl5.14/Makefile
index 65e2f17fa089..b847383570e0 100644
--- a/lang/perl5.14/Makefile
+++ b/lang/perl5.14/Makefile
@@ -7,6 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
+PORTREVISION= 1
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN \
${MASTER_SITE_LOCAL:S/$/:local/} \
diff --git a/lang/perl5.14/files/patch-Configure b/lang/perl5.14/files/patch-Configure
index 0abb559cbc33..21ccd2c8c62e 100644
--- a/lang/perl5.14/files/patch-Configure
+++ b/lang/perl5.14/files/patch-Configure
@@ -1,6 +1,6 @@
--- Configure.orig 2010-07-14 15:28:45.000000000 +0000
+++ Configure 2010-07-14 15:29:23.000000000 +0000
-@@ -4780,7 +4780,7 @@
+@@ -4798,7 +4798,7 @@
libpth=''
for xxx in $dlist
do
@@ -9,3 +9,13 @@
case " $libpth " in
*" $xxx "*) ;;
*) libpth="$libpth $xxx";;
+@@ -9125,8 +9125,7 @@
+
+ : determine where add-on public executable scripts go
+ case "$sitescript" in
+-'') dflt=$siteprefix/script
+- $test -d $dflt || dflt=$sitebin ;;
++'') dflt=$sitebin ;;
+ *) dflt="$sitescript" ;;
+ esac
+ fn=d~+