aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.16/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-04-09 12:21:29 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-04-09 12:21:29 +0000
commitbfee655ccfd4b4ce770d4aca8a31f44df7d52229 (patch)
tree13588e47865d92c5a884f61a462b25fb3c56bb9f /lang/perl5.16/Makefile
parentbddf326fa5675b66aa0acafb32d4ad5383cf38fc (diff)
downloadports-bfee655ccfd4b4ce770d4aca8a31f44df7d52229.tar.gz
ports-bfee655ccfd4b4ce770d4aca8a31f44df7d52229.zip
Make Perl build more reproducibly.
Differential Revision: https://reviews.freebsd.org/D2016 Some bits from: Jérémy Bobbio <lunar@debian.org> Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=383641
Diffstat (limited to 'lang/perl5.16/Makefile')
-rw-r--r--lang/perl5.16/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/lang/perl5.16/Makefile b/lang/perl5.16/Makefile
index d3d8bdb49282..e9a2b3b7d93d 100644
--- a/lang/perl5.16/Makefile
+++ b/lang/perl5.16/Makefile
@@ -3,7 +3,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../../src
@@ -67,7 +67,9 @@ CONFIGURE_ARGS= -sde -Dprefix=${PREFIX} \
-Dsiteman1dir=${PREFIX}/man/man1 \
-Dotherlibdirs=${PREFIX}/lib/perl5/site_perl/${PERL_VER}:${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH} \
-Ui_malloc -Ui_iconv -Uinstallusrbinperl -Dusenm=n \
- -Dcc="${CC}" -Duseshrplib -Dinc_version_list=none
+ -Dcc="${CC}" -Duseshrplib -Dinc_version_list=none \
+ -Dcf_by=${MAINTAINER:C,@.*,,} -Dcf_email=${MAINTAINER} \
+ -Dcf_time="`env LANG=C ${STAT} -t \"%a %b %d %T %Z %Y\" -f %Sm ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX}`"
# Keep the following two in sync.
# lddlflags is used for all .so linking
# shrpldflags is used for libperl.so, so remove all the extra bits inherited from lddlflags.