aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.18
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-10-08 12:10:54 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-10-08 12:10:54 +0000
commitadc0d56a13ea9e27224256f15fa66771dd447f50 (patch)
tree36fb2ed9a61dcdda5394ebd4d6ae75c49d0e0a45 /lang/perl5.18
parent03b2deaf057256c14eceb77cdc58389d157ad0df (diff)
downloadports-adc0d56a13ea9e27224256f15fa66771dd447f50.tar.gz
ports-adc0d56a13ea9e27224256f15fa66771dd447f50.zip
Use the test framework to run perl's tests.
Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=398814
Diffstat (limited to 'lang/perl5.18')
-rw-r--r--lang/perl5.18/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/lang/perl5.18/Makefile b/lang/perl5.18/Makefile
index 225f67c8c029..be460404cd32 100644
--- a/lang/perl5.18/Makefile
+++ b/lang/perl5.18/Makefile
@@ -19,6 +19,9 @@ LICENSE_FILE_GPLv1= ${WRKSRC}/Copying
DEPRECATED= Unsupported, please upgrade to a more recent version of Perl
EXPIRATION_DATE=2016-12-31
+TEST_TARGET= test_harness
+TEST_ENV= ${MAKE_ENV} TEST_JOBS=${MAKE_JOBS_NUMBER}
+
OPTIONS_DEFINE= DEBUG GDBM PERL_64BITINT PTHREAD \
MULTIPLICITY SITECUSTOMIZE USE_PERL
# it seems perl malloc has problems with threaded perl on FreeBSD
@@ -246,9 +249,4 @@ post-install:
done
${INSTALL_DATA} ${WRKDIR}/perl-man.conf ${STAGEDIR}${PREFIX}/etc/man.d/perl${PERL_VER}.conf
-test: build
- (cd ${WRKSRC}; TEST_JOBS=${MAKE_JOBS_NUMBER} make test_harness)
-
-regression-test: test
-
.include <bsd.port.mk>