aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.20
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-08-31 13:17:48 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-08-31 13:17:48 +0000
commit398dca09df851a70f0a4c887f43155242dc35a31 (patch)
treefd7ea3eddaacad9b5eec9befdd34907fa9b6e88c /lang/perl5.20
parentbd7fbe226ce90cceac4c1b47cb3914f8820c66eb (diff)
downloadports-398dca09df851a70f0a4c887f43155242dc35a31.tar.gz
ports-398dca09df851a70f0a4c887f43155242dc35a31.zip
To ease up with future upgrades, move PERL_VERSION into a separate file.
While there, remove 8.4 support, and do some cleanup. Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=395673
Diffstat (limited to 'lang/perl5.20')
-rw-r--r--lang/perl5.20/Makefile19
-rw-r--r--lang/perl5.20/files/use.perl.in42
-rw-r--r--lang/perl5.20/pkg-plist2
-rw-r--r--lang/perl5.20/version.mk1
4 files changed, 5 insertions, 59 deletions
diff --git a/lang/perl5.20/Makefile b/lang/perl5.20/Makefile
index 1d14c879bf70..3d6cce40a889 100644
--- a/lang/perl5.20/Makefile
+++ b/lang/perl5.20/Makefile
@@ -53,7 +53,7 @@ PERL_MALLOC_CONFIGURE_OFF= -Dusemymalloc=n
PORTSCOUT= limit:^${PERL_VER}.
# Remember to update Mk/Uses/perl5.mk too.
-PERL_VERSION= 5.20.2
+.include "version.mk"
PERL_VER= ${PERL_VERSION:C/\.[0-9]+$//}
PERL_ARCH= mach
SITE_PERL_REL?= lib/perl5/site_perl
@@ -108,7 +108,7 @@ SUB_LIST+= PERL_VERSION=${PERL_VERSION} \
SITEMAN3PREFIX=${SITE_MAN3_PREFIX} \
PERL_ARCH=${PERL_ARCH}
-SUB_FILES= perl5_version
+SUB_FILES= perl5_version perl-man.conf
INSTALL_TARGET= install-strip
@@ -144,7 +144,6 @@ PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
PRIV_LIB=${_PRIV_LIB} \
ARCH_LIB=${_ARCH_LIB}
-.include <bsd.port.pre.mk>
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
# if this port is default due PERL5_DEFAULT
@@ -158,16 +157,6 @@ PKGNAMESUFFIX= ${PERL_VER}
CONFLICTS_INSTALL+= perl5-*
.endif
-.if ${OSVERSION} >= 900022
-SUB_FILES+= perl-man.conf
-PLIST_SUB+= MANCONF=""
-.else
-# FIXME when 8.4 goes out, remove this
-SUB_FILES+= use.perl
-PLIST_SUB+= MANCONF="@comment "
-PKGINSTALL= ${WRKDIR}/use.perl
-PKGDEINSTALL= ${WRKDIR}/use.perl
-.endif
# Put a symlink to the future libperl.so.x.yy so that -lperl works.
post-extract:
@@ -210,13 +199,11 @@ post-install:
${STRIP_CMD} $$f; \
${CHMOD} 444 $$f; \
done
-.if ${OSVERSION} >= 900022
${INSTALL_DATA} ${WRKDIR}/perl-man.conf ${STAGEDIR}${PREFIX}/etc/man.d/perl${PERL_VER}.conf
-.endif
test: build
(cd ${WRKSRC}; TEST_JOBS=${MAKE_JOBS_NUMBER} make test_harness)
regression-test: test
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/perl5.20/files/use.perl.in b/lang/perl5.20/files/use.perl.in
deleted file mode 100644
index e50f83b9d0d2..000000000000
--- a/lang/perl5.20/files/use.perl.in
+++ /dev/null
@@ -1,42 +0,0 @@
-#!/bin/sh
-
-# $FreeBSD$
-
-: ${OSVERSION:=`/sbin/sysctl -n kern.osreldate`};
-PERL_VERSION="%%PERL_VERSION%%"
-banner="# added by use.perl $(/bin/date +'%F %T')"
-
-do_cleanup_manpath()
-{
- if [ -f /etc/manpath.config ] ; then
- /bin/cp -p /etc/manpath.config /etc/manpath.config.new
- /usr/bin/awk 's=0;
- /^#.*use.perl/ { s=1; mode=1 }
- /^#/ { s=1; if (mode != 1) { mode=0 } }
- /^OPTIONAL_MANPATH.*perl5/ { s=1; if (mode == 1) { mode=2 } }
- /^$/ { s=1; if (mode != 2) { mode = 0 } }
- { if (s != 1) { mode = 0 } if (mode == 0) print }' /etc/manpath.config >/etc/manpath.config.new
- /bin/mv /etc/manpath.config /etc/manpath.config.bak
- /bin/mv /etc/manpath.config.new /etc/manpath.config
- /bin/rm /etc/manpath.config.bak
- fi
-}
-
-do_spam_manpath()
-{
- if [ -f /etc/manpath.config ] ; then
- echo "${banner}" >>/etc/manpath.config
- echo "OPTIONAL_MANPATH ${PKG_PREFIX}/%%SITEMAN3PREFIX%%/man" >>/etc/manpath.config
- echo "OPTIONAL_MANPATH ${PKG_PREFIX}/%%MAN3PREFIX%%/man" >>/etc/manpath.config
- fi
-}
-
-
-if [ "$2" = "POST-INSTALL" ] ; then
- do_cleanup_manpath
- do_spam_manpath
-elif [ "$2" = "POST-DEINSTALL" ] ; then
- do_cleanup_manpath
-fi
-
-exit 0
diff --git a/lang/perl5.20/pkg-plist b/lang/perl5.20/pkg-plist
index 5146eeafff70..57ecd46e8d09 100644
--- a/lang/perl5.20/pkg-plist
+++ b/lang/perl5.20/pkg-plist
@@ -36,7 +36,7 @@ bin/shasum
bin/splain
bin/xsubpp
bin/zipdetails
-%%MANCONF%%etc/man.d/perl%%PERL_VER%%.conf
+etc/man.d/perl%%PERL_VER%%.conf
etc/perl5_version
%%PRIV_LIB%%/AnyDBM_File.pm
%%PRIV_LIB%%/App/Cpan.pm
diff --git a/lang/perl5.20/version.mk b/lang/perl5.20/version.mk
new file mode 100644
index 000000000000..fc6609893cf1
--- /dev/null
+++ b/lang/perl5.20/version.mk
@@ -0,0 +1 @@
+PERL_VERSION= 5.20.2