aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.20
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-05-09 16:03:40 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-05-09 16:03:40 +0000
commit5ba8187c38021ae1c20c686b189d588c8ab2009f (patch)
tree2aeca2a93057e2a88a3588f8e9cb17f66024e09a /lang/perl5.20
parent27d5e0b3bc05723ddbc19b7e4f305cbea354b6f5 (diff)
downloadports-5ba8187c38021ae1c20c686b189d588c8ab2009f.tar.gz
ports-5ba8187c38021ae1c20c686b189d588c8ab2009f.zip
A new release was done, so resync all the Perl 5 Makefiles a bit more,
and adjust the perl5-devel Makefile a bit for the couple of new tasks that need doing. Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=414862
Diffstat (limited to 'lang/perl5.20')
-rw-r--r--lang/perl5.20/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/lang/perl5.20/Makefile b/lang/perl5.20/Makefile
index 8e9a75e8942f..201e37004906 100644
--- a/lang/perl5.20/Makefile
+++ b/lang/perl5.20/Makefile
@@ -51,7 +51,6 @@ THREADS_CONFIGURE_OFF= -Dusethreads=n
PERL_MALLOC_CONFIGURE_ON= -Dusemymalloc=y
PERL_MALLOC_CONFIGURE_OFF= -Dusemymalloc=n
-# For the older Perl ports, this should be:
PORTSCOUT= limit:^${PERL_VER}.
.include "version.mk"
@@ -70,7 +69,8 @@ SITE_MAN1?= ${PREFIX}/${SITE_MAN1_REL}
_PRIV_LIB= lib/perl5/${PERL_VER}
_ARCH_LIB= ${_PRIV_LIB}/${PERL_ARCH}
-USES= tar:bzip2 cpe
+USES= cpe tar:bzip2
+
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT=Configure
CONFIGURE_ARGS= -sde -Dprefix=${PREFIX} \
@@ -161,7 +161,7 @@ _PERL5_DEFAULT_FILE= /tmp/PERL5_DEFAULT
# if this port is default due PERL5_DEFAULT
# change PKGNAME to reflect this
.if ${PERL_VER} == ${PERL5_DEFAULT}
-PKGNAMESUFFIX= ${PERL_VERSION:C/\.[0-9]+\.[0-9]+$//}
+PKGNAMESUFFIX= 5
IAMDEFAULTPERL= yes
.else
# make PKGNAME unique among other lang/perl5.x
@@ -218,8 +218,6 @@ post-clean:
@${RM} ${_PERL5_DEFAULT_FILE}
.endif
-.if !defined(MAKING_PATCHES)
-# make clean patch makepatch MAKING_PATCHES=
post-patch:
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/Configure ${WRKSRC}/hints/freebsd.sh
@@ -234,7 +232,6 @@ post-patch-PTHREAD-on:
post-patch-PTHREAD-off:
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%||g;' \
${WRKSRC}/hints/freebsd.sh
-.endif
post-build:
@${REINPLACE_CMD} -e '/^lddlflags/s|-L${WRKSRC} ||' \