aboutsummaryrefslogtreecommitdiff
path: root/lang/php5
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2007-02-15 06:52:30 +0000
committerAlex Dupre <ale@FreeBSD.org>2007-02-15 06:52:30 +0000
commit9312854b8ca6e595b8c51248fd612a496a724aa7 (patch)
tree5b5396b804d64a2b7dd794cf5690de52ffd8d6b6 /lang/php5
parent6773b2c49d9886ffb8fdb75346cf1fd4cfb61356 (diff)
downloadports-9312854b8ca6e595b8c51248fd612a496a724aa7.tar.gz
ports-9312854b8ca6e595b8c51248fd612a496a724aa7.zip
Fix a crashbug on str_replace().
Submitted by: esser Obtained from: PHP CVS
Notes
Notes: svn path=/head/; revision=185213
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/Makefile2
-rw-r--r--lang/php5/files/patch-ext_standard_string.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index cfeed28af2ef..918c9af86528 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= php5
PORTVERSION= 5.2.1
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
http://downloads.php.net/ilia/:rc \
diff --git a/lang/php5/files/patch-ext_standard_string.c b/lang/php5/files/patch-ext_standard_string.c
new file mode 100644
index 000000000000..1bf5dc8377eb
--- /dev/null
+++ b/lang/php5/files/patch-ext_standard_string.c
@@ -0,0 +1,11 @@
+--- ext/standard/string.c.orig Thu Feb 15 07:50:09 2007
++++ ext/standard/string.c Thu Feb 15 07:50:33 2007
+@@ -3148,7 +3148,7 @@
+ }
+
+ Z_STRLEN_P(result) = len + (char_count * (to_len - 1));
+- Z_STRVAL_P(result) = target = safe_emalloc(char_count, to_len, len);
++ Z_STRVAL_P(result) = target = safe_emalloc(char_count, to_len, len + 1);
+ Z_TYPE_P(result) = IS_STRING;
+
+ if (case_sensitivity) {