aboutsummaryrefslogtreecommitdiff
path: root/lang/php70/Makefile.ext
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:08:37 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:08:37 +0000
commita9dcad2fffcc27906b85c5a15fdb3e50fdc1e2e2 (patch)
tree23607acdfffe977946d3c7bb877bab60e64640e7 /lang/php70/Makefile.ext
parent4e1b79a0a61f4973df8b4b0864d22086c769e219 (diff)
downloadports-a9dcad2fffcc27906b85c5a15fdb3e50fdc1e2e2.tar.gz
ports-a9dcad2fffcc27906b85c5a15fdb3e50fdc1e2e2.zip
Remove ${PORTSDIR}/ from dependencies, categories h, i, j, k, and l.
With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=412347
Diffstat (limited to 'lang/php70/Makefile.ext')
-rw-r--r--lang/php70/Makefile.ext50
1 files changed, 25 insertions, 25 deletions
diff --git a/lang/php70/Makefile.ext b/lang/php70/Makefile.ext
index ad0d0bebc9de..871e1ed1091b 100644
--- a/lang/php70/Makefile.ext
+++ b/lang/php70/Makefile.ext
@@ -32,7 +32,7 @@ CONFIGURE_ARGS+=--enable-ctype
.endif
.if ${PHP_MODNAME} == "curl"
-LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:ftp/curl
CONFIGURE_ARGS+=--with-curl=${LOCALBASE}
.endif
@@ -86,8 +86,8 @@ USE_OPENSSL= yes
.endif
.if ${PHP_MODNAME} == "gd"
-LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
- libpng.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libfreetype.so:print/freetype2 \
+ libpng.so:graphics/png
USES+= jpeg
CONFIGURE_ARGS+=--with-gd \
@@ -115,7 +115,7 @@ USES+= gettext
.endif
.if ${PHP_MODNAME} == "gmp"
-LIB_DEPENDS+= libgmp.so:${PORTSDIR}/math/gmp
+LIB_DEPENDS+= libgmp.so:math/gmp
CONFIGURE_ARGS+=--with-gmp=${LOCALBASE}
.endif
@@ -151,7 +151,7 @@ USES+= firebird
.if ${PHP_MODNAME} == "intl"
CONFIGURE_ARGS+=--with-intl=${LOCALBASE}
-LIB_DEPENDS= libicui18n.so:${PORTSDIR}/devel/icu
+LIB_DEPENDS= libicui18n.so:devel/icu
.endif
.if ${PHP_MODNAME} == "json"
@@ -182,8 +182,8 @@ PHP_HEADER_DIRS=libmbfl libmbfl/filters libmbfl/mbfl libmbfl/nls
.endif
.if ${PHP_MODNAME} == "mcrypt"
-LIB_DEPENDS+= libltdl.so:${PORTSDIR}/devel/libltdl \
- libmcrypt.so:${PORTSDIR}/security/libmcrypt
+LIB_DEPENDS+= libltdl.so:devel/libltdl \
+ libmcrypt.so:security/libmcrypt
CONFIGURE_ARGS+=--with-mcrypt=${LOCALBASE}
.endif
@@ -196,7 +196,7 @@ MYSQLND_DESC= Use MySQL Native Driver
.endif
.if ${PHP_MODNAME} == "odbc"
-LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= libodbc.so:databases/unixODBC
CONFIGURE_ARGS+=--enable-odbc \
--with-unixODBC=${LOCALBASE}
@@ -242,7 +242,7 @@ USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "pdo_odbc"
-LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= libodbc.so:databases/unixODBC
CONFIGURE_ARGS+=--with-pdo-odbc=unixODBC,${LOCALBASE}
USE_PHP= pdo
@@ -295,7 +295,7 @@ CONFIGURE_ARGS+=--enable-posix
.endif
.if ${PHP_MODNAME} == "pspell"
-LIB_DEPENDS+= libaspell.so:${PORTSDIR}/textproc/aspell
+LIB_DEPENDS+= libaspell.so:textproc/aspell
CONFIGURE_ARGS+=--with-pspell=${LOCALBASE}
@@ -310,7 +310,7 @@ USES+= readline
.endif
.if ${PHP_MODNAME} == "recode"
-LIB_DEPENDS+= librecode.so:${PORTSDIR}/converters/recode
+LIB_DEPENDS+= librecode.so:converters/recode
CONFIGURE_ARGS+=--with-recode=${LOCALBASE}
.endif
@@ -338,7 +338,7 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE} \
CONFIGURE_ENV+= ac_cv_buggy_snprint_value="no"
-LIB_DEPENDS+= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
+LIB_DEPENDS+= libnetsnmp.so:net-mgmt/net-snmp
LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
.endif
@@ -363,7 +363,7 @@ CONFIGURE_ARGS+=--with-sqlite3=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "sybase_ct"
-LIB_DEPENDS+= libct.so:${PORTSDIR}/databases/freetds
+LIB_DEPENDS+= libct.so:databases/freetds
CONFIGURE_ARGS+=--with-sybase-ct=${LOCALBASE}
.endif
@@ -383,7 +383,7 @@ CONFIGURE_ARGS+=--enable-sysvshm
.if ${PHP_MODNAME} == "tidy"
CONFIGURE_ARGS+=--with-tidy=${LOCALBASE}
-LIB_DEPENDS+= libtidy.so:${PORTSDIR}/www/tidy-lib
+LIB_DEPENDS+= libtidy.so:www/tidy-lib
.endif
.if ${PHP_MODNAME} == "tokenizer"
@@ -447,7 +447,7 @@ USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "zip"
-LIB_DEPENDS+= libzip.so:${PORTSDIR}/archivers/libzip
+LIB_DEPENDS+= libzip.so:archivers/libzip
CONFIGURE_ARGS+=--enable-zip \
--with-zlib-dir=/usr \
@@ -472,17 +472,17 @@ USE_BDB= 40+
WITH_BDB_HIGHEST= yes
. endif
. if ${PORT_OPTIONS:MGDBM}
-LIB_DEPENDS+= libgdbm.so:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= libgdbm.so:databases/gdbm
CONFIGURE_ARGS+=--with-gdbm=${LOCALBASE}
. endif
. if ${PORT_OPTIONS:MQDBM}
-LIB_DEPENDS+= libqdbm.so:${PORTSDIR}/databases/qdbm
+LIB_DEPENDS+= libqdbm.so:databases/qdbm
CONFIGURE_ARGS+=--with-qdbm=${LOCALBASE}
. endif
. if ${PORT_OPTIONS:MTOKYO}
-LIB_DEPENDS+= libtokyocabinet.so:${PORTSDIR}/databases/tokyocabinet
+LIB_DEPENDS+= libtokyocabinet.so:databases/tokyocabinet
CONFIGURE_ARGS+=--with-tcadb=${LOCALBASE}
. endif
@@ -496,7 +496,7 @@ CONFIGURE_ARGS+=--disable-flatfile
.if ${PHP_MODNAME} == "gd"
. if ${PORT_OPTIONS:MT1LIB}
-LIB_DEPENDS+= libt1.so:${PORTSDIR}/devel/t1lib
+LIB_DEPENDS+= libt1.so:devel/t1lib
CONFIGURE_ARGS+=--with-t1lib=${LOCALBASE}
. endif
@@ -512,7 +512,7 @@ USE_XORG= xpm
CONFIGURE_ARGS+=--with-xpm-dir=${LOCALBASE}
. endif
. if ${PORT_OPTIONS:MVPX}
-LIB_DEPENDS+= libvpx.so:${PORTSDIR}/multimedia/libvpx
+LIB_DEPENDS+= libvpx.so:multimedia/libvpx
CONFIGURE_ARGS+=--with-vpx-dir=${LOCALBASE}
. endif
@@ -520,15 +520,15 @@ CONFIGURE_ARGS+=--with-vpx-dir=${LOCALBASE}
.if ${PHP_MODNAME} == "imap"
. if ${PORT_OPTIONS:MPANDA}
-LIB_DEPENDS+= libc-client4.so.10:${PORTSDIR}/mail/panda-cclient
+LIB_DEPENDS+= libc-client4.so.10:mail/panda-cclient
. else
-LIB_DEPENDS+= libc-client4.so.9:${PORTSDIR}/mail/cclient
+LIB_DEPENDS+= libc-client4.so.9:mail/cclient
. endif
.endif
.if ${PHP_MODNAME} == "mbstring"
. if ${PORT_OPTIONS:MREGEX}
-LIB_DEPENDS+= libonig.so:${PORTSDIR}/devel/oniguruma5
+LIB_DEPENDS+= libonig.so:devel/oniguruma5
CONFIGURE_ARGS+=--with-onig=${LOCALBASE}
. else
CONFIGURE_ARGS+=--disable-mbregex
@@ -561,9 +561,9 @@ post-extract:
.if ${PHP_MODNAME} == "pdo_dblib"
. if ${PORT_OPTIONS:MMSSQL}
-LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds
+LIB_DEPENDS+= libsybdb.so:databases/freetds
. else
-LIB_DEPENDS+= libct.so:${PORTSDIR}/databases/freetds
+LIB_DEPENDS+= libct.so:databases/freetds
. endif
.endif