aboutsummaryrefslogtreecommitdiff
path: root/lang/pike72/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-04-03 02:05:18 +0000
committerSteve Price <steve@FreeBSD.org>1999-04-03 02:05:18 +0000
commit823617c5f6d39f2dcfd959a9a176e7edd9addae5 (patch)
treea9cc6741c8bada73c570e71bdf67e2d2922f6225 /lang/pike72/Makefile
parent7159d2fa1715098059e941d3fe03f542f696cd5f (diff)
downloadports-823617c5f6d39f2dcfd959a9a176e7edd9addae5.tar.gz
ports-823617c5f6d39f2dcfd959a9a176e7edd9addae5.zip
Import of pike version 0.6.110.
A dynamic programming language with a syntax similar to C++. PR: 9783 Submitted by: Vladimir N.Silyaev <vns@delta.odessa.ua>
Notes
Notes: svn path=/head/; revision=17608
Diffstat (limited to 'lang/pike72/Makefile')
-rw-r--r--lang/pike72/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/lang/pike72/Makefile b/lang/pike72/Makefile
new file mode 100644
index 000000000000..74ca0d72f13b
--- /dev/null
+++ b/lang/pike72/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: pike
+# Version required: 0.6
+# Date created: 16 Jan 1999
+# Whom: vns@delta.odessa.ua
+#
+# $Id:$
+#
+
+DISTNAME= Pike-v0.6.110
+PKGNAME= pike-0.6
+CATEGORIES= lang
+MASTER_SITES= http://pike.idonex.se/download/
+
+MAINTAINER= vns@delta.odessa.ua
+
+pre-fetch:
+.if !defined(BATCH)
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.pike
+.endif
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src/
+
+IS_INTERACTIVE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS?= \
+ --without-ttflib \
+ --without-gdbm \
+ --without-mysql \
+ --without-postgresql \
+ --without-msql \
+ --without-jpeg
+
+pre-configure:
+ @${ECHO} ${CONFIGURE_ARGS}
+
+.include <bsd.port.mk>