aboutsummaryrefslogtreecommitdiff
path: root/lang/pike72
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-05-06 09:15:09 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-05-06 09:15:09 +0000
commit1cc31ebddac62770dbe3c12fae3622439618c34c (patch)
treedecbd8b80f04d437f46472f82b54300fe58bac0e /lang/pike72
parente3fc9b5f522b4c2fb3ead0e029b34b8aba0b278b (diff)
downloadports-1cc31ebddac62770dbe3c12fae3622439618c34c.tar.gz
ports-1cc31ebddac62770dbe3c12fae3622439618c34c.zip
Update to version 7.2.294 and removed GNOME dependency to fix unbuildable port.
Added build dependency to gmp4 only when FreeBSD 5.0 is detected. PR: 50938 Submitted by Xavier Beaudouin <kiwi@oav.net>
Notes
Notes: svn path=/head/; revision=80246
Diffstat (limited to 'lang/pike72')
-rw-r--r--lang/pike72/Makefile36
-rw-r--r--lang/pike72/distinfo2
-rw-r--r--lang/pike72/pkg-plist2
3 files changed, 21 insertions, 19 deletions
diff --git a/lang/pike72/Makefile b/lang/pike72/Makefile
index 09587405b7f3..ff0c768d8edb 100644
--- a/lang/pike72/Makefile
+++ b/lang/pike72/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pike72
-PORTVERSION= 7.2.440
+PORTVERSION= 7.2.492
PORTREVISION= 0
CATEGORIES= lang
MASTER_SITES= ftp://ftp.oav.net/pkg_freebsd/distfiles/ \
@@ -25,8 +25,7 @@ COMMENT= A dynamic programming language with a syntax similar to C++
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm/
.endif
-LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4 \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
gdbm.3:${PORTSDIR}/databases/gdbm \
mird.1:${PORTSDIR}/databases/mird
@@ -35,9 +34,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src/
WANT_MESA= yes
WANT_GTK= yes
-WANT_GNOME= yes
-#USE_AUTOCONF_VER=213
-#USE_AUTOMAKE= yes
+#WANT_GNOME= yes
USE_BISON= yes
GNU_CONFIGURE= yes
@@ -67,10 +64,16 @@ CONFIGURE_ARGS+= --without-debug \
--without-ssleay
# --with-gdbm=${PREFIX} \
# --without-relocatable-dumped-modules \
-PLIST_SUB+= PORTVERSION=${PORTVERSION}
.include <bsd.port.pre.mk>
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+
+# FreeBSD 5.0 Needs to have libgmp port to support gmp.
+.if ${OSVERSION} >= 500000
+LIB_DEPENDS+= gmp.6:${PORTSDIR}/math/libgmp4
+.endif
+
.if exists(${LOCALBASE}/lib/libttf.so.4)
WITH_TTF= yes
.endif
@@ -177,7 +180,7 @@ CONFIGURE_ARGS+= --without-sane
.endif
.if defined(WITH_PDF)
-LIB_DEPENDS+= pdf.4:${PORTSDIR}/print/pdflib4
+LIB_DEPENDS+= pdf.5:${PORTSDIR}/print/pdflib4
CONFIGURE_ARGS+= --with-libpdf
.else
CONFIGURE_ARGS+= --without-libpdf
@@ -191,14 +194,14 @@ CONFIGURE_ARGS+= --with-GL --with-GLUT
CONFIGURE_ARGS+= --without-GL --without-GLUT
.endif
-.if defined(HAVE_GNOME)
-USE_GNOME= yes
-USE_GTK= yes
-USE_GLI= yes
-CONFIGURE_ARGS+= --with-GTK --with-gnome --with-glade
-.else
+#.if defined(HAVE_GNOME)
+#USE_GNOME= yes
+#USE_GTK= yes
+#USE_GLI= yes
+#CONFIGURE_ARGS+= --with-GTK --with-gnome --with-glade
+#.else
CONFIGURE_ARGS+= --without-GTK --without-gnome --without-glade
-.endif
+#.endif
.if (${MACHINE} == "i386")
CONFIGURE_ARGS+= --with-poll
@@ -208,6 +211,8 @@ CONFIGURE_ARGS+= --without-poll
.endif
USE_GMAKE= yes
+MAN1= hilfe.1 pike.1
+MAN1PREFIX= ${PREFIX}/pike/${PORTVERSION}
pre-everything::
.if !defined(WITH_OPTIMIZED_CFLAGS)
@@ -245,7 +250,6 @@ pre-everything::
@${ECHO_MSG} "MesaGLi, GNOME and SQL support by defining WITH_MOST."
.endif
-
pre-configure:
# @cd ${WRKSRC}; \
# ./run_autoconfig
diff --git a/lang/pike72/distinfo b/lang/pike72/distinfo
index a32f18e69607..72b2d2881f97 100644
--- a/lang/pike72/distinfo
+++ b/lang/pike72/distinfo
@@ -1 +1 @@
-MD5 (pike-7.2.440.tar.gz) = 1c1b6e166b4368f8c447bacba7a7295c
+MD5 (pike-7.2.492.tar.gz) = d6f458ece48b395cf40feb9d7bdc1bc2
diff --git a/lang/pike72/pkg-plist b/lang/pike72/pkg-plist
index c203a799156f..ade0ec7b15dd 100644
--- a/lang/pike72/pkg-plist
+++ b/lang/pike72/pkg-plist
@@ -433,8 +433,6 @@ pike/%%PORTVERSION%%/include/pike/lexer0.h
pike/%%PORTVERSION%%/include/pike/lexer1.h
pike/%%PORTVERSION%%/include/pike/lexer2.h
pike/%%PORTVERSION%%/include/pike/aclocal.m4
-pike/%%PORTVERSION%%/man/man1/hilfe.1
-pike/%%PORTVERSION%%/man/man1/pike.1
@unexec rm -rf %D/pike/%%PORTVERSION%%/lib/modules
@dirrm pike/%%PORTVERSION%%/lib/include
@unexec rm -rf %D/pike/%%PORTVERSION%%/lib/0.6