aboutsummaryrefslogtreecommitdiff
path: root/lang/pm3-base/Makefile
diff options
context:
space:
mode:
authorJohn Polstra <jdp@FreeBSD.org>2000-02-13 23:16:52 +0000
committerJohn Polstra <jdp@FreeBSD.org>2000-02-13 23:16:52 +0000
commit61db71a1984a9316fc349de34180eac6b5405a00 (patch)
treeda514b97ed4ecfde16c25cea89ae275418f15290 /lang/pm3-base/Makefile
parentea24708b74539fd3cf34c4454c1f730a25adf362 (diff)
downloadports-61db71a1984a9316fc349de34180eac6b5405a00.tar.gz
ports-61db71a1984a9316fc349de34180eac6b5405a00.zip
Use my FreeBSD.org address in the MAINTAINER line. Spell freebsd
as "FreeBSD". Check for a conflicting Modula-3 port before installing. Install the copyright notice into a different place.
Notes
Notes: svn path=/head/; revision=25785
Diffstat (limited to 'lang/pm3-base/Makefile')
-rw-r--r--lang/pm3-base/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/lang/pm3-base/Makefile b/lang/pm3-base/Makefile
index a04e01932bfb..3fbd10e2c435 100644
--- a/lang/pm3-base/Makefile
+++ b/lang/pm3-base/Makefile
@@ -1,18 +1,18 @@
# New ports collection makefile for: pm3-base
# Version required: 1.1.13
# Date created: 6 Feb 2000
-# Whom: John Polstra <jdp@freebsd.org>
+# Whom: John Polstra <jdp@FreeBSD.org>
#
# $FreeBSD$
#
DISTNAME= pm3-base-${VERSION}
CATEGORIES= lang
-MASTER_SITES= http://www.freebsd.org/~jdp/distfiles/pm3/
+MASTER_SITES= http://www.FreeBSD.org/~jdp/distfiles/pm3/
DISTFILES= ${BOOTSTRAP} \
pm3-${VERSION}-src.tar.bz2
-MAINTAINER= jdp@polstra.com
+MAINTAINER= jdp@FreeBSD.org
DIST_SUBDIR= pm3
INSTALL_TARGET= all
@@ -82,13 +82,16 @@ do-build:
@${ECHO_MSG} "This port does everything in the install step."
@${ECHO_MSG} "The build step is a no-op."
+pre-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/check_conflicts
+
do-install:
@${RM} -rf ${WRKSRC}/${TARGET}
@(ulimit -d `ulimit -Hd` && ulimit -m `ulimit -Hm` && \
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
@for i in ${PROGS}; do strip ${PREFIX}/$$i; done
- @${MKDIR} ${PREFIX}/share/pm3
- @${INSTALL_DATA} ${WRKSRC}/src/COPYRIGHT ${PREFIX}/share/pm3
+ @${MKDIR} ${PREFIX}/share/pm3-base
+ @${INSTALL_DATA} ${WRKSRC}/src/COPYRIGHT ${PREFIX}/share/pm3-base
.include <bsd.port.post.mk>