aboutsummaryrefslogtreecommitdiff
path: root/lang/pm3-base
diff options
context:
space:
mode:
authorJohn Polstra <jdp@FreeBSD.org>2000-02-13 23:16:52 +0000
committerJohn Polstra <jdp@FreeBSD.org>2000-02-13 23:16:52 +0000
commit61db71a1984a9316fc349de34180eac6b5405a00 (patch)
treeda514b97ed4ecfde16c25cea89ae275418f15290 /lang/pm3-base
parentea24708b74539fd3cf34c4454c1f730a25adf362 (diff)
downloadports-61db71a1984a9316fc349de34180eac6b5405a00.tar.gz
ports-61db71a1984a9316fc349de34180eac6b5405a00.zip
Use my FreeBSD.org address in the MAINTAINER line. Spell freebsd
as "FreeBSD". Check for a conflicting Modula-3 port before installing. Install the copyright notice into a different place.
Notes
Notes: svn path=/head/; revision=25785
Diffstat (limited to 'lang/pm3-base')
-rw-r--r--lang/pm3-base/Makefile13
-rw-r--r--lang/pm3-base/pkg-plist4
-rw-r--r--lang/pm3-base/scripts/check_conflicts18
3 files changed, 28 insertions, 7 deletions
diff --git a/lang/pm3-base/Makefile b/lang/pm3-base/Makefile
index a04e01932bfb..3fbd10e2c435 100644
--- a/lang/pm3-base/Makefile
+++ b/lang/pm3-base/Makefile
@@ -1,18 +1,18 @@
# New ports collection makefile for: pm3-base
# Version required: 1.1.13
# Date created: 6 Feb 2000
-# Whom: John Polstra <jdp@freebsd.org>
+# Whom: John Polstra <jdp@FreeBSD.org>
#
# $FreeBSD$
#
DISTNAME= pm3-base-${VERSION}
CATEGORIES= lang
-MASTER_SITES= http://www.freebsd.org/~jdp/distfiles/pm3/
+MASTER_SITES= http://www.FreeBSD.org/~jdp/distfiles/pm3/
DISTFILES= ${BOOTSTRAP} \
pm3-${VERSION}-src.tar.bz2
-MAINTAINER= jdp@polstra.com
+MAINTAINER= jdp@FreeBSD.org
DIST_SUBDIR= pm3
INSTALL_TARGET= all
@@ -82,13 +82,16 @@ do-build:
@${ECHO_MSG} "This port does everything in the install step."
@${ECHO_MSG} "The build step is a no-op."
+pre-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/check_conflicts
+
do-install:
@${RM} -rf ${WRKSRC}/${TARGET}
@(ulimit -d `ulimit -Hd` && ulimit -m `ulimit -Hm` && \
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
@for i in ${PROGS}; do strip ${PREFIX}/$$i; done
- @${MKDIR} ${PREFIX}/share/pm3
- @${INSTALL_DATA} ${WRKSRC}/src/COPYRIGHT ${PREFIX}/share/pm3
+ @${MKDIR} ${PREFIX}/share/pm3-base
+ @${INSTALL_DATA} ${WRKSRC}/src/COPYRIGHT ${PREFIX}/share/pm3-base
.include <bsd.port.post.mk>
diff --git a/lang/pm3-base/pkg-plist b/lang/pm3-base/pkg-plist
index 2d4be8147189..f671356fc4e2 100644
--- a/lang/pm3-base/pkg-plist
+++ b/lang/pm3-base/pkg-plist
@@ -903,8 +903,8 @@ lib/m3/pkg/tempfiles/%%TARGET%%/libTempFiles.a
lib/m3/pkg/tempfiles/%%TARGET%%/libTempFiles.m3x
lib/m3/pkg/tempfiles/%%TARGET%%/libTempFiles.so
lib/m3/pkg/tempfiles/src/TempFiles.i3
-share/pm3/COPYRIGHT
-@dirrm share/pm3
+share/pm3-base/COPYRIGHT
+@dirrm share/pm3-base
@dirrm lib/m3/pkg/tempfiles/src
@dirrm lib/m3/pkg/tempfiles/%%TARGET%%
@dirrm lib/m3/pkg/tempfiles
diff --git a/lang/pm3-base/scripts/check_conflicts b/lang/pm3-base/scripts/check_conflicts
new file mode 100644
index 000000000000..9b417494a187
--- /dev/null
+++ b/lang/pm3-base/scripts/check_conflicts
@@ -0,0 +1,18 @@
+#! /bin/sh
+#
+# check_conflicts - Checks for an SRC modula-3-lib port
+# installed into the same PREFIX.
+
+portnames=$(pkg_info -aI | sed -n -e '/^modula-3-/s/[ ].*$//p')
+for port in ${portnames}; do
+ prefixes=$(pkg_info -p ${port} |\
+ sed -n -e 's/^[ ]*CWD to \([^ ]*\).*$/\1/p')
+ for prefix in ${prefixes}; do
+ if [ X${prefix} = X${PREFIX} ]; then
+ echo "This port conflicts with your installed \"${port}\" port."
+ echo "Please remove \"${port}\" before continuing."
+ exit 1;
+ fi
+ done
+done
+exit 0