aboutsummaryrefslogtreecommitdiff
path: root/lang/py-compiler
diff options
context:
space:
mode:
authorJohann Visagie <wjv@FreeBSD.org>2001-09-06 14:15:37 +0000
committerJohann Visagie <wjv@FreeBSD.org>2001-09-06 14:15:37 +0000
commitad6b729c660de06984c1d2759a630ee09f9e052f (patch)
treed264a13184bb7f61fc1d761b5b6cf65ee6bd55f9 /lang/py-compiler
parent5e820e6321892360f643cc4668ed14ea4971ce8e (diff)
downloadports-ad6b729c660de06984c1d2759a630ee09f9e052f.tar.gz
ports-ad6b729c660de06984c1d2759a630ee09f9e052f.zip
Add py-compiler, a Python source to bytecode compiler.
Notes
Notes: svn path=/head/; revision=47473
Diffstat (limited to 'lang/py-compiler')
-rw-r--r--lang/py-compiler/Makefile33
-rw-r--r--lang/py-compiler/distinfo2
-rw-r--r--lang/py-compiler/files/setup.py29
-rw-r--r--lang/py-compiler/pkg-comment1
-rw-r--r--lang/py-compiler/pkg-descr8
-rw-r--r--lang/py-compiler/pkg-plist34
6 files changed, 107 insertions, 0 deletions
diff --git a/lang/py-compiler/Makefile b/lang/py-compiler/Makefile
new file mode 100644
index 000000000000..98ceefa97d4c
--- /dev/null
+++ b/lang/py-compiler/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: py-compiler
+# Date created: 6 September 2001
+# Whom: Johann Visagie <wjv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+# XXX The compiler package is included in Python 2.1 upwards.
+# This port somehow needs to take this into account.
+
+PORTNAME= compiler
+PORTVERSION= ${PYTHON_PORTVERSION}
+CATEGORIES= lang python
+MASTER_SITES= http://www.python.org/ftp/python/${PORTVERSION}/ \
+ http://SunSITE.Informatik.RWTH-Aachen.DE/python/ftp/python/${PORTVERSION}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTFILES= ${PYTHON_DISTFILE}
+
+MAINTAINER= wjv@FreeBSD.org
+
+BUILD_DEPENDS= ${PYDISTUTILS}
+
+DIST_SUBDIR= python
+USE_PYTHON= yes
+WRKSRC= ${PYTHON_WRKSRC}/Tools/${PORTNAME}
+
+do-build:
+ @ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py build
+
+do-install:
+ @ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} \
+ setup.py install -c -O1 --prefix=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/lang/py-compiler/distinfo b/lang/py-compiler/distinfo
new file mode 100644
index 000000000000..963842afdc2c
--- /dev/null
+++ b/lang/py-compiler/distinfo
@@ -0,0 +1,2 @@
+MD5 (python/Python-2.1.tgz) = 2ba2baeccd6100a4be80e6368a975054
+MD5 (python/Python-2.1.1.tgz) = eb34371c49b271abc74b42572883e1b4
diff --git a/lang/py-compiler/files/setup.py b/lang/py-compiler/files/setup.py
new file mode 100644
index 000000000000..402918ee225c
--- /dev/null
+++ b/lang/py-compiler/files/setup.py
@@ -0,0 +1,29 @@
+#!/usr/bin/env python
+# To use:
+# python setup.py install
+#
+
+__version__ = "$FreeBSD: /tmp/pcvs/ports/lang/py-compiler/files/Attic/setup.py,v 1.1 2001-09-06 14:15:37 wjv Exp $"
+
+try:
+ import distutils
+ from distutils import sysconfig
+ from distutils.command.install import install
+ from distutils.core import setup, Extension
+except:
+ raise SystemExit, "Distutils problem"
+
+prefix = sysconfig.PREFIX
+inc_dirs = [prefix + "/include"]
+lib_dirs = [prefix + "/lib"]
+libs = ["expat"]
+
+setup(name = "pyexpat",
+ description = "Interface to the Expat XML parser",
+
+ ext_modules = [Extension("pyexpat", ["pyexpat.c"],
+ include_dirs = inc_dirs,
+ define_macros = [("HAVE_EXPAT_H", 1)],
+ libraries = libs,
+ library_dirs = lib_dirs)]
+ )
diff --git a/lang/py-compiler/pkg-comment b/lang/py-compiler/pkg-comment
new file mode 100644
index 000000000000..ecbaef7f73c2
--- /dev/null
+++ b/lang/py-compiler/pkg-comment
@@ -0,0 +1 @@
+A Python source to bytecode compiler
diff --git a/lang/py-compiler/pkg-descr b/lang/py-compiler/pkg-descr
new file mode 100644
index 000000000000..372fe29dbd12
--- /dev/null
+++ b/lang/py-compiler/pkg-descr
@@ -0,0 +1,8 @@
+A Python source to bytecode compiler written in Python, including an
+interface for manipulating abstract syntax trees.
+
+Still under development.
+
+Author: Jeremy Hylton <jeremy@beopen.com>
+
+-- Johann Visagie <wjv@FreeBSD.org>
diff --git a/lang/py-compiler/pkg-plist b/lang/py-compiler/pkg-plist
new file mode 100644
index 000000000000..1926f48368b6
--- /dev/null
+++ b/lang/py-compiler/pkg-plist
@@ -0,0 +1,34 @@
+lib/%%PYTHON_VERSION%%/site-packages/compiler/__init__.py
+lib/%%PYTHON_VERSION%%/site-packages/compiler/__init__.pyc
+lib/%%PYTHON_VERSION%%/site-packages/compiler/__init__.pyo
+lib/%%PYTHON_VERSION%%/site-packages/compiler/ast.py
+lib/%%PYTHON_VERSION%%/site-packages/compiler/ast.pyc
+lib/%%PYTHON_VERSION%%/site-packages/compiler/ast.pyo
+lib/%%PYTHON_VERSION%%/site-packages/compiler/astgen.py
+lib/%%PYTHON_VERSION%%/site-packages/compiler/astgen.pyc
+lib/%%PYTHON_VERSION%%/site-packages/compiler/astgen.pyo
+lib/%%PYTHON_VERSION%%/site-packages/compiler/consts.py
+lib/%%PYTHON_VERSION%%/site-packages/compiler/consts.pyc
+lib/%%PYTHON_VERSION%%/site-packages/compiler/consts.pyo
+lib/%%PYTHON_VERSION%%/site-packages/compiler/future.py
+lib/%%PYTHON_VERSION%%/site-packages/compiler/future.pyc
+lib/%%PYTHON_VERSION%%/site-packages/compiler/future.pyo
+lib/%%PYTHON_VERSION%%/site-packages/compiler/misc.py
+lib/%%PYTHON_VERSION%%/site-packages/compiler/misc.pyc
+lib/%%PYTHON_VERSION%%/site-packages/compiler/misc.pyo
+lib/%%PYTHON_VERSION%%/site-packages/compiler/pyassem.py
+lib/%%PYTHON_VERSION%%/site-packages/compiler/pyassem.pyc
+lib/%%PYTHON_VERSION%%/site-packages/compiler/pyassem.pyo
+lib/%%PYTHON_VERSION%%/site-packages/compiler/pycodegen.py
+lib/%%PYTHON_VERSION%%/site-packages/compiler/pycodegen.pyc
+lib/%%PYTHON_VERSION%%/site-packages/compiler/pycodegen.pyo
+lib/%%PYTHON_VERSION%%/site-packages/compiler/symbols.py
+lib/%%PYTHON_VERSION%%/site-packages/compiler/symbols.pyc
+lib/%%PYTHON_VERSION%%/site-packages/compiler/symbols.pyo
+lib/%%PYTHON_VERSION%%/site-packages/compiler/transformer.py
+lib/%%PYTHON_VERSION%%/site-packages/compiler/transformer.pyc
+lib/%%PYTHON_VERSION%%/site-packages/compiler/transformer.pyo
+lib/%%PYTHON_VERSION%%/site-packages/compiler/visitor.py
+lib/%%PYTHON_VERSION%%/site-packages/compiler/visitor.pyc
+lib/%%PYTHON_VERSION%%/site-packages/compiler/visitor.pyo
+@dirrm lib/%%PYTHON_VERSION%%/site-packages/compiler