aboutsummaryrefslogtreecommitdiff
path: root/lang/python+ipv6
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1998-07-23 07:49:12 +0000
committerThomas Gellekum <tg@FreeBSD.org>1998-07-23 07:49:12 +0000
commited9f74ade1151d8dd5b732b1476a26f7f2c95ed5 (patch)
treec384364b2e807ec4a68642b29d6eba5206a4a742 /lang/python+ipv6
parent4c6cadfcbb498f166a44c389017e8944cf43c13a (diff)
downloadports-ed9f74ade1151d8dd5b732b1476a26f7f2c95ed5.tar.gz
ports-ed9f74ade1151d8dd5b732b1476a26f7f2c95ed5.zip
Use ldconfig to check for libc_r, not an absolute path. Thread support
should now be compiled in on -current. Suggested by: Jacques Vidrine
Notes
Notes: svn path=/head/; revision=12071
Diffstat (limited to 'lang/python+ipv6')
-rw-r--r--lang/python+ipv6/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/python+ipv6/Makefile b/lang/python+ipv6/Makefile
index b7fbb39338b3..ac388ca91a9e 100644
--- a/lang/python+ipv6/Makefile
+++ b/lang/python+ipv6/Makefile
@@ -3,7 +3,7 @@
# Date created: 08 August 1995
# Whom: jkh
#
-# $Id: Makefile,v 1.34 1998/06/19 09:00:49 tg Exp $
+# $Id: Makefile,v 1.35 1998/06/25 06:43:26 tg Exp $
#
DISTNAME= pyth151
@@ -56,7 +56,8 @@ SETUP_LOCAL= Setup.tk
# This option is enabled by default.
#
WITH_THREADS?= yes
-.if exists(/usr/lib/libc_r.a) && defined(WITH_THREADS) && ${WITH_THREADS} == yes
+LIBC_R!= /sbin/ldconfig -r | grep c_r
+.if ${LIBC_R} != "" && defined(WITH_THREADS) && ${WITH_THREADS} == yes
CONFIGURE_ARGS+= --with-thread
CFLAGS+= -D_THREAD_SAFE
CONFIGURE_ENV= LDFLAGS="-pthread ${LDFLAGS}"