aboutsummaryrefslogtreecommitdiff
path: root/lang/python+ipv6
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2001-04-03 17:34:57 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2001-04-03 17:34:57 +0000
commit757a81331fbcd347cc0c022079c7b46ce6e01127 (patch)
tree4892145b9ad90055fdff4a1729556445c5df4af2 /lang/python+ipv6
parentba4e0df55b3347e0d44175a5552487f75ea9440f (diff)
downloadports-757a81331fbcd347cc0c022079c7b46ce6e01127.tar.gz
ports-757a81331fbcd347cc0c022079c7b46ce6e01127.zip
Sync with lang/python15.
Submitted by: knu
Notes
Notes: svn path=/head/; revision=40814
Diffstat (limited to 'lang/python+ipv6')
-rw-r--r--lang/python+ipv6/Makefile47
1 files changed, 29 insertions, 18 deletions
diff --git a/lang/python+ipv6/Makefile b/lang/python+ipv6/Makefile
index 517ca80b00bf..2218f6397b7b 100644
--- a/lang/python+ipv6/Makefile
+++ b/lang/python+ipv6/Makefile
@@ -5,44 +5,48 @@
# $FreeBSD$
#
-PORTNAME= python+ipv6
+PORTNAME= python
PORTVERSION= 1.5.2
+PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= ftp://www.python.org/pub/python/src/ \
ftp://ftp.cwi.nl/pub/python/src/
-DISTNAME= py152
-EXTRACT_SUFX= .tgz
+PKGNAMESUFFIX= +ipv6
+DISTFILES= ${PYTHON_DISTFILE}
PATCH_SITES= ftp://ftp.kame.net/pub/kame/misc/
-PATCHFILES= python-152-v6-20000120.diff.gz
+PATCHFILES= ${PORTNAME}-${PORTVERSION:S/.//g}-v6-20000120.diff.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= sumikawa@FreeBSD.org
DIST_SUBDIR= python
-WRKSRC= ${WRKDIR}/Python-1.5.2
+WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-fpectl --with-libs='-lxpg4'
+CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
INSTALL_TARGET= install
PLIST= ${WRKDIR}/PLIST
MAN1= python.1
+USE_PYTHON= yes
+PYTHON_VERSION= python1.5
+PYTHON_NO_DEPENDS= yes
+
#
# The standard setup file
#
SETUP_FILE= Setup
#
-# If you want to use Python's thread module, you need to set WITH_THREADS
-# to 'yes', and you must have the FreeBSD threading c library (libc_r)
-# installed. See 'man 3 pthread' for details on libc_r.
-#
-# This option is enabled by default.
+# If you don't want to use Python's thread module, you need to set
+# WITHOUT_THREADS. libc_r should be installed on nowadays' systems.
#
LIBC_R!= /sbin/ldconfig -r | grep c_r || true
-.if (${LIBC_R} != "") && !defined(WITHOUT_THREADS)
-CONFIGURE_ARGS+= --with-thread
+.if (${LIBC_R} == "") || defined(WITHOUT_THREADS)
+CONFIGURE_ARGS+= --without-threads
+.else
+CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
.endif
@@ -57,7 +61,7 @@ PLIST_GMP= ${PKGDIR}/pkg-plist.gmp
#
# Install the Tools by default. It contains scripts ranging from an IDE
-# to a web tree checker, to a collection of simple scripts that are useful
+# to a web tree checker, to a collectioln of simple scripts that are useful
# while extending or managing Python.
#
.if !defined(WITHOUT_TOOLS)
@@ -83,6 +87,13 @@ CONFIGURE_ARGS+=--enable-ipv6
CONFIGURE_ARGS+=--disable-ipv6
.endif
+.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
+CONFIGURE_ARGS+= --with-libs='-lxpg4'
+.endif
+.if ${OSVERSION} < 400020
+CONFIGURE_ARGS+= --with-libs='-lxpg4'
+.endif
+
.if ${OSVERSION} >= 500000
PLATFORMS=plat-freebsd2 plat-freebsd3 plat-freebsd4
.elif ${OSVERSION} >= 400000
@@ -95,9 +106,9 @@ PLATFORMS=plat-freebsd3 plat-freebsd4 plat-freebsd5
pre-install:
.for platform in ${PLATFORMS}
- ${MKDIR} ${PREFIX}/lib/python1.5/${platform}
+ ${MKDIR} ${PYTHON_LIBDIR}/${platform}
${INSTALL_DATA} ${WRKSRC}/Lib/${platform}/* \
- ${PREFIX}/lib/python1.5/${platform}/
+ ${PYTHON_LIBDIR}/${platform}/
.endfor
@sort -r -o ${PLIST} ${PLIST_GMP} ${PLIST_TOOLS} ${PLIST_V6} ${PKGDIR}/pkg-plist
@@ -108,10 +119,10 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/Misc/python-mode.el ${PREFIX}/share/emacs/site-lisp
${INSTALL_DATA} ${WRKSRC}/Misc/COPYRIGHT ${PREFIX}/share/doc/python
${INSTALL_DATA} ${WRKSRC}/README.v6 ${PREFIX}/share/doc/python
- @${MKDIR} ${PREFIX}/lib/python1.5/site-packages
+ @${MKDIR} ${PYTHON_SITELIBDIR}
.if !defined(WITHOUT_TOOLS)
@cd ${WRKSRC}; tar cf - Tools | \
- (cd ${PREFIX}/lib/python1.5; tar xf -)
+ (cd ${PYTHON_LIBDIR}; tar xf -)
.endif
.include <bsd.port.post.mk>